amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Linux und WLAN

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Linux und WLAN

Beitragvon aspettl » 15.11.2004 17:23

Hallo

Ich habe bei mir SuSE Linux 9.0, habe aber auch die aktuelle Debian und Mandrake-Version. Hat schon einmal jemand von euch die "Intel Pro/Wireless 2200 GB" unter Linux zum Laufen gebracht?
Danke für Antworten!

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon Anonymous » 15.11.2004 17:43

Zum laufen gebracht ist der falsche Ausdruck. Die Karte is bei mir in meinem Notebook eingebaut und mit den ipw2200 Treibern entwickelt als OpenSource von Intel selbst nativ für Linux unter ipw2200.sourceforge.net ist da betreiben dieser Karte kein Problem. Die Treiber befinden sich zwar noch in Entwicklung mir persönlich geht dabei aber nichts ab.
AFAIK werden die Treiber auch in den Kernel einfließen sobald sie einen stable Status erreicht haben könnte allerdings sein, dass es durch diverse Auflagen von Seiten der benötigten Firmware nicht möglich ist diese in den Kernel zu integrieren aber hoffen wir das beste.
Meiner Meinung nach sind die ipw Karten derzeit für Linux die geeignetsten.
Anonymous
 

Linux-WLAN-Treiber für 2200 GB

Beitragvon aspettl » 15.11.2004 17:58

Hi tezem

Danke für die schnelle Antwort! Ich werde den Treiber auch mal herunterladen und testen, ich schreib dann was daraus geworden ist :-).
So wie ich das gerade sehe, muss ich erst noch den Kernel 2.6.4 oder höher irgendwie draufkriegen. (Ich habe noch nie einen anderen Kernel in Linux installiert, das kann also dauern...)

Gruß
Aaron

EDIT: Mandrake hat gerade die neue Version 10.1 herausgebracht, ich lade erst diese herunter (mit Kernel 2.6.8) und teste es dann. Zum Glück habe ich hier ein Uni-Netz.
Zuletzt geändert von aspettl am 15.11.2004 19:01, insgesamt 1-mal geändert.
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon Anonymous » 15.11.2004 18:58

Du brauchst nicht unbedingt deinen eigenen Kernel kompilieren. Du kannst auch einfach einen Standard Kernel von deiner Distribution installieren über dein Paketmanagment und dann für diesen Kernel die ipw Treiber kompilieren.
Weiß zwar nicht wie das bei solchen Distris läuft aber meines Wissens kann man sich schon bereits fertige Kernel runterladen und installieren über das Paketmanagment der Distri.

Zum Thema Kernel kompilieren kann ich nur sagen, dass man sich damit beschäftigen sollte jedoch muss man damit rechnen, dass man speziell als Anfanger in diesem Gebiet kaum einen lauffähigen Kernel bauen wird wenn man mordsmäßig in der Config des Kernels herumpfuscht deshalb ist das A und O bei diesen Versuchen immer eine möglichkeit zu haben einen "alten" funktionierenden Kernel booten zu können um im notfall ein bootbares Linux zu haben um alles wieder zu richten.
Allgemein kann man jedoch sagen, dass sich das eigenständige Kernelkompilieren sehr wohl lohnt da man zum einen einen wesentlich schlankeren Kernel bekommt und zum anderen individuelle Einstellungen vornehmen kann die speziell bei Laptops zum Teil sehr wichtig sein können.
Anonymous
 

Beitragvon aspettl » 15.11.2004 19:06

Hallo tezem

Danke nochmals für die schnellen Antworten. Einen Kernel will ich auch nicht selbst kompilieren, mir hat das Update in SuSE Linux 9.0 von KDE 3.1 auf KDE 3.3 schon Stunden Arbeit beschert - aber so lernt man halt...
Optimal wäre wahrscheinlich SuSE Linux 9.2, aber das kann man leider nicht herunterladen. So probiere ich mal Mandrake 10.1, dann erspare ich mir den Wechsel des Kernels in SuSE 9.0 (ich weiß nicht, ob es für diese Version einen abgestimmten 2.6.4+ Kernel gibt).

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Probleme mit ipw2200

Beitragvon aspettl » 18.11.2004 12:47

Hallo

Jetzt habe ich SuSE Linux 9.1 Personal. Da will ich testen, ob es geht (Kernel 2.6.5 nach Online-Update - das reicht :-) ).
Hast du den Treiber schon mal installiert? Ich komme nämlich nicht ganz klar damit, was ich machen muss. Und ist es normal, dass in der Personal-Version der Befehl "make" nicht vorhanden ist?

Gruß
Aaron

EDIT: "make" habe ich mir jetzt mit einigen anderen Sachen als rpm von der SuSE-Website geholt. War doch tatsächlich nicht dabei. Morgen muss ich's noch mal probieren.
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon Anonymous » 26.11.2004 17:15

also das installieren funktioniert an sich so, dass du das tar Archiv von der sourceforge Seite runterlädst es entpackst in das Verzeichnis wechselst nach dem entpacken und dort dann 'make' ausführst. Damit kompiliert er alles nötige und danach brauchst nur mehr als root 'make install' ausführen. Dadurch hast es installiert. Funktionieren tuts dann aber noch nicht du must die Lizenzen und das Modul laden.
In den neuen Versionen werden die Lizenzen gleichzeitig mit dem Modul geladen du musst also nur die Lizenzen runterladen von http://ipw2200.sf.net/firmware.php und diese wiederum entpacken und im Normalfall nach /usr/lib/hotplug/firmware/ kopieren. Ob das auch der Pfad für dich ist kannst in /etc/hotplug/firmware.agent erfahren.
Das Modul lässt sich natürlich auch händisch laden mit 'modprobe ipw2200'.
Anonymous
 

Beitragvon nodh » 26.11.2004 23:48

Jap, "make" kann man mit einer Standard-SUSE-Installation nicht ausführen. Am besten die "Entwicklungstools" oder wie das heißt im YaST installieren, danach solltest du was mit make kompilieren können.
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630

Beitragvon aspettl » 27.11.2004 16:06

Ja, danke für die Antworten :-) Muss ich dann morgen mal probieren, heute hab ich noch anderes zu tun, und wenn man einmal anfängt...

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

WLAN unter Linux erfolgreich

Beitragvon aspettl » 28.11.2004 10:04

Hallo nochmals

Ich habe es jetzt nochmal probiert: Erfolg! :D
Diesmal kennt er make und auch alles andere, d.h. nicht massig Fehler beim Aufruf. Testen kann ich die WLAN-Funktionalität aber noch nicht, hier gibts gerade keins. Aber der Treiber wird nun auf jeden Fall (ohne Fehler) geladen.

Gruß und Danke
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon aspettl » 30.11.2004 20:27

Hallo schon wieder!

Der Treiber läuft nun tatsächlich. Im Uni-WLAN-Netz findet er den jeweiligen Access-Point. Aber irgendwie bekomme ich glaube ich keine IP zugewiesen (kann das sein?) Auf jeden Fall steht im KWifiManager keine und auch sonst kann ich keine finden, auch alle Sachen (Internet usw.) funktionieren nicht. Weiß da jemand einen Trick oder sonst irgendetwas, was man noch machen muss?

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon nodh » 30.11.2004 21:43

Vielleicht musst du dir mit "dhcpcd <Device>" eine IP holen. Also zB dhcpcd eth0 oder dhcpcd wlan0.
Mit "ifconfig -a" müsstest du dein WLAN-Device angezeigt bekommen.
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630

Beitragvon aspettl » 30.11.2004 21:49

Hi

Danke für den Tipp, das probier ich morgen doch gleich aus :-)

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon aspettl » 01.12.2004 20:47

Hallo

Die IP habe ich so trotz einer komischen Meldung zugewiesen bekommen, ebenso wie DNS, Gateway etc. Trotzdem funktioniert es immer noch nicht, sogar der Ping an den DNS-Server schlägt fehl.

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon nodh » 02.12.2004 16:38

"komische Meldung"? Posten, alles kann nützlich sein ;)
Was auffälliges in den Systemlogs? "/var/log/messages" oder "dmesg"?
SUSE-Firewall aus?
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630

Nächste

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron