amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

ACPI Problem Amilo D 7800

Alle Probleme mit Windows oder Windows-Treibern.

ACPI Problem Amilo D 7800

Beitragvon biergary » 03.10.2006 18:55

Hallo liebe Forumuser,
ich habe ein Problem mit dem Firewire/ACPI meines Notebooks. Bei mir werden nur IRQs bis 11 vergeben, d.h heißt Grafikkarte, Firewire, PCMCIA Slots und USB teilen sich EINEN IRQ (11). Ist das bei euren Modellen auch so? Muss ich noch etwas installieren? Die Performance meiner Firewire Device (Soundkarte) ist sehr schlecht. Je mehr ich jedoch vom IRQ 11 abstelle, desto besser wird alles. Nur leider kann ich die Grafik als auch das USB nicht abschalten.


Vielen Dank

Christian
Dateianhänge
1.bmp
Anzeige der Geräte nach IRQ - normal?
(843.8 KiB) 167-mal heruntergeladen
biergary
 
Beiträge: 4
Registriert: 03.10.2006 18:41

Beitragvon petschbot » 04.10.2006 10:55

Bei mir teilen sich WLAN/LAN/USB/Firewire einen Port:
Dateianhänge
gm.jpg
Mein Amilo-Blog:
http://7440g.blogspot.com
Benutzeravatar
petschbot
 
Beiträge: 1086
Registriert: 15.07.2005 17:01
Notebook:
  • M 7440G
  • Palm Zire 31
  • Lintec Desktop
  • FSC Desktop "Trend"

Beitragvon biergary » 04.10.2006 11:35

Aha - und hast du auch Probleme mit der Performance oder ist da bei dir alles ok?
biergary
 
Beiträge: 4
Registriert: 03.10.2006 18:41

Beitragvon petschbot » 04.10.2006 13:18

Eigetlich keine Probleme. Allerdings hängt bei mir auch nicht die GraKa am selben IRQ.

Ich hätte ja gesagt, man kann über Harewareprofile natürlich das eine oder andere Ausknipsen, aber ich bezweifele ob das bei die soviel Sinn macht. Früher, also unter Windows 95/98, konnte man die IRQ-Vergabe noch im Gerätemanager beeinflussen (Wenn das Gerät es anbot, als den Soundblaster z.B. von IRQ 5 auf IRQ 7 ummappen). Alternativ konnte man auch noch im BIOS die IRQs für bestimmte Motherboard-Komponeten vergeben. Die Möglichkeiten gibt es heute nicht mehr.
Mein Amilo-Blog:
http://7440g.blogspot.com
Benutzeravatar
petschbot
 
Beiträge: 1086
Registriert: 15.07.2005 17:01
Notebook:
  • M 7440G
  • Palm Zire 31
  • Lintec Desktop
  • FSC Desktop "Trend"

Beitragvon biergary » 04.10.2006 19:13

petschbot hat geschrieben:Eigetlich keine Probleme. Allerdings hängt bei mir auch nicht die GraKa am selben IRQ.

Ich hätte ja gesagt, man kann über Harewareprofile natürlich das eine oder andere Ausknipsen, aber ich bezweifele ob das bei die soviel Sinn macht. Früher, also unter Windows 95/98, konnte man die IRQ-Vergabe noch im Gerätemanager beeinflussen (Wenn das Gerät es anbot, als den Soundblaster z.B. von IRQ 5 auf IRQ 7 ummappen). Alternativ konnte man auch noch im BIOS die IRQs für bestimmte Motherboard-Komponeten vergeben. Die Möglichkeiten gibt es heute nicht mehr.


Ja, dass das früher ging weiß ich auch noch. Ich habe auch versucht das unter Windows XP hinzubekommen. Aber vor dem jetzigen Hintergrund ist doch das Noti voll der KOnstruktionsfehler oder? Ich meine Man muss doch die Komponenten im vollen Umfang nutzen können die onboard verbaut sind?
biergary
 
Beiträge: 4
Registriert: 03.10.2006 18:41

Beitragvon petschbot » 05.10.2006 09:51

Ich glaube weniger, dass hier ein Hardware-Problem vorliegt, ich zitiere mal kurz aus Wikipedia zum Thema IRQ:

Bei modernen Systemen (zum Beispiel PCI-Systemen) ist das sogenannte Interrupt-Sharing in der Regel ohne Probleme möglich. Dabei teilen sich mehrere Geräte einen Interrupt. Die Behandlungsroutine für einen solchen Interrupt muss dann alle Treiber, deren Geräte diesen Interrupt ausgelöst haben könnten, aufrufen (am IRQ kann dies nicht festgestellt werden). Hier kann es zu Problemen kommen, wenn einzelne Treiber z. B. aufgrund schlechter Programmierung zu lange aktiv sind, und in der Zwischenzeit im Gerät, welches den Interrupt ursprünglich ausgelöst hat, beispielsweise der Puffer voll wird und überläuft (d. h. im schlimmsten Fall: Datenverlust).

Bei modernen Peripheriegeräten kümmern sich der Computer und das Betriebssystem selbst um die Vergabe der IRQ-Nummern (PnP = Plug-and-Play-Geräte). Bei alten Steckkarten, z. B. ISA-Karten, müssen die IRQs von Hand eingestellt werden oder sind fest auf den Karten verdrahtet.


Mir wäre es auch nicht bekannt, dass moderne Hardware noch IRQ-Probleme verursacht, dass ist eher ein 1990er-Ding. Hast du vielleicht irgendwo einen zu aktuellen (Beta-)Treiber installiert, z.B. für die GraKa?[/b]
Mein Amilo-Blog:
http://7440g.blogspot.com
Benutzeravatar
petschbot
 
Beiträge: 1086
Registriert: 15.07.2005 17:01
Notebook:
  • M 7440G
  • Palm Zire 31
  • Lintec Desktop
  • FSC Desktop "Trend"

Beitragvon biergary » 05.10.2006 10:16

Naja ich habe die aktuellsten Treiber von der Fujitsu-Siemens Website benutzt. Ich kann mir nicht vorstellen wo das Problem liegen soll.
biergary
 
Beiträge: 4
Registriert: 03.10.2006 18:41


Zurück zu Windows

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste