amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Linux + Windows, mit lilo oder grub

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Linux + Windows, mit lilo oder grub

Beitragvon Luigi. » 22.11.2006 18:09

Hallo Leute ich bin noch ein sehr Linux Unerfahrener und will das die beiden Systeme auf dem Rechner laufen.

Ich möchte das linux über den bootmanager von Windows starten.

zur Konfiguration: ich habe Linux als Live CD mit der Auditor-Collection, das gab es einen HD-Installer und darüber habe ich es auf dem Rechner installiert, hab alles geklappt, und den Boot -manager in den MBR geschrieben, da mir die Oberfläche(des MBR-Bootmanager) nicht gefiel hab ich es noch mal deinstalliert und noch mal von der Live-CD installiert, und den Bootmanger (grub) auf Diskette verbannt, funktioniert auch, nur stört mich immer das einlegen der Diskette um Linux zu booten.

Ich habe zwar Anleitungen gefunden das und wie man den lilo Manager installieren, verändern kann, doch da scheitert es schon daran, das ich den lilo Manger gar nicht erst aktivieren kann, ist wahrscheinlich nicht bei der Live-Cd dabei gewesen.
Nun hab ich auch die lilo-22.7.3.bin.tar.gz gesaugt und weiß garnicht wie ich sie installieren soll( die Befehle weiss ich nicht) oder ob ich nur die Ordner irgend wohin kopieren muss, oder wie das überhaupt geht.

Wie gesagt mein Grundanliegen, ist dass ich Windows und Linux über den Windows -Boot Manager auswählen möchte.
auf der Diskette habe ich den "grub" LADER als Startdiskette, diesen Ordner BOOT und deren Unterordner habe ich schon auf C: kopiert und in der Boot.ini von windows veruscht alle darin befindlichen Dateine zu verlinken, aber leider macht der winxp-Loader, dann nicht das was er soll, bei der Auswahl der Zeile.

Vielleich kann mir jemand helfen.

Wenn ihr antwortet, dann bitte mit den (falls erforderlich) genauen befehlszeilen.
aus sicht von linux: windows befindet sich auf: hda1 und linux auf: had2

Danke schon mal falls sich einer die Mühe macht zu antworten.
Amilo Xi 1554 2,0GHz; 2GB RAM PC2-5300; Windows 7
Amilo 1667EX 2,6GHz; 2GB RAM PC-3200 (200MHz CL2) Windows 7
Luigi.
 
Beiträge: 278
Registriert: 01.12.2005 16:14
Wohnort: Dresden

Beitragvon Luigi. » 22.11.2006 18:32

hat keiner ne lösung?
Amilo Xi 1554 2,0GHz; 2GB RAM PC2-5300; Windows 7
Amilo 1667EX 2,6GHz; 2GB RAM PC-3200 (200MHz CL2) Windows 7
Luigi.
 
Beiträge: 278
Registriert: 01.12.2005 16:14
Wohnort: Dresden

Beitragvon petschbot » 22.11.2006 19:32

Mein Amilo-Blog:
http://7440g.blogspot.com
Benutzeravatar
petschbot
 
Beiträge: 1086
Registriert: 15.07.2005 17:01
Notebook:
  • M 7440G
  • Palm Zire 31
  • Lintec Desktop
  • FSC Desktop "Trend"

Beitragvon Luigi. » 22.11.2006 19:57

.. jo, das klingt wie die anderen Anleitungen, werd das noch mal versuchen, vielleicht hängt das auch damit zusammen, das ich meinstens nicht als root eingeloggt war....

Bericht wird morgen erfolgen..
Amilo Xi 1554 2,0GHz; 2GB RAM PC2-5300; Windows 7
Amilo 1667EX 2,6GHz; 2GB RAM PC-3200 (200MHz CL2) Windows 7
Luigi.
 
Beiträge: 278
Registriert: 01.12.2005 16:14
Wohnort: Dresden

Beitragvon petschbot » 22.11.2006 21:22

Daran wirds wohl liegen. Der betreffende Bereich sollte für den eingeschränkten Benutzer nicht zugänglich sein
Mein Amilo-Blog:
http://7440g.blogspot.com
Benutzeravatar
petschbot
 
Beiträge: 1086
Registriert: 15.07.2005 17:01
Notebook:
  • M 7440G
  • Palm Zire 31
  • Lintec Desktop
  • FSC Desktop "Trend"

Beitragvon Luigi. » 23.11.2006 12:26

hat zwar nicht gleich gewollt, aber nach ein wenig nachdenken schon

Vorgabe: dd if=/dev/sda3 of=/media/floppy/bootsek.lin bs=512 count=1
Modifizi.: dd if=/dev/hda2 of=/bootsek.lin bs=512 count=1

hda2 ist die Partition, wo mein Linux drauf ist, und folglich hat er dann es nach hda2/ gleich in die erste schicht kopiert, somit war es auch gleich zu finden.

naja und die boot.ini von Windoof mit der Zeile:

c:\bootsek.lin="Mein Linux"

zu ergänzen ist ja dann ein kinderspiel

natürlich musste die "bootsek.lin" auch noch nach c: kopiert werden.

Alles Super, und wieder wäre ein Problem gelöst.
Amilo Xi 1554 2,0GHz; 2GB RAM PC2-5300; Windows 7
Amilo 1667EX 2,6GHz; 2GB RAM PC-3200 (200MHz CL2) Windows 7
Luigi.
 
Beiträge: 278
Registriert: 01.12.2005 16:14
Wohnort: Dresden


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste