amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

3D mit Mobility Radeon x1800 unter Linux

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

3D mit Mobility Radeon x1800 unter Linux

Beitragvon Conroe » 11.06.2007 20:19

Hallo Leute!
Hab vor einiger Zeit auf meinem 1546er SuSE 10.1 installiert und dieses vor kurzem auf openSuse 10.2 geupdatet. Aber in keiner Version wollte die 3D - Beschleunigung funktionieren. Hab den ATi-Treiber installiert, dann kam eine Meldung dass irgendwas mit FireGL nicht stimmt. Nach der Installation vom FireGL-Treiber gings immer noch nicht. Könnt ihr mir helfen? Schon mal vielen Dank im Voraus.
Gruß

Conroe
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon ChaosKrieger » 11.06.2007 20:46

wenn ich mich nicht irre brauchst du den fglrx (radeon) treiber

http://ati.amd.com/support/drivers/linu ... adeon.html
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep; shutdown -r now
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon Conroe » 13.06.2007 16:48

habs ausprobiert....hat aber nicht geklappt. In der Log-Datei (s. Anhang) steht irgendeine Fehlermeldung.
Dateianhänge
fglrx-install.log
(502 Bytes) 156-mal heruntergeladen
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon ChaosKrieger » 13.06.2007 17:02

installier mal die "kernel-headers" oder "linux-headers" , wenn es dort mehrere versionen gibt, mach ein "uname -r"

die datei müsste dann heisen linux-headers-`das was bei uname -r rauskommt"
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep; shutdown -r now
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon Conroe » 16.06.2007 14:55

hab die linux-kernel-headers von der DVD installiert, dann nochmal den Treiber. Wenn man allerdings im Startmenü auf den Catalyst Center klickt, passiert gar nichts. OpenGL Anwendungen funktionieren ebenfalls immer noch nicht. Das Problem hab ich übrigens schon mit 10.2 gehabt. Irgendwas stimmt da nicht...
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon Conroe » 17.06.2007 14:44

moment...hab da so einen Verdacht. Könnte das irgendwie mit dem Ext3-Filesystem zusammenhängen? Hab bisher die Root-Partition nach Voreinstellung mit ReiserFS formatiert, jetzt in 10.2 mit Ext3. Hab außer dem Grafiktreiber noch ein Problem mit VirtualBox unter Linux. Glaubs zwar nicht so sehr, könt aber vielleicht sein. Man weiß ja nie...
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon aspettl » 17.06.2007 16:11

Nein, Grafiktreiber haben mit dem Dateisystem fast sicher nichts zu tun ;-)
("fast" nur, weil man bei Computern nie etwas 100% ausschließen kann...)

War denn die Installation diesmal erfolgreich - also was stand in der Logdatei?
Was gibt "fglrxinfo" aus?

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Lifebook E8020D

Beitragvon Conroe » 18.06.2007 19:00

hier ist die "fglrx-install.log" aus usr/share/ati.
Außerdem gab's bei der Installation noch die Meldung "loki_setup: Can't create //usr/X11R6/lib/modules/dri/fglrx_dri.so: Die Datei existiert bereits".
"fglrxinfo" gibt folgendes aus:
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.1)

Was ist "XFree86-DRI"?
Gruß

Conroe
Dateianhänge
fglrx-install.log
(502 Bytes) 123-mal heruntergeladen
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon ChaosKrieger » 18.06.2007 20:57

glxinfo bzw fglryinfo bitte nicht (!) als root ausführen..

kannst du es nochmal versuchen?

und was gibt uname -a aus?
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep; shutdown -r now
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon Conroe » 20.06.2007 15:14

also...fglrxinfo gibt wieder das aus:

Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.1)

glxinfo siehe Anhang
uname -a:
Linux amilo 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 i686 i686 i386 GNU/Linux
(alles nicht als root)
Dateianhänge
glxinfo.txt
(1.96 KiB) 150-mal heruntergeladen
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon Conroe » 26.06.2007 18:28

also...wo könnte das Problem jetzt liegen? Muss ich noch was nachinstallieren oder openSuSE ganz neu aufsetzen?
Gruß

Conroe
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon fairlane » 26.06.2007 19:28

Code: Alles auswählen
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h


Installier mal noch die Kernel Header.
Die scheinen zu fehlen, oder unvollständig zu sein.
Slackware
Slackware Linux Current, Kernel 2.6.24.12
Benutzeravatar
fairlane
 
Beiträge: 56
Registriert: 10.05.2006 12:48

Beitragvon Conroe » 10.07.2007 17:39

wo bekommt man die? Auf der DVD sind sogenannte "Linux-Kernel-Headers". Sind das die richtigen oder gibt es noch seperate Kernel-headers?
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546

Beitragvon fairlane » 11.07.2007 17:17

Glaube nicht, dass es noch andere gibt.
Hab aber kein Suse, kann dir daher in Bezug darauf nix sagen.
Slackware
Slackware Linux Current, Kernel 2.6.24.12
Benutzeravatar
fairlane
 
Beiträge: 56
Registriert: 10.05.2006 12:48

Beitragvon Conroe » 13.07.2007 15:36

Hui...
endlich, ENDLICH hab ich die 3d-Beschleunigung hinbekommen :wink: . Hab nach langem googeln diese Seite hier gefunden: http://de.opensuse.org/SDB:ATI_Treiber_ ... stallieren
Hier wird noch mal alles genau beschrieben. Wahrscheinlich lag das Problem daran, dass mir noch einige Packages gefehlt haben. Trotzdem vielen Dank für die Antworten!
Gruß
Conroe
Benutzeravatar
Conroe
 
Beiträge: 50
Registriert: 15.05.2007 16:34
Notebook:
  • Amilo Xi 1546


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste