amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

WLAN unter Kubuntu Feisty Fawn auf Amilo A1650

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

WLAN unter Kubuntu Feisty Fawn auf Amilo A1650

Beitragvon minipingu » 27.09.2007 23:16

Erstmal ein großes Danke an dieses Forum, in dem ich schon viele nützliche Tipps bekommen habe - sowohl Windows als auch Linux! Versuch seit einiger Zeit einen Komplettumstieg nach Linux...
Bei meinem jetzigen Problem wurde ich aber leider bislang nicht fündig:
Ich bekomme mein Wlan beim besten Willen unter Kubuntu auf meinem Amilo 1650 nicht zum Laufen, Ich hab schon sämtliche Anleitungen befolgt, die ich in diesem Forum und auch im Wiki zu dem Thema finden konnte...
Soweit ich Linux bislang versteh, wird wohl meine WLAN-Karte mit 'iwconfig' erkannt:
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"inach_3" Nickname:"Broadcom 4318"
Mode:Managed Frequency=2.472 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Link Quality=0/100 Signal level=-256 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Wenn ich aber 'iwlist eth1 scan' eingeb, kommt 'no scan results'...
Meine Sondertasten hab ich bislang auch nicht zum Laufen bekommen. Kann mir hier vielleicht jemand weiterhelfen?
Vielen Dank schon im Voraus!
Gruß, Wiebke
minipingu
 
Beiträge: 1
Registriert: 27.09.2007 23:01

Beitragvon TABASCO » 09.10.2007 19:37

Dein Problem dürfte mit der kommenden Version von Ubuntu / Kubuntu 7.10 (Gutsy Gibbon) gelöst werden.

In dieser ist die Firmware für die Broadcom 43xx Chips nämlich mit wenigen Klicks und einer Internetverbindung über das Management für eingeschränkte Treiber installierbar.

Du kannst die Betaversion jetzt schon testen oder auf das finale Release warten (was am 18. Oktober erscheint).

Ich habe das auf einem Amilo Pro V2030 mit einem Broadcom 4318 probiert und es funktioniert hervorragend.

In Kubuntu 7.10 soll auch der restricted manager enthalten sein, ich weiß aber nicht, wie er da funktioniert.

Im Zweifelsfalle versuch es einfach mit Ubuntu.

Viel Glück dabei :)

TABASCO
TABASCO
 
Beiträge: 4
Registriert: 09.10.2007 17:20

Beitragvon satyria » 26.10.2007 11:53

danke für den Tollen Tip, aber leider Funktioniert er nicht.

Ich hatte hier im Forum schonmal genau dieses reingestellt, allerdings ohne Erfolg.
Ich vermute einfach, dass zunächst das LAN Aktiviert werden muss, bevor man diese Treiber installiert (Unter Windows geht eine LED an). Es wird sowas sein, einen Hardwarebefehl auszusenden, den wahrscheinlich nur die Entwickler kennen,was ich sehr schade finde. Der Chipsatz wird allerdings von Linux unterstütz!

Naja, vieleicht hat es inzwischen jemand gefunden, wie es geht?

Gruß Satyria
satyria
 
Beiträge: 10
Registriert: 22.10.2005 10:21

Beitragvon anybodysgothic » 26.10.2007 12:37

@ satyria

hallo erstmal...

um dein Problem zu lösen, solltest du mal in meinen WIKI-Beitrag schauen :lol:

http://wiki.ubuntu-forum.de/index.php/W ... figuration

viel glück... :!:
OS: Ubuntu Gutsy Gibbon 7.10 32bit | Kernel: 2.6.22 | HARDWARE: Modell: Fujitsu Siemens Amilo 1650 Prozessor: AMD 3700+ 64bit 2.4 GHz RAM: 1024 MB Festplatte: 100 GB
Benutzeravatar
anybodysgothic
 
Beiträge: 12
Registriert: 09.12.2005 02:04
Notebook:
  • Fujitsu Siemens Amilo 1650

Re: WLAN unter Kubuntu Feisty Fawn auf Amilo A1650

Beitragvon satyria » 22.09.2008 08:33

@ anybodysgothic

hallo, ich weis, das es doch schon einige Zeit her ist, das dieser Tipp hier geschrieben wurde. Aber er funktioniert!!!! Tausend Dank dafür! Leider hab ich erst Heute davon gelesn, da ich keine Mitteilung bekommen habe, das hier was dazu kam.


Noch mal mein System: Amilo 1650 mit Broadcom 43xx-Chipsatz.

Hier aber mal ein kleines Update (da es inzwischen eine neue Version gibt) dieser Beschreibung:

Nach der Installation (Ubuntu 8.04) und der Aktualisierung des Systems, erkennt Ubuntu automatisch, das im System ein WLAN eingebaut ist. Da es sich um keinen freien Treiber handelt fragt das System erstmal ab, ob er diese überhaupt installieren darf. Dies bejaht man und bei der Frage ob er die Firmware herunterladen darf, bejaht man wiederum.

Jetzt sind schon mal die Treiber installiert.

Jetzt kommt der Schalter dazu (siehe Link oben „Schritt 2“):

In einem Terminal wird folgendes eingetragen:

Code: Alles auswählen
sudo modprobe acerhk force_series=5020 autowlan=1


Mit z.B. „nano“ wird die Datei „/etc/modprobe.d/options“ bearbeitet

Code: Alles auswählen
sudo nano –w /etc/modprobe.d/options


Dort wird am Schluss dieser Text eingefügt :

Code: Alles auswählen
options acerhk force_series=5020 autowlan=1


Danach wir die Datei /etc/modules bearbeitet:

Code: Alles auswählen
sudo nano –w /etc/modules


Eintrag in letzter Zeile:

Code: Alles auswählen
acerhk


Jetzt kann schon getestet werden ob es funktioniert, indem einfach die WLAN-Taste gedrückt wird -> Lampe läst sich an und aus schalten!!!

Um nun einen Kontakt zu bekommen, ist nur noch Schritt 3 notwendig!!!

Nochmals vielen Dank an „@ anybodysgothic“, der mir nun ein Jahrelanges Problem gelöst hat!!!

Gruß Satyria
satyria
 
Beiträge: 10
Registriert: 22.10.2005 10:21


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste