amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Xa 2529 keine Dirstribution funktioniert Thema ist gelöst

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Xa 2529 keine Dirstribution funktioniert

Beitragvon gently » 07.06.2008 07:32

Hallo,

ich habe mir einen Xa2529 zugelegt und würde jetzt gerne Linux installieren. Leider versagen alle Distributionen die ich ausprobiert habe.

Beim booten von CD/DVD bleiben die Linuxe immer bei der Erkennung des Sata Controllers hängen.

Probiert habe ich :

Knoppix : 3.7, 5.1, 5.31
OpenSuse : 11RC1
Ubuntu : 8.04 / hardy daily build amd-alternate von gestern

wer kann helfen ?

Gruß,

gently
gently
 
Beiträge: 4
Registriert: 31.05.2008 09:47

Beitragvon enigma » 07.06.2008 08:41

Ubuntu:

Im Xa2529 dürfte dieselbe Hardware verbaut sein wie im Xa2528.
Laut http://forum.ubuntu-fr.org/viewtopic.ph ... 0#p1819120 lässt sich Ubuntu auf dem Xa2528 mit dem Wubi-Installationsprogramm installieren. Damit müsste die Installation auch auf dem Xa2529 möglich sein. Laut dem franz. Beitrag dauert die Installation ziemlich lange. Außerdem werden Fehlermeldungen erscheinen. Letztlich läuft die Installation aber durch.

Die Installation mit Wubi ist unter http://wiki.ubuntuusers.de/Wubi beschrieben.

Verwende für die Installation die 32bit-Variante von
Ubuntu. Laut dem franz. Forumsbeitrag gibt es ansonsten Probleme mit der WLAN-Karte.
Download: http://de.archive.ubuntu.com/ubuntu-rel ... p-i386.iso

Nach der Installation werden dieselben Schritte wie in http://astuces.absolacom.com/?p=3 beschrieben auszuführen sein - natürlich außer der Demontage der SATA-Platte. Du kannst dir die Seite mit http://www.google.at/language_tools?hl=de übersetzen lassen.
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Beitragvon hikaru » 09.06.2008 11:02

Da hast du dir auch ein paar Exoten ausgesucht:
- Knoppix: Der Installer ist alles andere als zuverlässig
- Suse: Warum ein RC?
- Ubuntu: Schon die Standardvariante probiert?

Folgende Distributionen würde ich noch für testenswert halten:
- Debian 4 bzw. 5
- Mandriva 2008
- Fedora 8
- Slackware 12.1
- Kanotix 2007
- PCLinuxOS 2007
(Gentoo sollte hier auch stehen, ich kenne mich aber zu wenig damit aus, um eine qualifizierte Beurteilung abgeben zu können.)
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Amilo Si 1520
  • Desktop (alt)

Beitragvon Common-Dolphin » 09.06.2008 11:39

hikaru hat geschrieben:Da hast du dir auch ein paar Exoten ausgesucht:
- Knoppix: Der Installer ist alles andere als zuverlässig
- Suse: Warum ein RC?
- Ubuntu: Schon die Standardvariante probiert?

Folgende Distributionen würde ich noch für testenswert halten:
- Debian 4 bzw. 5
- Mandriva 2008
- Fedora 8
- Slackware 12.1
- Kanotix 2007
- PCLinuxOS 2007
(Gentoo sollte hier auch stehen, ich kenne mich aber zu wenig damit aus, um eine qualifizierte Beurteilung abgeben zu können.)


Kann ich so nur bestätigen.
Allerdings wäre ich mit der Spring-Version bei Mandriva 2008 etwas vorsichtig.
Die scheint etwas mehr buggy zu sein als die eigentliche 2008er.
allerdings haben beide ein hässliches Problem das ich nur mit viel Gefummel lösen konnte.
Das WLAN.
Beide erkennen zwar den Intel WLAN Adapter, wollen ihn aber nicht verwenden weil Treiber fehlen.
Ich habe das dann über NDIS-Wrapper gemacht.
Allerdings hab ich nur das NDIS Wrapper Modul installiert nicht aber den Windowstreiber dazu.
Und schon kam ich dann doch in das Konfigurationsmenü und das Ding funktionierte.
Allerdings auch da vorsichtig sein. Je nach Systemkonfiguration kann es passieren dass das ganze System einfriert in dem Moment wo du das NDIS Wrapper Modul installierst.

Bezüglich der SATA & RAID Geschichte:
Solange du kein RAID konfigurierst, erkennt Mandriva die HDDs problemlos.
RAID Konfigurationen scheinen aus irgendeinem Grund nicht gelesen werden zu können.
Bis jetzt hatte ich noch nicht die Muße dem auf den Grund zu gehen.
Bis auf diese Kleinigkeiten wirkt Mandriva ansonsten deutlich ausgereifter
als die meisten anderen bekannten Distributionen.
Aber da spielt sicher auch persönliches Empfinden eine Rolle.
Benutzeravatar
Common-Dolphin
 
Beiträge: 51
Registriert: 10.04.2008 18:52
Notebook:
  • Amilo M3438G

Beitragvon hikaru » 09.06.2008 12:34

Common-Dolphin hat geschrieben:RAID Konfigurationen scheinen aus irgendeinem Grund nicht gelesen werden zu können.
Ist bei Mandriva dmraid installiert?
Ich weiß es nicht aus dem Kopf und kann im Moment nicht nachschauen.

Wenn ich nicht so ein Freund der Debian-Philosophie (frei, stabil, "community-driven") und der deb-Packages wäre, würde ich vielleicht Mandriva verwenden.
Aber die Struktur des Fedora-Projekts gefällt mir besser (Firma vs. Community). ... womit wir wieder bei Debian wären. ;-)
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Amilo Si 1520
  • Desktop (alt)

Beitragvon enigma » 09.06.2008 17:00

enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Beitragvon hikaru » 09.06.2008 17:31

Von Hause aus ist dmraid nicht enthalten:
Code: Alles auswählen
[hikaru@mandrivabox ~]$ which dmraid
which: no dmraid in (/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt4/bin:/home/hikaru/bin:/usr/lib/qt4/bin)
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Amilo Si 1520
  • Desktop (alt)

Beitragvon Common-Dolphin » 09.06.2008 20:23

Wie läßt sich das denn machen?
Kann man das während des booten von DVD nachreichen?
Benutzeravatar
Common-Dolphin
 
Beiträge: 51
Registriert: 10.04.2008 18:52
Notebook:
  • Amilo M3438G

Beitragvon hikaru » 09.06.2008 20:42

Bei Ubuntu geht das.
Wie es bei Mandriva ist, weiß ich nicht. Prinzipiell scheint es aber seit der letzten Version zu gehen:
http://www.steletch.org/spip.php?article49

Vielleicht wird auch während der Installation anhand der Konfiguration entschieden, ob dmraid installiert wird. In dem Fall kann ich es natürlich nicht finden.
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Amilo Si 1520
  • Desktop (alt)

pata_amd

Beitragvon gently » 21.06.2008 09:44

Hallo,

mein Problem ist leider noch nicht gelöst. Ich hatte auf die finale Opensuse 11 gewartet, aber leider funktiniert es auch mit dieser Distribution nicht.

Bei einem Installationsversuch wird beim laden des pata_amd immer der Fehler ausgegeben das kein funktionierender Modus für das Optiarc Laufwerk gefunden wird.

loading pata_amd
.
.
.
ata3.00
ATAPI Optiarc
Drive reports diagnostic failure

Bei dem Laufwerk handelt es sich um ein Optiarc AD-7540a mit der Firmware 1.42

Gruß,

gently
gently
 
Beiträge: 4
Registriert: 31.05.2008 09:47

Re: Xa 2529 keine Dirstribution funktioniert

Beitragvon enigma » 22.06.2008 09:56

Hast du schon versucht, Ubuntu 8.04 mit dem Wubi-Installer unter Windows zu installieren (siehe meinen Beitrag oben)
Wie du unter http://wiki.ubuntuusers.de/Wubi nachlesen kannst, ist Wubi ein Ubuntu-Installationsprogramm für Windows. Fahre Windows hoch und lege die Ubuntu 8.04-CD ein. Daraufhin erscheint das Ubuntu-Installationmenü.

Verwende diese Ubuntu-Version: http://de.archive.ubuntu.com/ubuntu-rel ... p-i386.iso
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Xa 2529 keine Dirstribution funktioniert

Beitragvon gently » 22.06.2008 10:02

Hallo Enigma,

sorry, hatte ich vergessen zu schreiben, ja ich habe natürlich auch alle eure Tips ausprobiert, auch Wubi funktioniert nicht, lässt sich zwar problemlos installieren, aber beim Booten der instllierten Version habe ich die selben Probleme.

Danke fuer eure Hilfsbereitschaft,

gently
gently
 
Beiträge: 4
Registriert: 31.05.2008 09:47

Re: Xa 2529 keine Dirstribution funktioniert  Thema ist gelöst

Beitragvon Ritschie » 22.06.2008 16:04

Ich denke, Du wirst nicht um eine Netzwerk-Installation herumkommen.

Auf meinem XA 2528 hab ich damit und der Bootoption
Code: Alles auswählen
brokenmodules=pata_amd
openSUSE 11.0 zum Laufen bekommen. CD/DVD-LW will aber (wie in nem anderen Thread bereits besprochen) immernoch nicht funktionieren. Werd also wohl um's selber kompilieren des Kernel nicht herumkommen.

Gruß,
Ritschie
Benutzeravatar
Ritschie
 
Beiträge: 68
Registriert: 14.11.2007 09:02
Wohnort: Bayreuth
Notebook:
  • Amilo Xa2528
  • Amilo A 7620

Re: Xa 2529 keine Dirstribution funktioniert

Beitragvon gently » 22.06.2008 21:54

HAllo,
der letzte Tip mit dem breakmodules hat gewirkt, neben dem pata_amd musste ich auch noch dem amd74xx rausschmeissen. Danach liess sich OSS11 aber über das Netz installieren.

Nach der Installation wird WLAN und Sound nicht erkannt, da kuemmer ich mich morgen drum, Problem war noch das der Grub mir wegen fehlendem DVD-Laufwerk eine unbrauchbare Config geschrieben hat und sich Vista nicht mehr booten liess. Dies musste ich noch durch händisches eingreifen in die Grub Configs bereinigen, funktioniert jetzt aber auch..

Langsam komme ich der Sache näher... vielen Dank an alle die untertützt haben.

Gruß,

Gently
gently
 
Beiträge: 4
Registriert: 31.05.2008 09:47

Re: Xa 2529 keine Dirstribution funktioniert

Beitragvon Ritschie » 12.02.2010 22:10

... übrigens, mit openSUSE 11.2 und
Code: Alles auswählen
brokenmodules=pata_amd
als Bootparameter läuft auch das CD/DVD-Laufwerk. Es wird dann amd74xx geladen, welches jetzt anscheinend mit dem Laufwerk klar kommt.

Installiert hab ich über NET-Install, sollte aber mit der normalen DVD auch funktionieren.

Gruß,
Ritschie
Linux - the other way!
Benutzeravatar
Ritschie
 
Beiträge: 68
Registriert: 14.11.2007 09:02
Wohnort: Bayreuth
Notebook:
  • Amilo Xa2528
  • Amilo A 7620

Nächste

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast