amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon Matscher » 11.08.2008 18:29

Hallo Gemeinde! :lol:

Ich habe mir vor kurzem neben mein XP die Ubuntu-Version 8.04 installiert. Dabei habe ich - ähnlich wie es das früher mit Winlinux schon mal gab - das Ubuntu auf einer XP-Partition mit Ubuntu-Wubi eingerichtet. Es ist also keine richtige Installation sondern mehr oder weniger eine "Probierversion". Alles in allem läuft das System sehr gut, auch meine Netzwerkkarte (LAN) wurde erkannt. Ich habe auf Anhieb eine Verbindung zu meinem Router aufbauen können (ohne DHCP, feste IP; DNS und Gateway über Router).
Leider "vergisst" das Linux regelmäßig die Netzwerk-Konfiguration und gelegentlich wird dann sogar die Netzwerkkarte nicht mehr erkannt. Anfänglich habe ich dann Ubuntu neu installiert, was ja ziemlich fix geht. Nach dem ich allerdings das System aktualisiert habe und einige Programme neu installiert hatte, machte mich die "Vergesslichkeit" des Ubuntu dann doch misslaunig!

Ich bin kein Linux-Spezi und weiss nicht, wie ich den Fehler korrigieren kann. Wer hat einen Rat für mich?

Weiterhin möchte ich wissen, ob es unter Ubuntu (Linux allgemein) eine Software gibt, mit der ich mein Windows-Smartphone und meinen Windows PocketPC synchronisieren kann. Für Palm-Geräte soll es so was geben, wie mir ein Eintrag in der Programmgruppe zeigt.

Gruß

Mathias
======
Leitsatz:
----------
So blöd, wie ich es brauche, kann man mir nicht kommen!
======
Matscher
 
Beiträge: 58
Registriert: 22.04.2006 18:33
Notebook:
  • Amilo L7300
  • Amilo L6820

Re: Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon enigma » 12.08.2008 08:17

1. Was wird angezeigt, wenn du im Terminal ( http://wiki.ubuntuusers.de/Terminal ) folgende Befehle eingibst ?

Code: Alles auswählen
lspci | grep -i net
cat /etc/network/interfaces
cat /etc/hosts
cat /etc/resolv.conf
ifconfig
lsmod > lsmod.txt


(Hinweis: durch den letzten Befehl wird eine Datei mit dem Namen lsmod.txt erzeugt, in der alle geladenen Treiber aufgelistet werden; diese Datei wird im Verzeichnis /home/deinBenutzername gespeichert . Poste die Datei lsmod.txt als Anhang.

Gib bitte den Output der drei letzten Befehle zwei Mal an - einmal für den Fall eines geglückten Netzwerkstartes und einmal für den Fall eines missglückten Netzwerkstartes.

2. Wenn die Netzwerkkarte erkannt wird, der Netzwerkstart aber nicht glückt, hilft es, wenn du im Terminal den Befehl

Code: Alles auswählen
sudo /etc/init.d/networking restart


eingbist? (dadurch wird das Netzwerk neu gestartet; der Netzwerkneustart könnte natürlich auch automatisiert werden).

3. Das Standardnetzwerktool ist der Network-Manager (siehe http://wiki.ubuntuusers.de/Network-Manager ). Verwendest du ein alternatives Tool, z. B. Wicd ( http://wiki.ubuntuusers.de/WLAN/Wicd ; mit Wicd kann man auch Kabelnetzwerke verwalten)?
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon Matscher » 12.08.2008 18:33

Hi enigma,

ich habe gerade Deine Anweisungen befolgt, habe Windows beendet, Ubuntu gestartet, die Shell aufgerufen, alle Befehle eingetippt, die Shell-Ausgaben markiert und in eine Textdatei eingetragen. Dann - weil ja kein Netz unter Ubuntu - selbiges beendet und Windows gestartet. Allerdings lassen sich die Textdateien kaum lesen, weil die Formatierung nicht stimmt. Lauter kryptische Zeichen, keine sauberen Textumbrüche etc.
Also habe ich gerade die Dateien inklusive der "lsmod.txt" wieder gelöscht. Ich werde mich in den nächsten Tagen, wenn ich mehr Zeit habe, noch mal mit der Sache beschäftigen und versuchen, vernünftig lesbare Dateien zu erstellen.

Nur so viel noch: Unter Ubuntu/Netzwerkdiagnose wird meine VIA Rhine nicht angezeigt. Einzig das Protokoll IPv6 steht da drin. Seltsamer Weise funktioniert die Karte immer nach einer Neuinstallation um dann beim dritten oder vierten Start wieder wech zu sein. Seltsam, aber ich habe in einem Linux-Forum bereits eine ähnliche Anfrage gesehen, wobei sich ein User auch beschwerte, dass die Netzwerk-Konfiguration immer wieder "vergessen" würde. Dort wurde behauptet, dass es sich um einen Bug (kenn' ich nur von Microsoft! :lol: ) bei Ubuntu handeln sollte.


Danke für die Tipps und Anregungen! Ich werde mich um Erledigung bemühen.

Gruß

Mathias
======
Leitsatz:
----------
So blöd, wie ich es brauche, kann man mir nicht kommen!
======
Matscher
 
Beiträge: 58
Registriert: 22.04.2006 18:33
Notebook:
  • Amilo L7300
  • Amilo L6820

Re: Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon Matscher » 12.08.2008 20:53

Hallo noch mal,

ich habe die Befehle erneut eingegeben und die Ergebnisse in eine PDF-Datei kopiert.

Hoffentlich kannst Du was damit anfangen.

Der Befehl über SUDO bringt nichts, da die Netzwerkkarte scheinbar gar nicht eingebunden wird.


Ich sage schon mal "DANKE"!

Gruß

Mathias
Dateianhänge
Network.pdf
Der Inhalt der "lsmod.txt" steht am Ende der Datei.
(10.18 KiB) 128-mal heruntergeladen
======
Leitsatz:
----------
So blöd, wie ich es brauche, kann man mir nicht kommen!
======
Matscher
 
Beiträge: 58
Registriert: 22.04.2006 18:33
Notebook:
  • Amilo L7300
  • Amilo L6820

Re: Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon enigma » 13.08.2008 12:43

Hallo!

1. Deine /etc/network/interfaces ist ziemlich verunstaltet.

Gib im Terminal

Code: Alles auswählen
 sudo gedit /etc/network/interfaces


ein. Daraufhin wird die Datei /etc/network/interfaces geöffnet. Ändere dann die Datei so, dass sie ausschließlich folgenden Inhalt hat:

auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.2.111
netmask 255.255.255.0
gateway 192.168.2.22
auto eth0

iface wlan0 inet static
address 192.168.2.222
netmask 255.255.255.0
gateway 192.168.2.22
wpa-psk 814efff5f79084f37d8a63bcb112b7c36753dc419dg13372707b4ed2b3928b22
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid LinkSys
auto wlan0

(Hinweis: neben wpa-psk muss natürlich DEIN WPA-Schlüssel stehen)

2. Deine Netzwerkkarte ist eine VIA VT6102. Die ist nicht unproblematisch.

a) Lösungsansatz 1:

Vorbemerkung: Ich habe noch nie eine Wubi-Ubuntu-Installation durchgeführt. Mein Wissen zu Wubi beruht also lediglich auf der Grundlage von Internet-Recherchen

Bei einer Wubi-Installation erfolgt der Start des Ubuntu-Systems über einen Eintrag im Windows-Bootmanager. Die Optionen für Ubuntu befinden sich
in Windows in c:\ubuntu\disks\boot\grub\menu.lst (wenn du Ubuntu etwa in einem Laufwerk f: installiert hast, in f:\ubuntu\disks\boot\grub\menu.lst
(bei frühren Wubi-Ubuntu-Versionen war das entsprechende Boot-File c:\wubi\boot\grub\menu.lst oder bei Installation etwa in d:
d:\wubi\boot\grub\menu.lst

Öffne in Windows mit einem Editor die Datei menu.lst (enthalten im Verzeichnis c:\ubuntu\disks\boot\grub\ ; bei Installation auf einem anderen Laufwerk eben im entsprechenden Verzeichnis)

In dieser Datei findest du unterhalb von

## ## End Default Options ##

Einträge, die in etwa wie folgt aussehen (bei dir natürlich völlig anders; allerdings ist das nicht weiter von Relevanz)

title Ubuntu, kernel 2.6.20-15-generic
find --set-root --ignore-floppies /wubi/boot/linux
kernel /wubi/boot/vmlinuz-2.6.20-15-generic find=/wubi/boot/linux ro quiet splash
initrd /wubi/boot/initrd.img-2.6.20-15-generic
boot

title Ubuntu, kernel 2.6.20-15-generic (recovery mode)
find --set-root --ignore-floppies /wubi/boot/linux
kernel /wubi/boot/vmlinuz-2.6.20-15-generic find=/wubi/boot/linux ro single
initrd /wubi/boot/initrd.img-2.6.20-15-generic

title Ubuntu, memtest86+
find --set-root --ignore-floppies /wubi/boot/linux
kernel /boot/memtest86+.bin


Füge nun in den Zeilen, die mit kernel beginnen, jeweils am Ende der Zeile den Eintrag irqpoll hinzu. Andere Änderungen sind nicht vorzunehmen. In meinem Beispiel würde der erste der drei obigen Abschnitte dann so aussehen

title Ubuntu, kernel 2.6.20-15-generic
find --set-root --ignore-floppies /wubi/boot/linux
kernel /wubi/boot/vmlinuz-2.6.20-15-generic find=/wubi/boot/linux ro quiet splash irqpoll
initrd /wubi/boot/initrd.img-2.6.20-15-generic
boot

Quellen:
http://www.mail-archive.com/ubuntu-bugs ... 92771.html
http://ubuntuforums.org/showpost.php?p= ... ostcount=1 und http://ubuntuforums.org/showpost.php?p= ... ostcount=2


b) Lösungsansatz 2 (wenn 1 nicht funktioniert):

Mach die Änderungen laut a) rückgängig (entferne die irqpoll Einträge in der menu.lst in Windows)

Starte Ubuntu.

Führe im Terminal den Befehl

Code: Alles auswählen
sudo gedit /etc/rc.local


aus. Ändere die daraufhin geöffnete Datei so ab, dass die 5 letzten Zeilen lauten:

ifdown eth0
rmmod via_rhine
modprobe via_rhine
ifup eth0
exit 0

Starte anschließend Ubuntu neu.

3. Zur WLAN-Karte

Du hast eine Broadcom Corporation BCM4306. Da mir der Output von lsmod zeigt, dass kein Broadcom-Treiber (b43, b44 oder b43legacy) , sondern ndiswrapper geladen wird, hast du die Karte offensichtlich mit ndiswrapper in Betrieb genommen.
Falls die WLAN-Karte Schwierigkeiten bereitet, gehe nach dieser Anleitung vor:
https://help.ubuntu.com/community/WifiD ... y_No-Fluff (es handelt sich um die ultimative Anleitung für die Inbetriebnahme von Broadcom-Wlan-Karten mit ndiswrapper (beachte dort insbesondere auch die Ausführungen unter " Hardy Bug Fix").
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.04 - Netzwereinstellungen müssen ständig erneuert w

Beitragvon Matscher » 15.08.2008 20:08

Hallo enigma, ich bin wieder!

Ich habe alle Deine Tipps befolgt, habe die Datei "interfaces" editiert und die beiden Varianten (menu.lst und rc.local) durchprobiert. Leider blieb der Erfolg aus und die VIA Netzwerkkarte wird weiterhin nicht unter der Netzwerkdiagnose aufgeführt. Auf eine Konfiguration der WLAN-Karte hatte ich bisher ganz verzichtet, da für mich die LAN-Schnittstelle erst einmal wichtiger war.

Ich hatte früher schon erste Versuche mit Linux unternommen. Mit Suse in den Versionen 4 und 5, als man seinen Kernel noch selbst kompilieren musste, standen mir schon die Schweißperlen auf der Stirn. Doch da hatte ich noch Zeit für Experimente. Ich hatte geglaubt, dass Linux so langsam die Bequemlichkeiten von Windows mitbringt und wäre auch zu einem Wechsel bereit. Es wird wohl noch dauern, bis es so weit ist. Oder ist das gar nicht gewollt, dass Linux zu Windows wird? :wink:

Ich werde die Ubuntu-Installation wieder löschen, da ich zum Beispiel auf Outlook und die Synchronisation meiner PDAs nicht verzichten kann. Wine wird sicherlich auch noch einige Zeit brauchen, bis die wichtigsten MS-Programme sauber funktionieren.

Ich danke Dir für Deine Mühen!

Ein schönes Wochenende

Gruß

Mathias
======
Leitsatz:
----------
So blöd, wie ich es brauche, kann man mir nicht kommen!
======
Matscher
 
Beiträge: 58
Registriert: 22.04.2006 18:33
Notebook:
  • Amilo L7300
  • Amilo L6820


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron