amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon Paul_88 » 19.08.2008 14:29

Hallo @All, hatte Ubuntu Hardy Heron 8.4.2 mit den neusten Updates am laufen, alles perfekt bis auf die Webcam deren Treiber zzt. noch in Alpha Status ist.

Zu meiner besonderen Freude lief auch die Kubuntu installation, also die zusätzliche Kde Oberfläche einwandfrei. Und es lief auch die Suspend und Hibernate Funktion wie erwartet.

LEIDER hat seit kurzem die Suspend Funktion aufgehört zu funktionieren, und zwar (wenn ich es recht beobachtet habe) nachdem ich Compiz installiert und aktiviert habe (Cube und Rotate Cube). Jetzt läuft die Suspend Funktion ein einziges mal, direkt nach dem Boot wie erwartet, und danach bekomme ich beim betätigen der Suspend Funktion praktisch das selbe Ergebnis wie bei Lock Session. Die Suspend Funktion läuft also einmal, und dann ist irgendwas zerschossen. Ich kann beobachten das ein versuch gemacht wird beim 2ten mal in suspend zu gehen, dann kommt aber irgendein Fehler in bezug zu Khubd. Ich kann aber damit nicht viel anfangen. Es hat vielleicht etwas mit USB zu tun.

Ich habe inzwischen alles mögliche versucht um sie Suspend Funktion wieder herzustellen, inklusive Compiz wieder komplette raus zuschmeißen. und Ubuntu-Gnome vollständig zu deinstallieren und neu zu installieren. Alles ohne Erfolg.

Ich habe jetzt 2 alternativen, eine komplette neu Installation zu machen (ich hatte keinen Backup), oder Suspend zu debuggen (relativ aufwendig, es gibt dazu eine Anleitung im Ubuntu Forum) ich wollte also vorher einfach mal die Leser dieses Threads fragen ob das Problem Schonmal von jemand anderem gelöst wurde. Ideal wäre eine Repair Funktion für Suspend der die gesamte tangierte Configuration wieder gerade zieht.

Vielen Dank im Voraus für alle Sachdienlichen Hinweise. Ich würde gerne wissen wer Suspend und Hibernate am Laufen hat und mit welcher Konfiguration.

update: Ich habe den verdacht es liegt an KDE also KUbuntu.. Ich werde wenn ich Zeit finde nochmal einen Vanilla 8.4.2 installation versuchen. Bin im moment etwas Ratlos, weil Suspend ist ziemlich wichtig
Paul_88
 
Beiträge: 35
Registriert: 02.02.2008 00:09

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon kane » 20.08.2008 01:11

Hallo,
ich habe eine ähnliche Beobachtung gemacht.

Wenn ich den Rechner ausm Gnome-Menü in den StandBy Modus schicke,
passiert manchmal das selbe, was du beschrieben hast.

Wenn ich es jedoch über die Tastenkombination [Fn+F12] mache, dann funktionierts.

Probier das mal.

Eingestellt habe ich dies bzgl. nichts.
Verkaufe: Amilo XI 2528 (Core2Duo2,4 GHz, 2GB Ram, Nvidia 8600GS, 320GB HDD)
Bei Interesse: PN.
kane
 
Beiträge: 95
Registriert: 03.01.2006 01:35
Wohnort: ./~
Notebook:
  • Amilo Xi 2528

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon Paul_88 » 20.08.2008 10:54

Danke für den Hinweis, ich habe es versucht, leider mit dem selben Fehler. Fn+F12, der Schirm wird schwarz, dann kommen mehrere Fehlermeldungen auf dem Schwarzen Schirm aber leider so schnell das ich keine Möglichkeit habe sie mitzulesen, dann wieder Schwarz und der Ventilator geht los, irgendwann wird dann wieder der Desktop hergestellt. Von welchem Subsystem kommen wahrscheinlich diese Fehler? Und werden sie irgendwo geloggt, wie kann ich sie leicht finden, gibt es ein Zentrales Fehler Repository?
Paul_88
 
Beiträge: 35
Registriert: 02.02.2008 00:09

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon enigma » 20.08.2008 13:36

Zum Fehler-Repository. Ja, so etwas gibt es > http://wiki.ubuntuusers.de/Logdateien

Das im Xi 2528 eine Nvidia-Karte eingebaut ist, empfehle ich auch http://wiki.ubuntuusers.de/Nvidia-Grafikkarten/Suspend
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon Paul_88 » 20.08.2008 21:54

Vielen Dank für die Hinweise.

Problem scheint bekannt zu sein und wurde schon mal beschrieben unter: http://forum.ubuntuusers.de/topic/nur-n ... ost-220548

Werde es jetzt mal nach dieser Beschreibung versuchen: http://wiki.ubuntuusers.de/Nvidia-Grafi ... d#source-2


Die Kernel-Parameter

acpi_sleep=s3_bios

oder

acpi_sleep=s3_mode


versuche ich zu einem späteren Zeitpunkt nachdem ich meinen Master Boot Record und hd0 gesichert habe.
Paul_88
 
Beiträge: 35
Registriert: 02.02.2008 00:09

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon Paul_88 » 22.08.2008 08:52

Werde die nächsten 10 Tage keine Zeit mehr hierfür haben.
Mein vorläufiges Ergebnis: Suspend hat am anfang mit Hardy-Heron-Gnome funktioniert, irgendwann hat es aufgehört zu funktionieren, ich habe relativ viel Software installiert inklusive KDE-Desktop und Compiz, weiss aber letztlich nicht an welcher Komponente es liegt.

Der Nvidia Distribution Teiber auf Hardy ist vom Februar 2008 also relativ alt, es gibt einen neuen: NVIDIA driver 173.14.12 in hardy-proposed and intrepid mit: "Release Highlights: Added support for GeForce 8600 GS". Es gibt eine Software EnvyNG mit der man ihn installieren kann, habe ich aber noch nicht versucht. Es ist auch möglich den neusten Treiber von Nvidia dowloads herunterzuladen und manuell zu installieren, ich habe festgestellt die Installation ist nicht trivial es gibt sehr viele Einstellungen die eine rolle spielen können insbesondere im X-Windows System.

Intressant is auch: nachdem ich blacklist agpgart, blacklist intel_agp in die blacklist in modprobe.d eingetragen habe, bekomme ich zum ersten mal überhaupt den Nvidia-Splash-Sscreen direkt nach dem boot zu sehen (...)
Paul_88
 
Beiträge: 35
Registriert: 02.02.2008 00:09

Re: Amilo XI 2528 Kubuntu 8.4.2 Suspend und Hibernate Problem

Beitragvon enigma » 23.08.2008 00:23

Installiere Envy:

Ubuntu:
Code: Alles auswählen
sudo apt-get install envyng-gtk


Kubuntu:
Code: Alles auswählen
sudo apt-get install envyng-qt


Nach der Installation findest du Envy unter Gnome unter Anwendungen > Systemwerkzeuge. Siehe das angehängte Bildschirmfoto.
Ich habe Envy auf meinem AMD-Desktop mit Nvidia-Grafikkarte ausprobiert. Das Tool hat bei mir einwandfrei funktioniert.

Bei einem Update des Treibers sollte man den alten vorher deinstallieren.
Schau dir vor der Nutzung von Envy jedenfalls http://albertomilone.com/envyngfaq.html an.
Dateianhänge
EnvyNG.png
Envy
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron