amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Amilo Xa 3530 und Linux?

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Re: Amilo Xa 3530 und Linux?

Beitragvon sisqonrw » 13.05.2009 01:37

habe mal wicd installiert. aber der findet keine router. nur lan geht.
muss ich bei den blacklisten was eintragen oder austragen?
sisqonrw
 
Beiträge: 54
Registriert: 16.01.2006 23:33

Re: Amilo Xa 3530 und Linux?

Beitragvon hikaru » 13.05.2009 10:15

@sisqonrw:
Wenn du dich (und andere) auf einen Thread konzentrierst sind die Lösungschancen höher:
https://www.amilo-forum.de/topic,27514,-WLAN-von-fujitsu-siemens-amilo-xa-3530-geht-nicht.html
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)

Re: Amilo Xa 3530 und Linux?

Beitragvon Laptopfan21 » 15.05.2009 22:31

habe euren Thread nicht ganz zu Ende gelesen, jedoch kann ich euch eins sagen, beim Wlan Problem ist es so, dass es nach dem Biosstart direkt ausgeschaltet ist bis man es manuell einschaltet, dies macht in Linux einige Probleme. Dazu ist es seit dem Bios Update eine Wlan funktion im Bios freigeschaltet worden, sodass ihr euer Wlan direkt beim Start auf on stellen könnt Wlan Radio On ! So ist euer Wlan immer an wie bei jedem anderen Laptop und ihr habt keine Probleme mehr.

Übrigens bin für Info Austasuch gerne bereit. Meldet euch per Pn wenn ihr Infos oder so austauschen wollt .
Laptopfan21
 
Beiträge: 27
Registriert: 15.05.2009 22:19

Re: Amilo Xa 3530 und Linux?

Beitragvon gr0sshirn » 16.05.2009 01:38

@Laptopfan21:

Danke für oberflächliche Informationen die hier schon 100fach geklärt wurden. (deswegen liebe ich Foren...)
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

Re: Amilo Xa 3530 und Linux?

Beitragvon tayfund » 24.06.2009 15:59

hi, I follow up this subject by google translate, in english. I am from turkey and dont know german. So, I have to write in english...
My linux is xubuntu 9.04. I have installed fglrx driver (ATI Catalyst™ Display Driver) couple of times (last one by this way http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide), but all the time system hanged up at a purplish colored two screen display on my monitor :( At the begining of the xorg I guess.

Now my xorg.conf file is
Code: Alles auswählen
Section "Device"
   Identifier   "ati"
   Driver      "radeon"
   VendorName   "ATI"
#   BusID      "PCI:02:00:0"
#   BoardName   "ATI Mobility Radeon 3650"
   BusID      "PCI:01:05:0"
   BoardName   "ATI Radeon HD 3200 Graphics"
EndSection


Section "Monitor"
   Identifier   "Configured Monitor"
EndSection


Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "ati"
EndSection

I have found it from a post by gr0sshirn .

Especially in the games, screen is slow. Is there anyone could use 3d? Which driver do you use? If you could paste your xorg.conf file, I will be very glad?
Danke :)
tayfund
 
Beiträge: 2
Registriert: 24.06.2009 15:27

Re: Amilo Xa 3530 und Linux?

Beitragvon mewtwo » 24.06.2009 16:07

If you've installed fglrx, you need to write Driver "fglrx" instead of Driver "radeon".
Benutzeravatar
mewtwo
 
Beiträge: 83
Registriert: 13.04.2008 02:59
Notebook:
  • Skytone Alpha 400
  • Amilo Pi 2515

Re: Amilo Xa 3530 und Linux?

Beitragvon tayfund » 24.06.2009 16:24

Yes when I installed the fglrx, driver was fglrx. Above is my current xorg.conf
Sorry, I didnt write other configurations.

fglrx driver made up an xorg.conf file:
Code: Alles auswählen
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
#   Screen         "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[1]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   Option       "UseFastTLS" "1"
   BusID       "PCI:1:5:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[1]-0"
   Driver      "fglrx"
   BusID       "PCI:2:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[1]-0"
   Device     "aticonfig-Device[1]-0"
   Monitor    "aticonfig-Monitor[1]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


then I tried this one:
Code: Alles auswählen
#Section "Device"
#   Identifier "ati3650"
#   BusID "PCI:02:00:0"
#   Driver "fglrx"
#   VendorName "ATI"
#   BoardName "ATI Mobility Radeon 3650"
#EndSection

Section "Device"
   Identifier "ati3200"
   BusID "PCI:01:05:0"
   Driver "fglrx"
   VendorName "ATI"
   BoardName "ATI Radeon HD 3200 Graphics"
EndSection


Section "Monitor"
   Identifier   "Configured Monitor"
EndSection


Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "ati3200"
EndSection


the result was same :(
two purpleish and blurred xubuntu splash screen hanged up

My guess is that; system knows two video card exists, but it didnt know that their monitors are only one and same. System sends the video to cards and two cards send the video to just one and the same monitor at the same time :( That is just guess.
tayfund
 
Beiträge: 2
Registriert: 24.06.2009 15:27

Re: Amilo Xa 3530 und Linux?

Beitragvon johnaA » 02.10.2009 12:20

Hallo@all!

Ich habe mich nun dazu entschlossen auf meinem FSC Amilo Xa 3530 ein Ubuntu 9.04 zu installieren. Ersteinmal läuft folgendes "Out-of-the-Box":

1. WLAN

- Ich habe ein BIOS-Update gemacht auf die aktuelle Version (2.07) dort kann der WLAN-Adapter permanent auf Ein oder Aus geschaltet werden.

*

Leider habe ich immer Verbindungsabbrüche, ist aber noch nicht geklärt, ob diese vom Atheros Treiber stammen.

2. Medialeiste "OSD Utility" bzw. "Launch Manager"

- Die Medialeiste funktioniert nur zum teil. Lautstärkeregler und der Mediaplayerbutton.

3. Touchpad und Scrollen:

- Funktionert einwandfrei!!! Sogar die Scrollfunktion ist aktiviert!

4. Sound:

Der Sound ist nur halb konfiguriert. Nur die Lautsprecher funktionieren. Der Subwoofer wird nicht angesprochen.

Jetzt kommen wir zu dem Problem an dem ich zur Zeit noch schwer Arbeite:

- Der Amilo Xa 3530 hat ZWEI! Grafikkarten. Eine Radeon HD3200 "onboard" und eine ATI Radeon HD Mobility 3650 (extra). Es wird von einem "Hybridbetrieb" gesprochen.

Es gibt ja verschiedene Treiber für die ATI Grafikkarten unter Ubuntu. Einmal den "fglrx" Treiber der auch über "Eingeschränkte Treiber" installierbar ist sprich den ATI Legacy Treiber mit Catalyst von der ATI Webseite. Dieser Treiber funktioniert bei dem Laptop GARNICHT!

Dann gibt es noch den Radeon Treiber, dieser funktioniert auf dem Amilo Xa 3530, jedoch ohne 3-D Unterstützung, sprich mehr oder weniger eine Notlösung. Welche Karte dieser Anspricht bzw. benutzt konnte ich noch nicht feststellen.

Zum dritten gibt es noch den RadeonHD Treiber. Ich habe im Wiki gelesen, dass dieser Laut der Readme auch die beiden Grafikkarten des Amilo Xa 3530 unterstützen soll. Jedoch steht da nichts von Hybridunterstützung. Hat schon jemand diesen Treiber auf dem Amilo Xa 3530 ausprobiert bzw. gar zum Laufen bekommen?!?

- Der Lüfter des Laptops wird durchaus von Ubuntu geregelt, keine Probleme.

Wenn es neues gibt, werde ich weiter Ergänzen.

Hoffe auf eure Hilfe! Mfg
johnaA
 
Beiträge: 2
Registriert: 28.09.2009 19:18

Re: Amilo Xa 3530 und Linux?

Beitragvon gr0sshirn » 06.10.2009 11:14

Hallo johnaA,

ja im Grunde genommen läuft alles super, nur mit der Grafik ist es tricky.
Mein Soundtreiber für die Xa3530 Soundkarte (ALC888) ist seit dem 29er Kernel integriert. Also wenn du Soundprobleme hast, update auf nen akutellen Kernel.
(Dem Subwoofer hab ich nen eigenen Regler verpasst, vielleicht ist der bei der gemutet? gib mal in ner console "alsamixer" ein und spiel bisschen mit den Reglern rum!)

Funktionstasten:
Lautstärke und Playersteuerung sollten funktionieren. Die Hybridgrafiktaste und die Silentmode Taste natürlich nicht. (da hängen ja sonst irgendwelche Windowstreiber dahinter)


Touchpad:
das Scrollen geht weil HAL das Teil automatisch mit der Synaptics Config initialisiert hat. Bedank dich bei HAL. (Änderungen kannst du in den .fdi Dateien von HAL vornehmen. Die sollten irgendwo unter /etc/ liegen, abhängig von der Distro)


Bezüglich der Grafikkarten gilt folgendes:
Die HD3650 wirst du unter Linux vorraussichtlich nicht nutzen können. Zur Umschaltung auf den Grafikchip ist ein spezieller Northbridge Treiber erforderlich, der bei jedem Notebook anders aussieht. Fujitsu hat sich den von ATI schreiben lassen. Leider aber auch nur für den veralteten Windows Catalyst Treiber auf der Fujitsu Homepage. Neuere Catalyst Treiber laufen also auch unter Windows nicht.

Momentan gibt es unter Linux mit keinem Treiber eine Möglichkeit die andere Karte zu wählen.
fglrx neigt dazu ganz abzuschmieren, weil er die 2. Karte findet, aber die Prüfsumme von dem ATOM Bios auf der Karte nicht auslesen kann.

xf86-video-ati und xf86-video-radeonhd laufen beide gut auf der HD3200. Mit ein bisschen Configgeschnipsel kriegt man auch hardwareseitiges DRI zum laufen. Für compiz-fusion reicht die HD3200 alle Mal.

Ich hoffe das bringt dich irgendwie weiter, wenn nicht noch mal melden.
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

Re: Amilo Xa 3530 und Linux?

Beitragvon johnaA » 08.10.2009 16:43

hey gr0sshirn!

danke erstmal für die tipps!

mittlerweile bin ich nun schon bei ubuntu 9.10 beta angekommen mit dem 2.6.31-12 kernel. ich benutze den xserver-xorg-driver-radeon treiber, der funktioniert, also so halb, halt keine 3D unterstützung usw... unter ubuntu 9.04 mit dem treiber konnte ich noch nicht mal ordentlich fenster verschieben --> diashow^

den radeonhd treiber habe ich auch schon probiert, da bleibt dann leider mein bildschirm schwarz und ich höre aber den startup sound von ubuntu, sehe aber einfach nichts. ich hänge mal meine xorg.conf an, vielleicht hast du ja noch einen tip ;-p.

das mit dem catalyst treiber und der northbridge hört sich böse an. eigentlich wollte ich den kompromiss machen und unter linux halt die hd 3560 benutzen und nicht die onboard. das mit dem umschalten im betrieb, war mir auch schon klar das dass unter linux nicht funzt, aber nur die hd 3200 ist ja wohl ein bisschen schlapp^^

was mich halt wundert ist, das der fglrx garnicht funktioniert. ich hatte schon öfters bei ati angerufen und die meinten die onboard grafikkarte wird auf jeden fall unterstützt. die mobility nicht weil das laptophersteller sache ist...sauerei^

was aber durchaus sehr sehr interessant ist die sache wenn du mal auf die ati.com homepage schaust und dort die relasenotes zum "ATI Catalyst™ 9.9 Proprietary Linux x86 Display Driver" anschaust unter: https://a248.e.akamai.net/f/674/9206/0/ ... _linux.pdf

dann siehst du auf seite 2 in der datei, dass dort auch die mobility karten auf einmal stehen und diese auch supported werden sollen. sprich auch wenn die northbridge da stört, müsste ich doch entweder die eine karte oder die andere, mit dem treiber ansprechen können?!?

meinst du es gibt hoffnung das ati die northbridge treiber für laptops irgendwann mit integriert?

ich glaube ich brauch nen programmierer :D

greetz johnny

ooops voll die xorg.conf vergessen:

Code: Alles auswählen
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "ati"
        BusID       "PCI:1:5:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Zuletzt geändert von johnaA am 08.10.2009 20:54, insgesamt 1-mal geändert.
johnaA
 
Beiträge: 2
Registriert: 28.09.2009 19:18

Re: Amilo Xa 3530 und Linux?

Beitragvon gr0sshirn » 08.10.2009 20:18

kurze Antwort zu der Northbridge Geschichte (längere folgt später...):

ich hab schon bei Fujitsu angefragt, weil ich den Treiber auch selbst schreiben würde - ohne Spezifikationen den ihrer Northbridge geht das aber nicht.

ATI gibt die Spezifikationen der Radeon Karten als PDF raus, die allein nützen aber nix. Da sich Fujitsu, wie so oft in Sachen Unfähigkeit beweist, und sich weiterhin weigert auch nur im entferntesten mit mir zusammen zu arbeiten, wird das wohl nix.

kommt zeit, kommt "Rad" ;) (an die Klugscheißerfraktion: bitte keine Hinweise auf Rechtschreibfehler)

die HD3200 läuft mit DRI (das ist das was du mit 3D Unterstützung meinst) und macht eigentlich auch genug fps für compiz und co...

good luck!


Edit 09.10.:

Was da in dem ATI Dokument steht stimmt - die HD3650 Mobility Radeon ist offiziell supportet. Dennoch gibts (noch) keinen Treiber der auf Sie umschalten kann. Wenn du ein Notebook kaufst wo nur ne HD3650 drin ist, wird die wahrscheinlich problemlos laufen.

Wegen der X.org Config: sofern du eine aktuelle HAL Version hast, kannst du dir die nahezu sparen. Das einzige was ich in meiner noch drin hab, ist die Auswahl des richtigen PCI Busses.
Glücklicherweise nimmt die Xorg.conf Haxxerei zur Zeit ein Ende weil HAL die Grafikkarte mit konfiguriert.
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

Nachtrag Grafik, Webcam Treiber

Beitragvon gr0sshirn » 23.10.2009 02:46

Ein kleiner Nachtrag für all jene die vlt. ein Xa3530 haben und noch mit Linux kämpfen.

aktueller Stand:
- mein Soundmodul ist seit dem 29er Kernel fest implementiert, sollte also problemlos laufen.
- Bluetooth geht mit bluez ganz normal
- für die Webcam benötigt man den uvc Treiber, der ist im Kernelsetup bei dem Multimedia, V4L Kram zu finden, das Modul heißt uvcvideo
- die HD3200 geht mit 3D Beschleunigung (DRI) wunderbar. Dafür braucht man einen 32er Kernel und (sehr) aktuelle xf86-video-ati sowie mesa Pakete (am besten die SVN Version, DRI Support für die r600 Chips gibts ab mesa-7.6) - Compiz Fusion macht bei mir ca 100 fps (nicht ultra viel, aber zum flüssigen arbeiten reichts!)
- ich empfehle xf86-video-ati zu nutzen, glxgears schafft mit diesem Treiber über 1000 fps, radeonhd nur etwas über die Hälfte dessen; fglrx geht nach wie vor nicht.

Hoffe das bringt euch weiter,

bei Fragen, fragen ;)
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

Re: Amilo Xa 3530 und Linux?

Beitragvon grissom » 01.11.2009 16:30

ich bin erfreut das ubuntu fortschritte macht mit dem notebook. aber was heisst das mit dem sound? wird auch kompletter 7.1 sound möglich? eventuell sogar mit treibersoftware möglichen splitten eines stereoklanges auf 7.1?

Bin ein absoluter Musikfan von daher ist dieser frage für mich von hoher wichtigkeit. hatte linux erstmal wieder weggefeuert nachdem ich feststellen musste das es nicht ging. naja und weil ich den 3d-support nicht hinbekommen hatte was ja jetzt möglich sein soll.

schade das fuji sich da querstellt, denke mal das es für die auch vom vorteil wäre auch einige linux nutzer diesen notebook schmackhaft zu machen. musste schon oft lesen das viele den notebook nur deswegen loserden wollten. nich mal XP geht drauf, schon ärgerlich genug gewesen. nun nutze ich windoof 7 und das läuft auch nich so schnittig. und vista, naja kein kommentar :/
grissom
 
Beiträge: 26
Registriert: 14.02.2009 00:14
Wohnort: Leegebruch bei Berlin
Notebook:
  • Amilo XA 3530

Antwort 8 Kanal Sound + KMS / DRM

Beitragvon gr0sshirn » 17.11.2009 20:10

Hallo grissom,

mein Alsa Soundmodel beherrscht 2, 4, 5.1 und 7.1 Sound. 8 Kanäle sollten also gehn. Wenn du den Kernel mit HDA-Intel Support (bei den Alsa Settings) kompilierst, sollte die Karte als ALC888 erkannt werden. Im Alsamixer kannst du dann einstellen, auf wie vielen Kanälen eine Ausgabe erfolgen soll.

---

Noch was anderes:
Die Tage kommt offiziell der 32er Kernel raus. Ich hab den Releasecandidate bei mir drauf und der läuft sehr sauber.
Es gibt jetzt auch KMS Support für Radeon - DRM.

Unterm Strich heißt das soviel wie, die 3D Beschleunigung geht gut und das Umschalten auf die Konsolen und zurück auf den X, geht jetzt auch etwas sauberer.

Bin soweit sehr zufrieden, die fps sollten in den kommenden Monaten (mit fortschreitenden Kernel, mesa und xf86-video-ati Treibern) noch etwas höhere Werte erreichen.

Es zeichnet sich also so langsam doch noch ein Happy End für Xa3530 ab :)
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

Re: Amilo Xa 3530 und Linux?

Beitragvon gr0sshirn » 11.03.2010 19:27

Ich habe ein kleines Linux Howto für das Xa 3530 verfasst, hier zu finden:

http://www.gnuyork.de/index.php?seite=amiloxa3530
gr0sshirn
 
Beiträge: 84
Registriert: 08.08.2007 16:11
Wohnort: Silicon Saxony

VorherigeNächste

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste