amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Ubuntu 8.10 auf Amilo Xi2550 - Tipps Thema ist gelöst

Du besitzt ein Amilo-Notebook und möchtest anderen die Erfahrungen mitteilen? Dann bist du hier richtig.

Ubuntu 8.10 auf Amilo Xi2550 - Tipps  Thema ist gelöst

Beitragvon enigma » 08.11.2008 10:21

UPDATE - neuer Beitrag:Ubuntu 10.10 auf Amilo Xi2550

Im Folgenden gebe ich einige Tipps zur Installation und Konfiguration von Ubuntu 8.10 (Intrepid Ibex) auf Amilo Xi2550. Was die im Amilo Xi2550 verbaute Hardware betrifft, verweise ich auf topic,23519,-Ubuntu-8-04-auf-Amilo-Xi2550-Tipps.html (siehe dort den Abschnitt vor Punkt 1. sowie die dort angehängte Datei lspci_lsusb.txt). Lan, Wlan, Sound, Bluetooth, CD-DVD-Laufwerk und der Card-Reader (getestet mit einer SD-Karte) laufen auch unter Ubuntu 8.10 out of the box (d.h. die Treiber sind bereits in Ubuntu integriert; es müssen für diese Komponenten also keine Treiber nachinstalliert werden). Lediglich mit der Bison-Webcam gibt es weiterhin Probleme. Was die übrige Hardware (Firewire, esata etc. betrifft, so konnte ich diese - da ich keine entsprechenden Peripheriegeräte besitze - nicht testen.

1. Zur Installation

Nach dem Erscheinen des Ubuntu-Startbildschirms wählt man zunächst bei der Sprachauswahl Deutsch. Zusätzlich drückt man noch die F4-Taste und wählt "Abgesicherter Grafikmodus". Erst dann startet man Ubuntu mit der Auswahl "Ubuntu ausprobieren"..

Das Starten mit der Option "Abgesicherter Grafikmodus" ist unter Ubuntu 8.10 zwingend erforderlich. Wird diese Option nicht gewählt, ist man nach dem Hochfahren von Ubuntu mit einem "black screen" konfrontiert.

Die Installation nimmt man - wie unter http://wiki.ubuntuusers.de/Ubuntu_Installation beschrieben - vor. Die Installation läuft in einem Zug durch und dauert ca. 10 Minuten.

2. Nach der Installation

a) Paketquellenerweiterung

Es empfiehlt sich, zunächst alle Ubuntu-Quellen freizuschalten. Siehe dazu http://wiki.ubuntuusers.de/Paketquellen_freischalten

Überdies sollten weitere Paketquellen verfügbar gemacht werden. Dies bewerkstelligt man, indem nacheinander folgende Befehle im Terminal (siehe http://wiki.ubuntuusers.de/Terminal ) ausgeführt werden:

Code: Alles auswählen
sudo -s
echo 'deb http://apt.wicd.net intrepid extras' | tee -a /etc/apt/sources.list
echo 'deb http://packages.medibuntu.org/ intrepid free non-free' | tee -a /etc/apt/sources.list
echo 'deb http://blognux.free.fr/ubuntu hardy main' | tee -a /etc/apt/sources.list
echo 'deb-src http://blognux.free.fr/ubuntu hardy main' | tee -a /etc/apt/sources.list
echo 'deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main' | tee -a /etc/apt/sources.list
echo 'deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main' | tee -a /etc/apt/sources.list
apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update


Hinweis:
Durch den 2. Befehl wirde der sources.list Medibuntu als Paketquelle hinzugefügt. Auf diese Weise erhält man Zugang zu wichtiger Software aus dem Bereich Unterhaltung und Multimedia. Siehe http://wiki.ubuntuusers.de/Medibuntu und insbesondere auch http://wiki.ubuntuusers.de/Erste_Schrit ... rstuetzung Durch den 5. und 6. Befehl werden die Quellen für die Installation von Openoffice 3 verfügbar gemacht.

b) ATI-Treiber (mit 3D-Beschleunigung)

Im Amilo Xi2550 ist eine ATI Mobility Radeon HD 2700 verbaut. Zur Installation des ATI-Treibers führt man im Terminal nacheinander folgende Befehle aus:

Code: Alles auswählen
sudo -s
apt-get update
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
echo 'DISABLED_MODULES="fglrx"' | sudo tee -a /etc/default/linux-restricted-modules-common
apt-get install xorg-driver-fglrx fglrx-amdcccle
depmod -a
sed -i 's/xforcevesa//' /boot/grub/menu.lst
aticonfig --initial -f
reboot


Nach dem Reboot sollte

Code: Alles auswählen
fglrxinfo


Code: Alles auswählen
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 2600 XT
OpenGL version string: 2.1.8087 Release


und

Code: Alles auswählen
glxinfo | grep direct


Code: Alles auswählen
direct rendering: Yes


zeigen.

Achtung:
Wenn man ein Kernel-Update durchführt und mit dem neuen Kernel bootet, funktioniert die Grafikkarte nicht mehr. Siehe http://wiki.ubuntuusers.de/Ubuntu_FAQ/S ... nicht-mehr .

Empfehlung:
Wer die höchste Bildschirmauflösung (1920x1200) verwendet und wem die Desktop-Schriftarten, die Schriftarten in den Anwendungen, die Dokumenten-Schrift und die Schrift in den Fenstertiteln zu klein ist, sollte unter System > Einstellungen > Erscheinungsbild > Schriftarten größere Schriften verwenden. Meine Einstellungen können der unter topic,23519,-Ubuntu-8-04-auf-Amilo-Xi2550-Tipps.html angehängten Datei Schriftarten.png entnommen werden. Im Dateimanager Nautilus ( siehe http://wiki.ubuntuusers.de/Nautilus ) können über Bearbeiten > Einstellungen gewünschte Änderungen vorgenommen werden, in Firefox über Bearbeiten > Einstellungen > Inhalt > Standard-Schriftart > Erweitert

c) Wlan-Karte

Im Notebook ist eine Intel Corporation PRO/Wireless 4965 AG/AGN Wlan-Karte verbaut

Code: Alles auswählen
lspci | grep Network


zeigt

Code: Alles auswählen
Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)


Den Treiber für die Karte (Name: iwlagn) bringt Ubuntu schon mit. Nähere Infos zum Treiber lassen sich durch den Befehl

Code: Alles auswählen
modinfo iwlagn


abrufen.

Die WLAN-Konfiguration kann man bequem mit dem Network-Manager vornehmen (siehe http://wiki.ubuntuusers.de/NetworkManager ).

d) Sound

Damit der Sound (insbesondere auch der Subwoofer) ordnungsgemäß funktioniert, muss man im Terminal den Befehl

Code: Alles auswählen
echo 'options snd-hda-intel model=lenovo-ms7195-dig' | sudo tee -a /etc/modprobe.d/alsa-base


ausführen und Ubuntu dann neustarten. Der Subwoofer lässt sich anschließend wie folgt in Betrieb nehmen und steuern:

Nach dem Reboot öffnet man den Lautstärkeregler. Den Lautstärkeregler muss man zunächst in der Menüleiste sichtbar man. Dazu geht man in System > Einstellungen > Hauptmenü. Daraufhin klickt man unter der Rubrik "Menüs" auf "Unterhaltungsmedien" und klickt anschließend "Lautstärkeregler" an.
Anschließend öffnet man den Lautstärkeregler (Anwendungen > Unterhaltungsmedien > Lautstärkeregler). Im Lautstärkeregler macht man nun über Bearbeiten > Einstellungen ALLE Tonspuren sichtbar. Wenn das geschehen ist, wählt man im Lautstärkeregler das Feld "Optionen". Dort stellt man bei "Channel Mode" statt "2ch" "6ch" ein. Dadurch kann man den Subwoofer nutzen. Dieser lässt sich im Feld "Wiedergabe" über die Tonspur "Center" steuern.

Hintergrundinfos:
http://wiki.ubuntuusers.de/Soundkarten_installieren/HDA

Zusatzinfo: Der Output von
Code: Alles auswählen
cat /proc/asound/cards

und
Code: Alles auswählen
head -n 1 /proc/asound/card0/codec*


lautet
Code: Alles auswählen
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf0800000 irq 22
1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xcfeec000 irq 17

bzw.
Code: Alles auswählen
==> /proc/asound/card0/codec#0 <==
Codec: Motorola Si3054
==> /proc/asound/card0/codec#1 <==
Codec: Realtek ALC883


e) Webcam

Code: Alles auswählen
lsusb | grep ALi


zeigt

Code: Alles auswählen
Bus 007 Device 004: ID 0402:5602 ALi Corp. Video Camera Controller


Es handelt sich also um eine Ali-Webcam. Genauer gesagt - wie sich aus der Release note-Datei des Windows-Vista-Treibers entnehmen lässt - um eine Ali m5602-Webcam mit s5k4aa-Sensor. Der Treiber für die Webcam (Name: gspca_m5602) ist bereits im Kernel enthalten. Wenn man auf System > Systemverwaltung > Hardware-Treiber klickt, wird angezeigt, dass der Ali m5602-Webcam-Treiber benutzt wird- Die grüne LED der Webcam leuchtet und

Code: Alles auswählen
dmesg | grep m5602


zeigt

Code: Alles auswählen
ALi m5602: Probing for a po1030 sensor
ALi m5602: Probing for a mt9m111 sensor
ALi m5602: Probing for a s5k4aa sensor
ALi m5602: Detected a s5k4aa sensor
ALi m5602: vertical flip quirk active
usbcore: registered new interface driver ALi m5602
ALi m5602: registered


Die Webcam funktioniert auch. Dies jedoch voerst nur bei Verwendung von Tools wie Ekiga und Kopete 0.12.7 (KDE 3), nicht jedoch z. B. mit Skype.
Nach einem Update des Paketes libv4l-0 wird der Kreis der Tools, mit denen die Webcam funktioniert, ausgedehnt (u.a. Skype). Dazu muss man lediglich im Terminal den Befehl

Code: Alles auswählen
sudo apt-get install libv4l-0


ausführen oder das Update via Synaptic vornehmen. Weitergehende Infos: Siehe http://m560x-driver.wiki.sourceforge.ne ... u+Intrepid

f) Sonstiges

Sollte Ubuntu beim Hochfahren mal hängen bleiben, einfach einmal auf die Esc-Taste drücken. Ca. 4 bis 5 Sekunden später geht es mit dem Boot-Prozess wieder voran.

Links:
http://ubuntuguide.org/wiki/Ubuntu:Intrepid
http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide
http://wiki.ubuntuusers.de/Startseite ,insbesondere http://wiki.ubuntuusers.de/Ubuntu_FAQ
https://help.ubuntu.com/community/UserDocumentation
http://www.galileocomputing.de/presse/p ... gp/pmID-80?
Zuletzt geändert von enigma am 21.01.2011 07:44, insgesamt 3-mal geändert.
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 08.12.2008 22:41

Hallo Enigma,
nach dem Upgrade auf 8.10 habe ich folgende Probleme mit meinem Xi 2550:

1. Sound
Der Sound geht nicht richtig, vorallem in Gnome. Wenn ich nach System->Einstellungen->Audio gehe und eines der Klangereignisse "testen" will, hängt sich das Applet auf.
Ähnliches passiert, wenn ich mit dem Standard Video Player ein Video abspielen will. Beim Hochfahren/Einloggen kommt auch kein Sound mehr. In VLC geht der Sound aber ...?

2. fglrx
Seit dem Upgrade geht fglrx nicht.
Zur Zeit verwende ich radeon. radeonhd habe ich auch nicht zum Laufen gebracht.
Ich habe mehrfach probiert, fglrx zu installieren. U.a. so, wie Du es beschrieben hast. Sobald die xorg.conf einen Eintrag zum Laden der fglrx enthält, fällt der XServer runter, weil er ein Signal 11 bekommt. (Mit envyng hat es auch nicht funktioniert.)
Ich wäre Dir sehr verbunden, wenn Du Deine xorg.conf posten könntest. Falls Du weist, wie eine entsprechende xorg.org für radeon oder radeonhd aussieht, wäre ich auch hier sehr interessiert...

3. Webcam
Vielleicht könntest Du bei Deinen Tips noch aufnehmen, dass man die Webcam erst mit der Tastenkombination Fn-F7 aktivieren muss. Bei mir war sonst nicht einmal ein Eintrag mit lsusb zu finden. dmsg schreibt nichts, was "ALi" enthält. In System->Systemsteuerung->Hardware Treiber habe ich keinen Eintrag für die Webcam, sondern nur einen für die Grafikkarte/fglrx. Es gibt auch kein Device /dev/video*.
Daher funktioniert auch Ekiga nicht.

4. Tastatur
Hier mal ein nicht Ubuntu Problem: Ich bin mit der Tastatur ziemlich unzufrieden, weil sie recht oft Tastendrücke nicht annimmt. Hast Du da ähnliche Erfahrungen, oder gar Tips wie man das verbessern kann?

Ich wäre Dir, oder sonst jedem der Hilfe weiss, sehr für Hinweise dankbar,

Bernhard
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 09.12.2008 16:39

Hallo patbeppo!

1.
Zunächst wäre es interessant zu erfahren, welchen Kernel zu verwendest.

Code: Alles auswählen
uname -r


müsste

Code: Alles auswählen
2.6.27-7-generic


zeigen (der Ali-Webcam-Treiber ist erst ab Ubuntu 8.10 Bestandteil des Kernels; die Webcam funktioniert, die Bildqualität lässt jedoch noch zu wünschen übrig).

Code: Alles auswählen
dpkg -s linux-generic | grep Version


zeigt bei mir:

Code: Alles auswählen
Version: 2.6.27.7.11


2.
Das Howto stellt darauf ab, dass Ubuntu neu installiert wird. Ein Upgrade ist oft mit Problemen verbunden. Ich selbst führe niemals ein Upgrade durch.
In http://forum.ubuntuusers.de/ wimmelt es von Beiträgen, in denen Probleme nach einem Upgrade thematisiert werden. Die von dir beschriebenen Probleme in 1. bis 3. treten nicht auf, wenn man Ubuntu 8.10 neu installiert. Du könntest jetzt umfangreiche Recherchen anstellen, wie z. B das Sound- und Treiber-Problem nach einem Upgrade zu lösen ist. Sei versichert, dass du dir viel Zeit ersparst, wenn du dies unterlässt und statt dessen Ubuntu 8.10 neu installierst.

3.
In der Anlage (Anlage.zip) zifindest du meine xorg.conf sowie ein Bildschirmfoto, auf dem der Webcam- und der Grafikkartentreiber angezeigt werden.

4.
Mit der Tastatur bin ich gleichfalls nicht ganz zufrieden. Die Tasten sind verhältnismäßig schwer anzuschlagen. Wenn der Anschlag nicht mit der entsprechenden Kraft erfolgt, werden auch bei mir Buchstaben bzw. Zeichen "verschluckt." Bislang habe ich mich noch nicht damit beschäftigt, wie hier Verbesserungen erzielt werden können.
Dateianhänge
Anlage.zip
xorg.conf u. Bildschirmfoto
(68.99 KiB) 215-mal heruntergeladen
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 09.12.2008 22:05

Hallo Enigma,

vielen Dank für die schnelle Antwort.
Zu 1.:
# uname -r
2.6.27-9-generic

# dpkg -s linux-generic | grep Version
Version: 2.6.27.9.13

Zu 2.: Ich hatte jetzt auch schon an eine Neuinstallation gedacht. Bisher hatte ich auf meinem Fest PC keine Probleme mit Upgrades: habe von der ersten Ubuntu Version bis zur letzten (LTS) relativ problem ubgegraded (Im wesentlichen ging jedesmal fglrx nicht; seid ich eine nvidia Karte drin habe scheint der Ärger auch vorbei zu sein). Ich finde auch, dass es einer der grossen Vorteile von Linux ist, dass das überhaupt geht. Was machst Du denn mit sonstiger Software (soll heissen ausser E-Mail, Web Browser, Skype und co.)? Weisst Du immer noch woher, Du welche Software hattest? Was machst Du mit mühsam vorgenommenen Einstellungen und Anpassungen?

Zu 3.: Vielen Dank. Den Screen Shot hatte ich mir auch so ungefähr vorgestellt. Allein bei mir ist immer nur fglrx angeboten.
Zur xorg.conf: Ich habe kürzlich fglrx "halb" ans laufen bekommen. Anscheinend war dann aber keine 3D Unterstützung vorhanden: glxgears mit einer Fehlermeldung ab. Idem bei glxinfo. Mir fiel auch noch auf, dass Du keine Optionen bzgl. Videobeschleunigung in der xorg.conf hast. Ist das mittlerweile Standard bei fglrx.
Meine letzte xorg.conf hatte folgende Device Section:

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "TexturedVideo" "on"
Option "TexturedVideoSync" "on"
Option "TexturedXRender" "on"
Option "Desktopsetup" "s"
Option "OffscreenPixmaps" "on"
EndSection

Zu 4.: Bei der Tastatur habe ich den Eindruck, dass die Tasten am Anfang besser gingen. Hoffentlich wird das nicht schlimmer, sonst muss man am Ende noch den Rechner in Kontaktspray duschen.

Nochmal zum Sound: Hast Du eine Idee woran das liegen könnte? Ich glaube, dass das Problem erst besteht seid ich radeon als Grafiktreiber verwende. Der sollte natürlich nichts mit dem Sound zu tun habe, aber ...?
Wie kann ich da weiter vorantasten?

Noch eine Frage: ist mittlerweile das Problem bzgl. fglrx behoben, dass bei aktivierten Desktopeffekten Video, Google Earth etc. so fürchterlich flimmern? Hast je probiert DRI2 in xorg.conf zu aktivieren?
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 10.12.2008 15:24

1.
Zunächst zum fglrx-Treiber. Das Problem mit dem Flimmern bei aktivierten Desktopeffekten ist noch nicht behoben. Siehe beispielsweise http://ubuntuforums.org/showthread.php?t=969418
DRI2 habe ich bislang noch nicht verwendet.

2.
Ich sehe, dass du eine andere (höhere) Kernelversion als ich verwendest. Was den Kernel generell betrifft, so nehme ich, wenn es nicht irgend welche zwingenden Gründe dafür gibt (z. B. bessere Hardwareunterstützung), niemals ein Kernelupdate vor.

3.
Bevor ich eine neue Ubuntu-Version installiere, baue ich mir immer mein "eigenes" Ubuntu. Dies erleichtert die Installation auf meinen Rechnern sowie auf den Rechnern einiger Verwandter und Freunde erheblich. Ich verwende dazu UCK > http://wiki.ubuntuusers.de/Ubuntu_Customization_Kit Dabei wechsle ich in die Konsole und lasse ein selbst gebasteltes Script durchlaufen. Dieses Script spielt mir u.a. automatisch alle Pakete/Prgogramme ein (ca. 700 MB, darunter alles, was so an Multimedia-Software benötigt wird), die ich schon unter früheren Versionen genutzt habe. Dies auf der Basis einer upgedateten Paketliste aus der jeweils vorherigen Ubuntu-Version (siehe zum Einstieg http://wiki.ubuntuusers.de/apt-get#Paketlisten , Paketliste zur Wiederherstellung erzeugen). Allenfalls erforderliche Anpassungen nach der Installation (z. B. fglrx-Treiber installieren, Schriftgröße ändern) muss ich natürlich neuerlich vornehmen. Dies ist meistens aber in realtiv kurzer Zeit erledigt.

4.
Zum Sound: Ich habe mal eine Alpha-Version von Ubuntu 8.10 probiert. Unter der Alpha-Version hatte ich zunächst keinen Sound.
Nachdem ich das Paket pulseaudio (PulseAudio sound server) entfernt und unter System > Einstellungen > Audio bei Audiowiedergabe -und -aufnahme ALSA eingestellt hatte, lief der Sound nach einem Neustart. Du könntest ja mal versuchen, ob das bei dir Verbesserungen bringt.
Wenn du das Paket pulseaudio entfernst, wird auch das Paket ubuntu-desktop entfernt. Das ist aber nicht weiter problematisch (dieses Paket soll reibungslose Upgrades gewährleisten, ist aber nicht zwingend erforderlich).
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 10.12.2008 22:33

Hallo Enigma,

vielen Dank für den Hinweis in 3. Werde ich beim nächsten mal wohl auch so machen.

Habe eben den brandneuen fglrx installiert (catalyst 8.12). Immerhin läuft damit der Xserver. Desktop Effekt gehen auch. Was direkt rendering angeht ist die Situation merkwürdig:
Code: Alles auswählen
# glxinfo |grep render
gibt folgendes aus:
Code: Alles auswählen
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: ATI Mobility Radeon HD 2600 XT


(Weist Du, wo ich LIBGL_DEBUG=verbose setzen muss? Ich habe es mal in der Shell gesetzt (wobei ich mir nicht sicher war, ob ich sowas wie: export LIBGL... sagen muss. Und wo würde ich dann mehr erfahren? In glxinfo??) Übrigens stürzt glxinfo mit einem Segmentation fault ab. Ähnliches bei fglxinfo
Code: Alles auswählen
# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 2600 XT
OpenGL version string: 1.4 (2.1.8304 Release)

Segmentation fault


Ferner:
Code: Alles auswählen
 # fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request:  GLXBadDrawable
  Major opcode of failed request:  145 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  41
  Current serial number in output stream:  41
Segmentation fault

Aber glxgears läuft und liefert >13000 frames in 5 Sekunden.
Auch google earth läuft, nur flimmert es immer noch wenn Desktop Effekt an sind.

Nochmal eine Frage zur WEBcam: weisst Du wie das Treiber Kernel Modul heist und wie ich nachprüfen kann, ob es in meinem Kernel kompiliert wurde. Mit "lsmod" kann ich doch nur Module sehen, die auch als Modul kompiliert und geladen wurden, oder?


Nachtrag:
Habe in den Kernel Message geschaut, was zu den Abstüzen steht:
Code: Alles auswählen
 glxinfo[7496]: segfault at 3d4 ip 00007fdfbf3af221 sp 00007fffc75b88a0 error 4 in ld-2.8.90.so[7fdfbf39a000+1f000]

Bei der Suche nach was ähnlichem habe ich auf einem Französischen Forum den Hinweis gesehen, dass ein ähnliches Problem nur beim root User auftritt. Bei mir ist es genauso:
Mit meinem normalen User läuft fgl_gears und liefert biszu >7000 frames in 5s. Woran kann nun das wieder liegen??
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54
Notebook:

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 11.12.2008 14:37

1. Zur Webcam_

Der Treiber heißt gspca_m5602 Es ist bereits im Kernel enthalten (braucht also nicht hineinkompiliert werden)



Code: Alles auswählen
modinfo gspca_m5602


zeigt bei mir:

Code: Alles auswählen
filename:       /lib/modules/2.6.27-7-generic/kernel/drivers/media/video/gspca/m5602/gspca_m5602.ko
license:        GPL
description:    ALi m5602 webcam driver
author:         ALi m5602 Linux Driver Project
srcversion:     CF9C47530056A5905618C51
alias:          usb:v0402p5602d*dc*dsc*dp*ic*isc*ip*
depends:        gspca_main,usbcore
vermagic:       2.6.27-7-generic SMP mod_unload modversions 586
parm:           force_sensor:force detection of sensor, 1 = OV9650, 2 = S5K83A, 3 = S5K4AA, 4 = MT9M111, 5 = PO1030 (int)
parm:           dump_bridge:Dumps all usb bridge registers at startup (bool)
parm:           dump_sensor:Dumps all usb sensor registers at startup providing a sensor is found (bool)


Code: Alles auswählen
lsmod | grep gspca_m5602


zeigt

Code: Alles auswählen
gspca_m5602            77068  2
gspca_main             30208  1 gspca_m5602
usbcore               148848  7 gspca_m5602,gspca_main,btusb,usbhid,ehci_hcd,uhci_hcd



2. zum Grafiktreiber:

LIBGL_DEBUG=verbose ist ein Dagnostikinstrument für die Shell > https://help.ubuntu.com/community/Binar ... leshooting

Verwendung:
Code: Alles auswählen
LIBGL_DEBUG=verbose glxinfo


Bei mir zeigen:

Code: Alles auswählen
glxinfo | grep render


Code: Alles auswählen
direct rendering: Yes
OpenGL renderer string: ATI Mobility Radeon HD 2600 XT


Code: Alles auswählen
fglrxinfo


Code: Alles auswählen
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 2600 XT
OpenGL version string: 2.1.8087 Release


Code: Alles auswählen
fgl_glxgears


Code: Alles auswählen
Using GLX_SGIX_pbuffer
4758 frames in 5.0 seconds = 951.600 FPS
6083 frames in 5.0 seconds = 1216.600 FPS
6248 frames in 5.0 seconds = 1249.600 FPS
5708 frames in 5.0 seconds = 1141.600 FPS
6617 frames in 5.0 seconds = 1323.400 FPS
6570 frames in 5.0 seconds = 1314.000 FPS
7314 frames in 5.0 seconds = 1462.800 FPS
6668 frames in 5.0 seconds = 1333.600 FPS
6868 frames in 5.0 seconds = 1373.600 FPS


Mir scheint , dass das Hauptproblem der Linux-Kernel (Paket linux-generic) in der Version 2.6.27.9.13 ist. Du könntest versuchen, ob es bei einem Kernel-Downgrade weniger Probleme gibt:
Zum Kerne-Downgrade: Synaptic öffnen, Paket linux-generic suchen, mit der Maus auf linux-generic fahren, dann Strg + e drücken und Version
2.6.27.7.11 erzwingen wählen (siehe dazu auch http://wiki.ubuntuusers.de/Synaptic#Ver ... -erzwingen ). Dann ein Backup der /etc/X11/xorg.conf anlegen und die xorg.conf durch die ursprüngliche xorg.conf (mit Eintrag: Driver "vesa") ersetzen (ansonsten bleibt nach einem Reboot wahrscheinlich der Bildschirm schwarz). Schließlich rebooten.

Sonstiges:
Die von mir verwendeten fglrx-Pakete (xorg-driver-fglrx, fglrx-modaliases, fglrx-kernel-source, fglrx-amdcccle) - jeweils in der Version 2:8.543-0ubuntu4 - stehen hier zum Download bereit: http://packages.ubuntu.com/intrepid/i386/allpackages
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 11.12.2008 23:57

Hallo Enigma,

ich habe Fortschritte gemacht:
1. Sound geht jetzt meist, selbst mit Pulse. (Nicht immer: bei Sykpe hat sich Pulse irgendwie aufgehängt, ich musste dann HDA Intel(hw: Intel,0) als Sounddevice wählen, dann ging es wieder. Es mag auch daran gelegen haben, dass ich wie wild versucht habe die Mixereinstellungen zuändern, was Skype/Pulse vielleicht nicht gefallen hat.Nach einem Neustart werde ich nochmal Pulse mit Skype probieren.)

2. Die Web Cam geht. Ich habe nach dem von Dir genannten Treiber gesucht und Bug-reports gefunden, die berichten, dass für viele WebCam die Unterstützung kürzlich kaputtgegangen ist. Eine Lösung sollte sein, das Modul selbst zu kompilieren und zu installieren. (Mich wundert ja, dass man über ein in den Kernel kompiliertes Modul ein anderes drüberladen kann ... :shock: ). Habe mir dann von http://linuxtv.org/hg/v4l-dvb die Sourcen geholt und kompiliert/installiert. Und siehe da, einmal Fn-F7 gedrückt und die Leuchtdiode der Kamera geht an. Auch der Treiber ist jetzt wie an Dir beschrieben bei den Hardwaretreibern gelistet. Ich habe dann mal Skype probiert und Video geht! Allein ist das Bild VIEL zu dunkel, man sieht fast nichts (nein ich sitze nicht im dunkeln ... :wink: ). Ich suche jetzt noch nach einer Möglichkeit die Bildparameter einzustellen. Kennst Du das was?

3. fglrx geht jetzt eigentlich auch recht gut. Warum fglrxinfo u.ä. abstürzen, wenn man sie mit Rootrechten ausführt, ist mir eigentlich mittlerweile egal. Die grafische Benutzeroberfläche fahre ich ja eh nie als root. Vielleicht sind für root irgendwelche Pfade nicht richtig gesetzt. Ich habe mir die Pakete jetzt mit dem Tool vom AMD selbst gebaut.
LIBGL_DEBUG=verbose zu setzen hilft auch nicht. Die Ausgabe von glxinfo wird nicht gesprächiger; vielleicht kommt der Segmentation Fault bevor er mir verraten kann, was er will...?

Ich habe gesehen, dass man mit fglrx_xgamma das gamma verstellen kann. Ich war auch mit der normalen Farbwiedergabe nicht zufrieden: zu wenig rot. Verwundert hat mich, dass man gamma < 1 setzen muss, um ein besseres Bild zu bekommen. Ich habe r g und b separat eingestellt und bin mit rgamma = 0.75 ggamma = 0.65 und bgamma= 0.6 recht zufrieden. Bin mal gespannt, ob die Werte nach dem Neustart noch da sind. Ich glaube mal Parameter für die xorg.conf für gamma gesehen zu haben, weiss aber nicht mehr wie die aussahen und wo ich die gefunden habe. Hast Du auch etwas an den gamma Werten verändert?

Hast Du noch einen Tip wie man dieses lästige hängenbleiben beim Booten verhindern kann. Soweit ich ausprobiert habe, reicht es auf eine belibiege Taste zu drücken. Das deutet vielleicht auf Probleme mit dem Power Saving Modes etc hin, oder?

Vielen Dank jedenfalls für die Hilfe!!
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54
Notebook:

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 12.12.2008 15:30

1.
Die gamma-Werte habe ich gleichfalls verändert. Dazu habe ich das Catalyst Control Center (GUI) verwendet.
Du brauchst einfach das Paket fglrx-amdcccle downloaden. Das Catalyst Control Center findest du anschließend unter Anwendungen > Zubehör. Die geänderten Einstellungen bleiben dauerhaft wirksam.

Alternativen:
a) gamma-Einträge in der xorg.conf in der Section "Monitor" vornehmen: Beispiel: http://ubuntuforums.org/showthread.php?t=341416
b) gamma-Werte in ein Shell-Script schreiben und dieses beim Booten automatisch ausführen lassen: siehe http://forum.ubuntuusers.de/post/1653813/

2.
Der Webcam-Treiber wurde erst vor Kurzem entwickelt. Laut http://wiki.ubuntuusers.de/Hardware_blacklist#Webcams arbeiten die Treiber-Entwickler ohne Unterstützung des Herstellers (Ali Corp.). Bei mir ist das Bild ebenfalls viel zu dunkel. Damit die Webcam besser funktioniert, muss der Teiber optimiert werden.

3.
Zum Booten: Probiere es mit dem Kernelparameter clocksource=hpet in der /boot/grub/menu.lst

Beispiel:

Code: Alles auswählen
title      Ubuntu 8.10
root      (hd1,2)
kernel      /boot/vmlinuz-2.6.27-7-generic root=/dev/sdb3 ro quiet clocksource=hpet
initrd      /boot/initrd.img-2.6.27-7-generic
quiet
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 24.12.2008 00:32

Hallo Enigma,

habe Fortschritte mit der WebCam gemacht: Hab mir die Quellen angeschaut; demnach scheint wirklich wenig, insbesondere über den Sensor, bekannt zu sein.
Bei der Initialisierung, die in m5602_s5k4aa.h definiert wird, lässt sich die Helligkeit auf ein vernünftiges Maß anheben. Dabei sieht man dann auch, dass die Bilder grau mit leichten Farbtönen sind und nicht wirklich "normal"-farben. Nach einigem Probieren habe ich herausgefunden, dass ein Offset falsch gesetzt war (muss ungerade sein und war gerade). Dadurch wurden die Farbkanäle von verschiedenen Pixeln in einem Pixel gemischt. Jedenfalls bekomme ich nach der Korrektur jetzt ganz ansehnliche Bilder. Wenn Du was zu den Details wissen willst, schreib kurz dann paste ich die gepatchte Datei. Interessant ist auch, dass zZ nur 640x480 unterstützt wird, was allerdings durch das Auslassen Pixeln eines 1280*960 Bildes gemacht wird. Sobald ich verstanden habe, wo (in welcher Datei) und wie das eigentliche Lesen der Sensordaten implementiert ist, will ich mal probieren, die volle Auflösung zu lesen und die kleine Auflösung durch Interpolation zu gewinnen. Das sollte bessere Bildqualität liefern.

Ich vermute, dass zur Zeit mehr oder weniger keinerlei IOCTLs richtig an den Subdriver durchgereicht werden. Denn immerhin sind für unseren Sensor Methoden zur Änderung der Helligkeit (gain), der Belichtungszeit (exposure) und zum Spiegel des Bildes an beiden Achsen definiert. Trotzdem habe ich kein Programm finden können, dass diese Parameter ändert. (Z.B. Ekiga hat Kontrols).
Ich suche zur Zeit noch nach einem Register zum Einstellen von Hue und Saturation. Wenn Du Dich an der Suche beteiligen magst, schreib kurz, dann poste ich, was ich schon probiert habe.

Anscheinend kann man irgendwo Debugging einschalten. Ich weiss aber nicht wo? Beim Laden des Kernelmoduls? Wie heisst der Parameter?? Wo bekommt man die Ausgaben zu sehen?

Bin für weitere Hinweise dankbar.
Schöne Weihnachten.
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54
Notebook:

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 28.12.2008 12:08

Hallo patbeppo!

Du hast dich - wie ich sehe - intensiv mit der Webcam befasst. Ich wäre dir dankbar, wenn du die gepatchte Datei hier uploaden würdest.
Da andere User sicherlich auch daran interessiert sind, mit der Webcam ansehnliche Bilder zu produzieren, wäre es überdies sehr vorteilhaft, wenn du eine kurze Anleitung verfassen könntest, wie dies zu bewerkstelligen ist. Ich würde dann in meiner Anleitung einen Link auf dein Posting setzen.

Ich selbst habe mich nicht mehr näher mit der Webcam befasst und möchte derzeit auch nicht Zeit in eine Optimierung der Funktionalität dieser Hardwarekomponente unter Linux investieren.

Zum Debugging habe ich leider auch nichts gefunden.

Viele Grüße
enigma
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 29.12.2008 12:06

Wird gemacht. Ich will noch erst mit einem der Entwickler Kontakt aufnehmen. Dann werden meine Patches vielleicht hinfällig. Wenn Du an einer Zwischenlösung interessiert bist, melde dich.

In der Zwischenzeit habe ich noch Fragen zum Sound: Ich verliere immer wieder den Center Lautsprecher, soll heissen, er erscheint schon noch im Mixer aber aus dem Lautsprecher kommt nichts raus. Nach einigem rumprobieren und Neuinstallieren von Teilen von Alsa bekam ich ihn wieder zum Laufen. Jetzt ist er schon wieder weg. Ich weiss werder, warum(durch welche Aktionen) ich ihn verliere, noch wie ich ihn genau wieder bekomme. Weisst Du was dazu?

Ausserdem ist mir noch folgendes aufgefallen: Wenn man FN-F4 (oder F5) zum Verstellen der Lautstärke drückt wird die Lautstärke immer bin zum Anschlag geändert, soll heissen: es ist nicht möglich von einer mittleren Lautstärke eine etwas lautere einzustellen, die eben nicht die maximale ist. Das Problem lässt sich umgehen, indem man SOFORT eine andere Taste nach betätigen der Tastenkombination drückt. Verhält sich das bei Dir auch so?

Zu den Sondertasten noch eine andere Frage: Weisst Du, wozo FN-F6 da ist? Schaltet FN-F10 den externen Monitoranschluss? Funktioniert die Taste rechts neben Lautsprecher stumm schalten bei Dir? (Welche Funktion hat sie?)
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54
Notebook:

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 29.12.2008 13:45

An der "Zwischenlösung" bin ich interessiert.

Wenn ich FN-F4 (oder F5) zum Verstellen der Lautstärke drücke, wird die Lautstärke auch bei immer bin zum Anschlag geändert.
Alternative: Das Xi2550 ist mit einer LightTouchTM bar ausgestattet (oberhalb der Tastatur) Ganz rechts befindet sich die Lautstärkeregler-Leiste.
Die Lautstärke kann erhöht [ + ] oder verringert [ - ] werden, indem man den Finger über die Lautstärkeregler-Leiste bewegt. Das funktioniert bei mir einwandfrei (jede beliebige Lautstärke kann gewählt werden).

Zu Fn-FN6: Damit kann man das Touchpad aus-/einschalten (funktioniert bei mir einwandfrei).

Zu Fn-F10: (Zitat aus dem Xi2550-Handbuch:
"Bildschirmausgabe umschalten.
Wenn Sie einen externen Bildschirm angeschlossen haben,
können Sie mit dieser Tastenkombination auswählen, auf
welchem Bildschirm die Ausgabe erfolgen soll.
Die Bildschirmausgabe ist möglich:
• nur am LCD-Bildschirm des Notebook (LCD)
• gleichzeitig am LCD-Bildschirm des Notebook und am
externen digitalen Bildschirm mit HDMI-Anschluss
• gleichzeitig am LCD-Bildschirm des Notebook und am
externen analogen Bildschirm
• gleichzeitig am externen digitalen Bildschirm mit
HDMI-Anschluss und am externen analogen Bildschirm
Die Bildschirmausgabe ist abhängig vom integrierten
Grafik-Controller und von den Displayeinstellungen im NVIDIA
Control Panel bzw. im ATI -CATALYST® Control Center. In der
Grafikhersteller-Software sind weitere Display-Einstellungen
möglich. Die Bildschirmausgabe ist auf maximal zwei Bildschirme
gleichzeitig begrenzt.")

Rechts neben Lautsprecher stumm schalten (F3) befindet sich F4 (Lautstärke verringern; siehe dazu oben). Meintest du eine andere Taste?

Zum Mixer: Das von dir beschriebene Problem ist bei mir seit der Installation von Ubuntu 8.10 kein einziges Mal aufgetreten. Allerdings verwende ich eine andere (nämlich die ursprüngliche Kernel-Version; ich habe kein Kernel-Update vorgenommen).

Befindet sich in deiner /etc/modprobe.d/alsa-base der Eintrag

Code: Alles auswählen
options snd-hda-intel model=lenovo-ms7195-dig


PS:
Von http://support.fujitsu-siemens.at/at/su ... nuals.html kannst du verschiedene Handbücher für das Xi2550 downloaden.
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon patbeppo » 06.01.2009 01:37

Hallo Enigma,

danke für die Antwort. Die Soundprobleme habe ich noch nicht lösen können. Wie Du auch schon schriebst, scheinen die durch Pulse versacht zu sein.
Ich denke zur Zeit noch über eine Neuinstallation nach. Vielleicht wird es ja dann besser. Die Baustelle mit der WEB Cam reicht mir zur Zeit. Hier meine "Zwischenlösung":

1. Quellen von http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.gz herunterladen, an geeignete Stelle kopieren (z.B. ins Home Verzeichnis) und dort entpacken:
Code: Alles auswählen
tar xvfz [filename der Datei]


2. In das generierte Verzeichnis wechseln (hat einen Namen so ähnlich wie v4l-dvb-77f789d59de, wobei der hintere Teil vermutlich anders aussieht, weil er sich mit jedem built ändert)

3. In folgendes Unterverzeichnis wechseln:
Code: Alles auswählen
cd linux/drivers/media/video/gspca/m5602


4. Die Datei m5602_s5k4aa.h editieren, z.B.
Code: Alles auswählen
gedit m5602_s5k4aa.h


5. Am Ende der Datei folgende Änderungen, erkenntlich durch meine Kommentare (/*BN ...*/) vornehmen:
Code: Alles auswählen
   {SENSOR, S5K4AA_ROWSTART_HI, 0x00, 0x00},
   {SENSOR, S5K4AA_ROWSTART_LO, 0x01, 0x00}, /*BN  war 2a */
   {SENSOR, S5K4AA_COLSTART_HI, 0x00, 0x00},
   {SENSOR, S5K4AA_COLSTART_LO, 0x0c, 0x00},
   /* window_height_hi, window_height_lo : 960 = 0x03c0 */
   {SENSOR, S5K4AA_WINDOW_HEIGHT_HI, 0x03, 0x00},
   {SENSOR, S5K4AA_WINDOW_HEIGHT_LO, 0xc0, 0x00},
   /* window_width_hi, window_width_lo : 1280 = 0x0500 */
   {SENSOR, S5K4AA_WINDOW_WIDTH_HI, 0x05, 0x00},
   {SENSOR, S5K4AA_WINDOW_WIDTH_LO, 0x00, 0x00},
   {SENSOR, S5K4AA_H_BLANK_HI__, 0x00, 0x00},
   {SENSOR, S5K4AA_H_BLANK_LO__, 0xa8, 0x00},
   {SENSOR, S5K4AA_EXPOSURE_HI, 0x06, 0x00}, /* BN war 01 */
   {SENSOR, S5K4AA_EXPOSURE_LO, 0x3f, 0x00}, /* BN war 00 */
   {SENSOR, 0x11, 0x04, 0x00},
   {SENSOR, 0x12, 0xc3, 0x00},
   {SENSOR, S5K4AA_PAGE_MAP, 0x02, 0x00},
   {SENSOR, 0x02, 0x0e, 0x00},
/*   {SENSOR_LONG, S5K4AA_GLOBAL_GAIN__, 0xff, 0xff}, */ /*BN war 0f,00; hat keinen Effekt */
   {SENSOR, S5K4AA_GAIN_1, 0x10, 0x00}, /* BN war 0b,00*/
   {SENSOR, S5K4AA_GAIN_2, 0x5f, 0x00} /* BN war a0,00*/
};

#endif


6. Die Cam ausschalten: FN-F7 drücken. LED sollte ausgehen.

7. Zurück ins Verzeichnis v4l_dbv_... welchseln. Dort eingeben
Code: Alles auswählen
make; make install


7. Fall es keinen Fehler gab: FN-F7 drücken. LED sollte wieder angehen.

8. Testen: z.B. mit skype (optionen->video), oder mit pixfmt-test, das sich im Unterverzeichniss v4l2-apps/test befindet und noch kompiliert werden muss.

9. Sehr nützlich ist auch qv4l2 (ein Kontrolpanel zum Einstellen von Exposure und gain (Achtung: das Speichern von Defaultwerten funktioniert nicht und bringt den Treiber so doll durcheinander, dass man das Kernel Modul neu laden muss (FN-F7 zweimal drücken)) im Unterverzeichnis v4l2-apps/util/qv4l2, welches ebenfall kompiliert werden muss. Es benötigt die Library libv4l2.so
Diese muss durch make; make install im Verzeichnis v4l2-apps/lib erzeugt werden. qv4l2 benötigt qmake, welches im Paket qt3-dev-tools enthalen ist und vor dem Kompilieren installiert werden muss.


Ich hoffe nichts vergessen zu haben. Sonst in die READMEs schauen. Nützlich fand ich auch http://moinejf.free.fr/gspca_README.txt
patbeppo
 
Beiträge: 10
Registriert: 06.09.2008 21:54
Notebook:

Re: Ubuntu 8.10 auf Amilo Xi2550 - Tipps

Beitragvon enigma » 08.01.2009 15:41

Hallo patbeppo!

Vielen Dank für das Howto!

Ich habe mittlerweile zwei v4l-dvb-builts unter Vornahme der von dir geposteten Änderungen der m5602_s5k4aa.h getestet (v4l-dvb-ce8589c52a7f und v4l-dvb-7c430437c967).

Leider erhalte ich jetzt nur noch Bilder mit Grünfärbung (etwa anderes als grün ist nicht zu erkennen). Das Ganze ist aber nicht problematisch, weil ich meine Partition zuvor mit partimage > http://wiki.ubuntuusers.de/partimage gesichert habe und die gesicherte Version binnen weniger Minuten wieder einspielen kann.
Ich werde in der nächsten Zeit noch Versuche mit anderen builts unternehmen.

Ergänzend wäre anzumerken, dass vor Ausführung des Howtos die für das Kompilieren erforderlichen Pakete downgeloadet werden müssen (einfach

Code: Alles auswählen
sudo apt-get install build-essential linux-headers-$(uname -r)


ausführen) und die beiden letzten Befehle

Code: Alles auswählen
make
sudo make install


lauten müssten.
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550

Nächste

Zurück zu Erfahrungsberichte / Tests

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron