amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

XI 2550 / Fedora 12 und OpenSuSE 11.2 Thema ist gelöst

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

XI 2550 / Fedora 12 und OpenSuSE 11.2  Thema ist gelöst

Beitragvon SchorschiAC » 07.12.2009 14:57

Hallo Amilo-Freunde,

ich benutze zurzeit einen Amilo XI 2550 und habe bisher ohne Probleme mit Fedora 10, Opensuse 11.1 und Ubuntu 8.04 LTS gearbeitet.

Jetzt wollte ich die neuen Versionen von Opensuse 11.2 bzw Fedora 12 ausprobieren und habe diese aufgespielt. Mein Problem: Der Amilo Xi 2550 zeigt bei beiden Linux-Distributionen Timing-Probleme, die sich durch Stehenbleiben der angezeigten Uhrzeit bzw. Stehenbleiben des Mauscursors äußern. Sobald ich das Touchpad oder die Tastatur bediene läuft der Rechner weiter. Allerdings muß ich die Uhr dann immer mit "date -s" neu stellen.

Unter Fedora 12 habe ich in der messages-Datei folgende Meldungen sehen können, die geschrieben werden, wenn der Fehler auftritt:

Code: Alles auswählen
localhost kernel: iwlagn 0000:04:00.0: Microcode SW error detected.  Restarting 0x82000000.
localhost kernel: Registered led device: iwl-phy0::radio
localhost kernel: Registered led device: iwl-phy0::assoc
localhost kernel: Registered led device: iwl-phy0::RX
localhost kernel: Registered led device: iwl-phy0::TX

und / oder

localhost rtkit-daemon[1523]: The poor little canary died! Taking action.

und / oder

kernel: psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.


Unter Opensuse 11.2 hatte ich folgende Medung:

Code: Alles auswählen
kernel: [ 1088.224964] iwlagn 0000:04:00.0: Microcode SW error detected.  Restarting 0x82000000.
kernel: [ 1088.464496] Registered led device: iwl-phy0::radio
kernel: [ 1088.464581] Registered led device: iwl-phy0::assoc
kernel: [ 1088.464648] Registered led device: iwl-phy0::RX
kernel: [ 1088.464726] Registered led device: iwl-phy0::TX
kernel: [ 1156.568265] iwlagn 0000:04:00.0: Microcode SW error detected.  Restarting 0x82000000.
kernel: [ 1156.591554] iwlagn 0000:04:00.0: No space for Tx
kernel: [ 1156.591587] iwlagn 0000:04:00.0: Error sending SENSITIVITY_CMD: enqueue_hcmd failed: -28
kernel: [ 1156.591613] iwlagn 0000:04:00.0: SENSITIVITY_CMD failed


Das Ausschalten von WLAN per Hardwareknopf bzw. das Blacklisten des Treibers IWLAGN brachte jedoch keine Besserung - zwar entfiel die Meldung, aber die Timing-Probleme blieben.

Hat jemand o.g. Systeme ohne Timing-Probleme einrichten können?

Oder hat jemand sonst eine Idee, woran das liegen könnte?

VG Georg
SchorschiAC
 
Beiträge: 4
Registriert: 07.12.2009 14:18
Notebook:
  • Amilo XI 2550

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon naraesk » 07.12.2009 15:26

Hallo.

unter Open Suse hatte ich dieses einfrieren auch. Ich hatte es aber nur 1-2 Tage zum Testen installiert und habe ich daher nicht um eine Lösung bemüht oder Ursachenforschung betrieben.

Deine Meldungen konnte ich jetzt in meiner /var/log/messages bei Fedora 12 nicht finden und habe auch diese Probleme nicht. Lediglich den "iwlagn"- Fehler habe ich auch schon gehabt. Der ist auf eine fehlerhafte Firmware für den WLAN- Chip zuruck zu führen, siehe auch hier: http://www.fedoraforum.de/viewtopic.php?f=5&t=18383. Funktioniert bei dir das WLAN etwa problemlos?
naraesk
 
Beiträge: 32
Registriert: 19.02.2009 14:11

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon hikaru » 07.12.2009 15:34

Auch unter Debian ist der Bug bekannt, allerdings tritt er seit Kernel 2.6.30-2 wohl nicht mehr auf:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548749
Ich vermute dass das aktuelle Ubuntu auch betroffen ist.

Von welchen Architekturen sprechen wir hier? Und habt ihr schon mal gewechselt?

PS:
Crosspostings in Zukunft bitte verlinken:
http://www.linux-club.de/viewtopic.php?f=19&t=106540
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon SchorschiAC » 07.12.2009 18:39

Hallo,

erst einmal vielen Dank für Eure Beiträge.
naraesk hat geschrieben:unter Open Suse hatte ich dieses einfrieren auch.

Da bin ich ja schon mal froh, dass ich nicht alleine bin.

naraesk hat geschrieben:Lediglich den "iwlagn"- Fehler habe ich auch schon gehabt. Der ist auf eine fehlerhafte Firmware für den WLAN- Chip zuruck zu führen, ...

Irgendwie bin ich davon überzeugt, dass das kurzzeitige Einfrieren des Systems nicht mit IWLAGN zu tun hat, denn es kommt ja wie gesagt auch vor, wenn ich IWLAGN blackliste und ausschalte. Ich denke da mehr an ein Folgefehler oder unabhängiger Fehler. Ich habe eben mal die IWL-Firmware von OpenSuse 11.1 auf 11.2 portiert (damit hatte ich ja keine Probleme). Das Timing-Problem tritt nach wie vor auf.

naraesk hat geschrieben:Funktioniert bei dir das WLAN etwa problemlos?

Ja, bis zu dem Freeze-Zeitpunkt nach einigen Minuten habe ich keine Probleme. Steht der Rechner, berühre ich nur das Touchpad oder die Tastatur. Dann gehts weiter.

hikaru hat geschrieben:Auch unter Debian ist der Bug bekannt, allerdings tritt er seit Kernel 2.6.30-2 wohl nicht mehr auf

Unter Opensuse benutze ich den Kernel 2.6.31.5 und unter Fedora 2.6.31.6. Aber der Fehler scheint noch nicht aus dem Kernel verschwunden zu sein.

hikaru hat geschrieben:Von welchen Architekturen sprechen wir hier? Und habt ihr schon mal gewechselt?

Ich benutze immer noch die x86-Architektur. Gewechselt habe ich noch nicht.

Weitere Versuche, die bisher fehlgeschlagen sind:

Code: Alles auswählen
clocksource=acpi_pm # statt standardmäßigem hpet

,da ich im message-log auch ein "Clocksource tsc unstable" gefunden habe.

Code: Alles auswählen
i8042.reset i8042.nomux i8042.nopnp i8042.noloop

, da ich ab und an mal einen nicht zu bewegenden Mauszeiger unter Fedora 12 mit synaptics habe (externe Mäuse funktionieren immer).

Sonst noch jemand Ideen? Kann man solche Fehler irgendwie debuggen?

VG Georg
SchorschiAC
 
Beiträge: 4
Registriert: 07.12.2009 14:18
Notebook:
  • Amilo XI 2550

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon hikaru » 07.12.2009 22:51

Du könntest mal den Suse-11.1-Kernel bzw. den Fedora-11-Kernel installieren und schauen ob das Problem damit verschwindet. Falls ja ist es wohl der Kernel, falls nicht würde ich auf hal tippen wenn es nicht die Firmware ist.
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon SchorschiAC » 08.12.2009 00:08

Hallo ,

ich habs:

Code: Alles auswählen
clocksource=jiffies


als Startparameter übergeben, läßt bei beiden Distributionen alle geschilderten Fehler verschwinden.

:D

Ich weiß zwar nicht, was das heißt ... aber hauptsache es läuft!

VG Georg
SchorschiAC
 
Beiträge: 4
Registriert: 07.12.2009 14:18
Notebook:
  • Amilo XI 2550

Re: XI 2550 / Fedora 12 und OpenSuSE 11.2

Beitragvon enigma » 08.12.2009 19:32

Das von SchorschiAC beschriebene Problem tritt auch unter Ubuntu 9.10 auf.

clocksource=jiffies als Startparameter schafft auch unter Ubuntu 9.10 Abhilfe.

Ubuntu 9.10 verwendet Grub2. Falls Grub2 als Bootloader verwendet wird, ist der Eintrag in der Datei /etc/default/grub vorzunehmen. Siehe Näheres unter http://forum.ubuntuusers.de/topic/clocksource-setzen (Achtung: Im Beitrag heißt es statt /etc/default/grub irrtümlich /etc/defaults/grub)
enigma
 
Beiträge: 85
Registriert: 04.05.2008 21:34
Notebook:
  • Amilo Xi2550


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste