amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Ubuntu fährt beim anstecken des Netzteiles das System runter Thema ist gelöst

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Ubuntu fährt beim anstecken des Netzteiles das System runter

Beitragvon D1Telekom » 06.03.2010 13:11

Hallo zusammen,

ich habe auf meinem Amilo M1437G Windows7 und Ubuntu installiert und beides läuft recht gut, bis auf einen kleinen Schönheitsfehler der nur unter Ubuntu auftritt. Wenn ich den Netzstecker vom Netzteil anstecke oder abziehe wird das System Ubuntu runtergefahren. Auf der Windows - Seite passiert es merkwürdigerweise nicht, so dass ich mal davon ausgehe dass es kein Hardware - Problem ist.
Ich finde aber weder in den Einstellungen etwas, noch habe ich hier im Forum etwas dazu gefunden.

Hat jemand eine Idee oder einen Tipp? Es ist relativ ärgerlich wenn der Akku zur Neige geht und man das Netzteil ansteckt dass dann das System runtergefahren wird. :(

Danke und beste Grüße
Jürgen
D1Telekom
 
Beiträge: 6
Registriert: 06.01.2008 00:39

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru

Beitragvon hikaru » 06.03.2010 13:47

Welche Ubuntuversion hast du?
Passiert das gleiche auch mit anderen Linuxdistributionen?
Steht was auffälliges in?: /var/log/messages
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru

Beitragvon D1Telekom » 06.03.2010 15:08

Hallo,

Danke für die schnelle Antwort:

Da steht: :wink:

Sie verwenden Ubuntu 9.10 - Karmic Koala

In der Datei /var/log/messages steht eine Menge, aber ich kann da nichts unauffälliges entdecken. Ich habe es eben mal
den Netzstecker gesteckt und Linux ist um 14:46 Uhr runtergefahren. Ich bin aber kein Linux-Profi, vielleicht steht da ja
versteckt doch was?

Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.612041] usb 4-1: new full speed USB device using uhci_hcd and address 10
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.786198] usb 4-1: configuration #1 chosen from 1 choice
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.798415] Bluetooth: Generic Bluetooth USB driver ver 0.5
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.798580] usbcore: registered new interface driver btusb
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.845496] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.845500] Bluetooth: BNEP filters: protocol multicast
Mar 6 14:46:27 jwaschke-notebook kernel: [ 89.862901] Bridge firewalling registered
Mar 6 14:46:27 jwaschke-notebook kernel: [ 90.180212] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
Mar 6 14:46:37 jwaschke-notebook kernel: [ 100.160254] input: Microsoft Bluetooth Notebook Mouse 5000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/bluetooth/hci0/hci0:11/input9
Mar 6 14:46:37 jwaschke-notebook kernel: [ 100.160465] generic-bluetooth 0005:045E:0700.0001: input,hidraw0: BLUETOOTH HID v1.00 Mouse [Microsoft Bluetooth Notebook Mouse 5000] on 00:0A:3A:65:5F:2C
Mar 6 14:56:13 jwaschke-notebook kernel: imklog 4.2.0, log source = /var/run/rsyslog/kmsg started.
Mar 6 14:56:13 jwaschke-notebook rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="697" x-info="http://www.rsyslog.com"] (re)start
Mar 6 14:56:13 jwaschke-notebook rsyslogd: rsyslogd's groupid changed to 102
Mar 6 14:56:13 jwaschke-notebook rsyslogd: rsyslogd's userid changed to 101
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpuset
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpu
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Linux version 2.6.31-19-generic (buildd@palmer) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu8) ) #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 (Ubuntu 2.6.31-19.56-generic)
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] KERNEL supported cpus:
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Intel GenuineIntel
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] AMD AuthenticAMD
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] NSC Geode by NSC
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Cyrix CyrixInstead
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Centaur CentaurHauls
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Transmeta GenuineTMx86
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] Transmeta TransmetaCPU
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] UMC UMC UMC UMC
Mar 6 14:56:13 jwaschke-notebook kernel: [ 0.000000] BIOS-provided physical RAM map:


Danke vorab und beste Grüße
Jürgen
D1Telekom
 
Beiträge: 6
Registriert: 06.01.2008 00:39

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru

Beitragvon hikaru » 06.03.2010 15:43

In dem Log steht nichts verdächtiges. Kannst du bitte das gleiche nochmal für /var/log/syslog machen? Das Log für den fraglichen Zeitraum ist vermutlich schon archiviert als syslog.1 bzw. syslog.?.gz

Hattest du mit früheren Ubuntuversionen das Problem auch schon?
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru

Beitragvon D1Telekom » 06.03.2010 16:17

Habe um 16:07 Uhr den Netzstecker gesteckt und Notebook ist wie immer runter gefahren!!!

Hier Auszug aus messages:
Mar 6 15:11:25 jwaschke-notebook kernel: [ 53.096367] padlock: VIA PadLock not detected.
Mar 6 16:01:11 jwaschke-notebook kernel: [ 3034.358538] input: Microsoft Bluetooth Notebook Mouse 5000 as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/bluetooth/hci0/hci0:11/input10
Mar 6 16:01:11 jwaschke-notebook kernel: [ 3034.358729] generic-bluetooth 0005:045E:0700.0002: input,hidraw0: BLUETOOTH HID v1.00 Mouse [Microsoft Bluetooth Notebook Mouse 5000] on 00:0A:3A:65:5F:2C
Mar 6 16:08:16 jwaschke-notebook kernel: imklog 4.2.0, log source = /var/run/rsyslog/kmsg started.
Mar 6 16:08:16 jwaschke-notebook rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="707" x-info="http://www.rsyslog.com"] (re)start
Mar 6 16:08:16 jwaschke-notebook rsyslogd: rsyslogd's groupid changed to 102
Mar 6 16:08:16 jwaschke-notebook rsyslogd: rsyslogd's userid changed to 101
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpuset
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpu
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Linux version 2.6.31-19-generic (buildd@palmer) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu8) ) #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 (Ubuntu 2.6.31-19.56-generic)
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] KERNEL supported cpus:
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Intel GenuineIntel
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] AMD AuthenticAMD
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] NSC Geode by NSC
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Cyrix CyrixInstead
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Centaur CentaurHauls
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Transmeta GenuineTMx86
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Transmeta TransmetaCPU
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] UMC UMC UMC UMC
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] BIOS-provided physical RAM map:
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)


Hier Auszug aus syslog:
Mar 6 16:02:19 jwaschke-notebook wpa_supplicant[901]: CTRL-EVENT-SCAN-RESULTS
Mar 6 16:04:19 jwaschke-notebook wpa_supplicant[901]: CTRL-EVENT-SCAN-RESULTS
Mar 6 16:06:19 jwaschke-notebook wpa_supplicant[901]: CTRL-EVENT-SCAN-RESULTS
Mar 6 16:07:40 jwaschke-notebook anacron[4962]: Anacron 2.3 started on 2010-03-06
Mar 6 16:07:40 jwaschke-notebook anacron[4962]: Normal exit (0 jobs run)
Mar 6 16:07:41 jwaschke-notebook anacron[5042]: Anacron 2.3 started on 2010-03-06
Mar 6 16:07:41 jwaschke-notebook anacron[5042]: Normal exit (0 jobs run)
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> Sleeping...
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): now unmanaged
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): device state change: 8 -> 1 (reason 37)
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): deactivating device (reason: 37).
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): canceled DHCP transaction, dhcp client pid 2566
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <WARN> check_one_route(): (eth1) error -34 returned from rtnl_route_del(): Sucess#012
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): cleaning up...
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth1): taking down device.
Mar 6 16:07:42 jwaschke-notebook avahi-daemon[737]: Withdrawing address record for 192.168.178.23 on eth1.
Mar 6 16:07:42 jwaschke-notebook avahi-daemon[737]: Leaving mDNS multicast group on interface eth1.IPv4 with address 192.168.178.23.
Mar 6 16:07:42 jwaschke-notebook avahi-daemon[737]: Interface eth1.IPv4 no longer relevant for mDNS.
Mar 6 16:07:42 jwaschke-notebook wpa_supplicant[901]: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth0): now unmanaged
Mar 6 16:07:42 jwaschke-notebook avahi-daemon[737]: Withdrawing address record for fe80::212:f0ff:fe57:e659 on eth1.
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth0): device state change: 2 -> 1 (reason 37)
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth0): cleaning up...
Mar 6 16:07:42 jwaschke-notebook NetworkManager: <info> (eth0): taking down device.
Mar 6 16:07:42 jwaschke-notebook nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
Mar 6 16:08:16 jwaschke-notebook kernel: imklog 4.2.0, log source = /var/run/rsyslog/kmsg started.
Mar 6 16:08:16 jwaschke-notebook rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="707" x-info="http://www.rsyslog.com"] (re)start
Mar 6 16:08:16 jwaschke-notebook rsyslogd: rsyslogd's groupid changed to 102
Mar 6 16:08:16 jwaschke-notebook rsyslogd: rsyslogd's userid changed to 101
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpuset
Mar 6 16:08:16 jwaschke-notebook rsyslogd-2039: Could no open output file '/dev/xconsole' [try http://www.rsyslog.com/e/2039 ]
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Initializing cgroup subsys cpu
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Linux version 2.6.31-19-generic (buildd@palmer) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu8) ) #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 (Ubuntu 2.6.31-19.56-generic)
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] KERNEL supported cpus:
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Intel GenuineIntel
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] AMD AuthenticAMD
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] NSC Geode by NSC
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Cyrix CyrixInstead
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Centaur CentaurHauls
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Transmeta GenuineTMx86
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] Transmeta TransmetaCPU
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] UMC UMC UMC UMC
Mar 6 16:08:16 jwaschke-notebook kernel: [ 0.000000] BIOS-provided physical RAM map:


Die anderen syslog-Dateien haben keine Einträge von heute!!!

Danke und beste Grüße
Jürgen
D1Telekom
 
Beiträge: 6
Registriert: 06.01.2008 00:39

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru  Thema ist gelöst

Beitragvon D1Telekom » 06.03.2010 16:28

Ok, habe mich mal im ubuntu-Forum umgesehen und da bin ich nicht der einzigste:

http://forum.ubuntuusers.de/topic/ubunt ... st-2282599

Anscheinend ist das ein Bug der Ubuntu-Version 9.10, habe jetzt auch "Bildschirm abdunkeln" eingestellt unter "Laptopdeckel schliessen" und
siehe da => Es wird nur noch der Bildschirm dunkel wenn ich das Netzteil stecke.

Danke für Eure Unterstützung und beste Grüße
Jürgen
D1Telekom
 
Beiträge: 6
Registriert: 06.01.2008 00:39

Re: Ubuntu fährt beim anstecken des Netzteiles das System ru

Beitragvon hikaru » 06.03.2010 17:06

Es gibt einen Bugreport der ein ähnliches Problem beschreibt:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/70293

Hier wird der Rechner aber nur runtergefahren, wenn der Akku beim Einstecken des Netzteils fast entladen ist. Wenn ich dich richtig verstehe, ist das bei dir nicht der Fall, sondern das Notebook fährt runter unabhängig davon, wie der Akkuladestatus ist.

Falls das also ein neues Problem ist, solltest du einen Bugreport absetzen.

Edit:
Ich habe es gerade mal unter Debian getestet das sich weitgehend ähnlich verhält wie Ubuntu. Hier tritt das Problem nicht auf. Falls du einen Bugreport absetzen möchtest, ich verwende ein reines Debian Lenny in der Architektur amd64.
Benutzeravatar
hikaru
Moderator
 
Beiträge: 3761
Registriert: 25.10.2007 10:23
Notebook:
  • Asus EEE 901
  • Amilo Si 1520
  • Desktop (alt)


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste