amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Kein Bild : Inverter - Reparatur / - Manipulation

Darstellungsfehler, kein Bild auf dem Monitor, TV-Out,...

Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon notebucker » 06.09.2010 11:35

Gleich vorab: Der Titel ist evtl. irreführend, denn hier wird zwar ein NB, aber kein Inverter (IV) repariert. Dieser wird eher manipuliert.
Die Ausgangslage:
Das Display des NBs ist dunkel, das "Rest" des NBs funktioniert, d.h., das Bios greift auf die Hd zu, das OS (z.B. Windows) wird geladen, man sieht aber halt nichts. Ein externer Monitor zeigt ein normales Bild.
Die Untersuchung:
Die Messung der Eingangsspannungen des IV ergab, dass
- dessen Betriebsspannung (oft derjenigen des NTs - also z.B. 19 Volt entsprechend) anliegt,
- einer der beiden Steuereingänge (Ste) korrekt auf ca. 2,5 bis 3 Volt (dort ist mit einem Oszi ein Rechtecksignal zu beobachten) liegt,
- und der Zweite (Ste2) bei ca. 0,1 Volt.
Bei diesem Zweiten müßte irgendwas zwischen ca. 1,0 V bis 2,5 V zu messen sein. Das IV-Kabel ist in Ordnung, der Fehler liegt also irgendwo auf dem MB.
Der IV befindet sich quasi im betriebsbereiten Zustand, er ist allerdings über seinen Steuereingang nicht eingeschaltet.

Eine Reparatur auf dem MB ist Expertensache, meist wird ja doch gleich getauscht. Es gibt aber die Möglichkeit, das NB derart zu manipulieren, dass die fehlende Spannung an Ste2 künstlich erzeugt wird. Damit gäbe es wieder Licht, das NB ließe sich fast normal gebrauchen. Was nicht funktionieren wird, sind die Stromsparmechanismen, bei denen während des laufenden OS das Display dunkel geschaltet werden soll. Da mag sich jeder überlegen, ob er darauf ganz oder vorübergehend verzichten kann nach dem Motto: Hauptsache, ich kann erst mal wieder arbeiten.

Die Arbeit wurde an einem Inverter eines Acer-NBs ausgeführt. Da Inverter vom Prinzip her sich sehr gleichen, läßt sich das aber sehr gut übertragen auf andere NBs / Inverter. Evtl. Anpassungen sind natürlich möglich. Die eigentliche Manipulation besteht darin, am Ste2 dafür zu sorgen, dass er nicht "auf Masse gezogen wird". Beim Muster-Inverter wurde das Einschalt-Steuersignal (EStS) vom Pfostenstecker über die Leiterbahn zu einem 100 KO Widerstand (R) geführt. Dessen andere Seite war gleichzeitig verbunden direkt mit einem Eingang des Steuer-ICs auf der IV-Platine und einem weiteren 100 KO R , der auf Masse lag. Das EStS wurde also durch einen Spannungsteiler 1:1 geteilt, u gelangte dann auf das Steuer-IC. Im vorgefundenen Störfall fehlte das Eingangssignal, der Spannungsteiler lag fast auf Masse-Potential u schaltete damit das IC aus.

Die Manipulationen:
Sicherheitshalber habe ich als Erstes die Leiterbahn zwischen Ste2 u dem ersten 100 KO R durchtrennt. Die zweite Maßnahme war dann, vom Punkt der Spannungsteilung (STP) einen hochohmigen R nach Plus der Uv (19V) des IV-Boardes zu legen. Als Größe hatte ich 240 KO gewählt, die Werte "rechts oder links" würden auch passen. Damit erhöhte sich die Spannung zwar nur auf knapp 1 Volt, Messungen ergaben aber, dass bereits eine positive Spannung von 0,2 Volt am STP reichten, um das Display voll einzuschalten. Den R lötete ich am STP u am schaltungs-inneren Punkt der Eingangs-Sicherung an. Da ausreichend Platz im Displaydeckel war, habe ich auf einen SMD-R verzichtet. Die Anschlüsse des eingelöteten Rs müssen natürlich gegen Berührungen mit anderen Bauteilen geschützt werden, in meinem Fall erledigte das die unersetzliche Heißklebepistole. Das Bild zeigt noch den Status ohne Schutz.
Das Ergebnis: Das Ein- und Ausschalten des NBs und seiner Displaybeleuchtung war damit wieder einwandfrei möglich.
Als Nachtrag sei erwähnt, das ein solcher Eingriff in eine Schaltung nur durchgeführt werden sollte, wenn man über ordentliche elektronische Kenntnisse verfügt. Handwerkliche Fehler - etwa bei schlechter Isolierung - führen im einfachsten Fall zur Nichtfunktion oder dem Ableben einiger Bauteile, im ungünstigsten Fall zum Erzeugen eines heftigen Kurzschlusses im NB. Also immer Vorsicht am Elektron!
Gruß, notebucker
Dateianhänge
iv-schaltung.JPG
inverterrep.JPG
notebucker
Ehemaliger Moderator
 
Beiträge: 2197
Registriert: 22.01.2007 18:11
Notebook:

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon Tarzan » 06.09.2010 18:10

Super Bericht. Danke, echt cool was alles geht. 8)

I want more..... :wink: :mrgreen:
Tarzan
 
Beiträge: 227
Registriert: 08.12.2006 14:20

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon notebucker » 07.09.2010 18:01

@ Tarzan,
Tarzan hat geschrieben:I want more....

Da wird auch noch was kommen! Heute kamen erst noch zwei Nachträge, einer enthielt eine Warnung hinsichtlich möglicher Risiken, und dann habe ich noch einen handschriftlichen Schaltplan nachgefügt, der sagt Elektronikern mehr als 50 Worte. Es sei an dieser Stelle auch gesagt, dass ich dieses Rad zwar erfunden habe, aber nicht der erste war, welcher......... Vor gut einem Jahr berichtete schon mal ein User über eine solche Manipulation. Hoffentlich hatte übrigens keiner gemerkt, dass ich die Größe des eingefügten Widerstandes zuerst falsch angegeben hatte - schwitz ! :evil: Ist aber jetzt korrigiert.
Gruß, notebucker
notebucker
Ehemaliger Moderator
 
Beiträge: 2197
Registriert: 22.01.2007 18:11
Notebook:

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon rainer123 » 10.09.2010 19:36

Hallo,
hier ist offensichtlich ein Fachmann! Toll!!!
Ich hab genau dieses Problem! Hab aber 6 Kabel (Amilo pro v2040). Die äußeren beiden rechts und die äußeren beiden links sind aber spätestens auf dem Inverter verbunden.
Rechts 2 Rote, links 2 Schwarze! Also Saft(ca 18V) und Masse!
Bleiben die 2 in der Mitte. Gelb und blau! Gelb ist neben Schwarz.
Was ist nun das beschriebene Ein/Aus Steuersignalkabel. Laut messung kommt nichts!
Hab leider keinen oszi. kann also kein rechtecksignal messen.
Auf dem Inverter schaut es für mein beschränktes wissen aus als würden beide Anschlüsse bei einem ca 80 Ohm der andere an ca 130 Ohm Widerstand enden!
Mal sehen ob Ihr mir helfen könnt!
Super dass es Leute gibt die hier noch was wissen und nicht gleich alles wegschmeißen!
Hab nämlich schon 3 Inverter gekauft die alle nicht arbeiteten dachte ich. Hab dann doch an den defekt aller Inverter gezweifelt und dann diesen Foreneintrag gefunden. Gott sei dank.
Einstweilen vielen Dank für die Mühe
rainer123
rainer123
 
Beiträge: 6
Registriert: 17.09.2008 16:17

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon notebucker » 12.09.2010 17:43

@ rainer123,
habe deinen Beitrag erst jetzt gelesen.
Gleich vorweg: Hat dein NB eine austauschbare Graka? Werde später mal im Forum suchen, vorerst mal dieses:
Weder an der Farbe noch an den genannten R's kann man erkennen, welcher der beide Anschlüsse für die Helligkeitssteuerung und welcher für das Ein-u. Ausschalten ist.
rainer123 hat geschrieben:Laut messung kommt nichts!
An beiden A's ist nichts zu messen? Dann dürfte hier erstmal Schluß sein. Das getaktete Signal ist übrigens mit normalem Multimeter zu messen u muß, wie gesagt, ca. 2,5 Volt im Gleichspannungsbereich anzeigen. Das Ein-Ausschaltsignal läßt sich vergleichsweise einfach ersetzen, es hat ja einen statischen Pegel. Aber das andere Bedarf eines Rechtecksignals, und soweit habe ich noch nicht experimentiert, um dies auch zu ersetzen zu versuchen - infrage käme natürlich eine Oszillatorschaltung. Wenn beide Kabel ohne Signal sind, bleibt dir wohl nichts anderes, als das Inverterkabel zu kontrollieren, und auch den Pfostenstecker auf dem MB. Gerade letzterer sorgt auch schon mal für Kontaktprobleme. Du müßtest letztlich das I-Kabel am P-Stecker abziehen u dort alle Signale durchmessen, was schwierig wird, weil die Anschlüsse sehr dicht beieinander und die üblichen Meßspitzen der MMCs zu dick sind. Ums Verrecken - pardon - dort einen Kurzschluß vermeiden! Ist am P-Stecker ebenfalls festzustellen, dass beide Signale fehlen, ist Feierabend - falls die Graka nicht tauschbar ist.
Gruß, notebucker
notebucker
Ehemaliger Moderator
 
Beiträge: 2197
Registriert: 22.01.2007 18:11
Notebook:

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon rainer123 » 13.09.2010 16:17

Hallo notebucker,
danke erstmal für die Info! Muss am Stecker nochmal mit Ruhe messen. Kann wirklich Kontaktsache sein. Kabel ist i.O. Bin leider etwas ungeduldig. Evtl hab ich selbst das Rechtecksignal mal kurzgeschlossen mit 18V(Bin beim messen abgerutscht!). Dann wär es der Blaue. Bin nicht sicher! Brauche deshalb Ruhe und Zeit am Wochenende zum Testen der Kontakte am Mainboardstecker. Meld mich dann nochmal wenn ich mehr weis. Grafigkarte ist leider Onboard. Wir werden sehen!
tschau
rainer123
 
Beiträge: 6
Registriert: 17.09.2008 16:17

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon rainer123 » 19.09.2010 18:33

Hallo,
so jetzt bin ich schlauer: es kommt sowohl auf dem 3. als auch auf dem 4. Kontakt nichts zum IV. Über 2. Monitor kommt ein top Bild! Hab nen Bekannten der kümmert sich mit Frequenzgenerator etc.! Mal sehen was rauskommt! Meld mich nochmal wenn ich ne Lösung habe! War auf jeden fall alles sehr hilfreich hier. Danke nochmal. Gruß rainer123
rainer123
 
Beiträge: 6
Registriert: 17.09.2008 16:17

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon igordahume » 03.11.2010 15:42

Ich hätte mal eine Frage zu dem Thema.
Habe heute einen neuen Inverter bekommen und ihn gleich eingebaut. Das Bild geht auch wieder, jedoch werden die Farben nicht richtig wiedergegeben.
Ich hoffe ihr könnt mir weiterhelfen.

Bild
igordahume
 
Beiträge: 1
Registriert: 02.11.2010 16:41

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon trickster » 02.12.2010 13:12

Hi!

Ich glaube, in dieses Thema passt auch meine Problemlage. Auch bei meinem Amilo Si 1520 funktioniert das Hintergrundlicht nicht mehr. Ich habe bereits einen Invertertausch probiert und ein neues LCD eingebaut - ohne Erfolg. Wenn es demnach weder am Inverter noch an der Leuchtstoffröhre liegt, welche Möglichkeiten gibt es noch, die diese Symptomatik bedingen könnten und wie überprüfe ich diese? Ich hatte mir überlegt, vielleicht die Anschlüsse des Inverterkabels am Mainboard zu überprüfen. Dazu müsste ich wissen, wie ich am einfachsten da rankomme.

Ich freue mich über jeden Input. Ich bin auf den Laptop in meinem Studium ziemlich angewiesen, kann mir gerade keinen neuen leisten und hege auch die Hoffnung, dass da noch was geht.
trickster
 
Beiträge: 1
Registriert: 02.12.2010 12:17

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon Untertasse » 19.12.2010 19:28

Zunächst mal muss ich sagen das ich mit dem Notebook bisher immer sehr gut zufrieden war. Bis halt aufmal kein Bild mehr kam.
Auch bei mir ist es so das der Rechner wie gewohnt hochfährt, wenn mn ihn gegen das Licht hält mit dem Display kann man das sogar erkennen.

*edit* Es handelt sich um ein Amilo D 7830

Habt ihr vielleicht ein Foto, wo denn dieser Inverter liegen müsste?
Liegt das nicht an der Lampe hinter dem Bildschirm?
Ich müsste zudem sowas wie eine Explosionszeichnung haben. Weiss jemand wo ich diese bekommen kann? Möchte das gute Stück einfach nicht aufgeben :(

Vielen Dank für eure Bemühungen.
Untertasse
 
Beiträge: 1
Registriert: 19.12.2010 19:21

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon An-Dr.Zej » 19.12.2010 20:39

Der Inverter liegt am unteren Rand des Displays wenn man davor sitzt.
Bei YouTube gibt es sogar Videos wie man einen Inverter allgemein tauscht.
Benutzeravatar
An-Dr.Zej
Ehemaliger Moderator
 
Beiträge: 3565
Registriert: 26.07.2006 20:23

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon Discipulus » 06.03.2011 11:38

@notebucker: Erst mal meine Hochachtung vor der Anleitung und dem Wissen dahinter.
Vielleicht passt meine Frage hier gut hin:

Neben mir liegen zwei Displays für ein Amilo Pro V3505.

Beide zeigen ein schwaches "unbeleuchtetes" Bild. Habe bereits einen Inverter ausgetauscht - ohne Veränderung.
Doch ich habe mich bisher so arrangiert:
Über die Einstellungen zur Graphik habe ich unter Windows "Nur Monitor" angegeben und erhalte mein Bild über einen Externen.

Nur, wenn ich den Monitor versehentlich mal abklemme, dann "findet" das NB (oder wer auch immer da drin) den ext. Monitor "nicht mehr".
Da habe ich jetzt das Orig.Display angeschlossen, Lampe dahinter und dann erhielt ich ein Bild in geringerer Auflösung ("kleiner") und das Hintergrundbild war auch verschwunden; nach einem Neustart habe ich dann die Graphikeinstellungen wieder erneuert.

Nun möchte ich gerne eines der Displays wieder anschließen, bin aber nicht so ein Fachmann wie Du.
Komme ich mit dem Inverter-Trick weiter?
Oder soll ich nochmal ein neues Display besorgen?
Ich kann leider gar nix an irgendwelchen Ausgängen durchmessen, so dass ich keine Werte liefern kann.
Was kann ich tun?
Grüßle
Discipulus
 
Beiträge: 1
Registriert: 06.03.2011 11:19

Re: Kein Bild : Inverter - Reparatur / - Manipulation

Beitragvon chris25x9 » 15.04.2011 17:01

Hat schonmal jemand gemessen wieviel Strom für die Hintergrund beleuchtung rauskommt? wenn der IV funktioniert?
chris25x9
 
Beiträge: 9
Registriert: 04.04.2011 21:50


Zurück zu Grafik, Display

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron