amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Amilo M7440: SATA/AHCI mit XP und Windows 2003

Probleme mit der Festplatte, CD/DVD-Laufwerk, Firmware-Updates, USB-Sticks, Kartenleser...

Amilo M7440: SATA/AHCI mit XP und Windows 2003

Beitragvon stn021 » 01.01.2012 23:51

Hallo,

der Amilo M7440 hat eine 82801fbm SATA/AHCI-Controller, den man im BIOS wahlweise deaktivieren kann, sodaß Festplatten wie IDE-Platten aussehen. Wie kriegt man XP oder Windows 2003 zum booten von einer SATA-Festplatte im AHCI-Modus?

Wenn man AHCI im BIOS aktiviert, kriegt man mit Windows Server 2003 einen Bluescreen (mit XP ohne spezielle Treiber soweit ich weiß auch). Mit inaktiven AHCI funktioniert die Installation, aber dann läuft die Festplatte langsamer.


Bei fujitsu.com gibt es den "Intel Application Accelerator", der angeblich auch einen SATA-Treiber beinhaltet.

Bei intel.com gibts verschiedene Treiber für den 82801fbm-Controller, für F6-Disketteninstallation und "Intel (Matrix) Storage Manager".

Leider geht keiner davon, die Disketten für die "F6-Methode" beim Installieren ändern gar nichts und sämtliche nachträglich installierbaren oben genannten Treiber behaupten, daß die Hardware nicht geeignet ist oder daß der Computer nicht die "Minimalanforderungen" erfüllt. Was immer diese sein mögen :evil:

Wie installiert man den SATA/AHCI-Treiber und wo kann man den richtigen Treiber runterladen?

THX, stn
stn021
 
Beiträge: 41
Registriert: 09.06.2009 19:54
Notebook:

Re: Amilo M7440: SATA/AHCI mit XP und Windows 2003

Beitragvon stn021 » 05.01.2012 20:32

Das war ja einfach :(

Die ganze Sache ging um die Installation von Windows Home Server Version 1, weitgehend identisch mit Server 2003.

Das geht dann so: Man nimmt einfach eine Installations-DVD von WHS v1, ermittelt einfach Chipsatz und Chipsatzfamilie vom Amilo M 7440, stellt einfach fest, daß es bei fujitsu.com keinen passenden Treiber gibt, probiert einfach sämtliche halbwegs relevanten Treiber von intel.com aus, findet einfach heraus, wie man diese bei der Installation überhaupt verfügbar macht und wählt schließlich einfach einen Treiber aus, der für das o.g. Betriebssystem gar nicht vorgesehen ist.

Alles kein Problem :evil:

Im Amilo M7440 wird der 82801fbm von Intel als AHCI/SATA-Controller verwendet, Chipsatzfamilie ICH6.

Der korrekte Treiber hat den Dateinamen iata78_enu.exe (Englisches Windows) bzw oder iata78_cd.exe (alle anderen Sprachen), Version: 7.8.0.1012

Vorgesehen für: Windows Vista *, Windows Vista 32*, Windows Vista 64*, Windows XP Home Edition*, Windows XP Media Center Edition*, Windows XP Professional x64 Edition*, Windows XP Professional*,

also offensichtlich nicht für Windows Server 2003/Windows Home Server

Aktuell gibts den Treiber iata78_cd/_enu hier: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17296&lang=eng&OSVersion=%0A&DownloadType=

Falls der Link nicht mehr gültig sein sollte: http://downloadcenter.intel.com/, dann Suche nach "AHCI" oder "82801fbm" oder so ...

Der Treiber wird vor der Installation ausgepackt mit
Code: Alles auswählen
iata78_cd.exe -A -A -PC:\iata_78
Das geht mit XP, nicht mir Windows 7 (sry). Anschließend befinden sich die 32bit- und 64bit-Treiber im Ordner C:\iata_78.

Die Integration in die Installations-CD geht mit dem Programm nLite (http://www.nliteos.com/). Das ist recht einfach, kopiere die Windows-Installations-DVD in einen neuen Ordner auf der Festplatte und integriere den Treiber mit nLite's Menüsystem. Wähle in nLite den Treiber für 82801fbm oder einfach alle angebotenen Treiber. Anschließend mit nLite ISO erstellen und brennen (am besten auf R/W) und WHS installieren.

Anleitung für nLite z.B. hier: Integration eines SATA AHCI-Treibers in eine Windows XP Setup-CD - http://aps2.toshiba-tro.de/kb0/TSB85017Z0000R01DE.htm und an vielen anderen Stellen.
Zuletzt geändert von stn021 am 09.01.2012 03:45, insgesamt 1-mal geändert.
stn021
 
Beiträge: 41
Registriert: 09.06.2009 19:54
Notebook:

Re: Amilo M7440: SATA/AHCI mit XP und Windows 2003

Beitragvon stn021 » 09.01.2012 03:33

OK, das mit iata78_cd.exe funzt tatsächlich. Auch mit XP.

Allerdings nur bei der Installation. Wenn man iata78_cd.exe auf ein installieres XP anwendet (im IDE-Modus), kriegt man eine Meldung in der Art von "nicht erfüllte Mindesvoraussetzungen". Auch der "Application Accelerator", der zu den Amilo-Treibern gehört (support.ts.fujitsu.com), geht nicht. Andere Fehlermeldung, selbes Ergebnis.

Lösung: Da muss man einfach :roll: nur einen Treiber von Dell verwenden, nämlich ftp://ftp.us.dell.com/SATA/R130118.EXE Dann Computer im AHCI-Modus neu starten und läuft. Das würde auch bedeuten, daß man so um die Integration des Treibers in die Installations-CD herumkommt, zumindest bei XP. Unklar, ob das auch mit Windows Home Server / Server 2003 geht.

Irritierend:
* Danach läuft der Notebook nur noch im AHCI-Modus, nicht mehr im angeblich "kompatiblen" IDE-Modus
* Dann kann man dann auch wieder iata78_cd installieren, ohne Fehlermeldung. (Das ist natürlich völlig überflüssig, aber interessant)

Das kapier mal einer :?
stn021
 
Beiträge: 41
Registriert: 09.06.2009 19:54
Notebook:


Zurück zu Laufwerke: Festplatte, DVD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste