amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Kill Switch beim Amilo M7440 lösen

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Kill Switch beim Amilo M7440 lösen

Beitragvon Jinidog » 14.10.2005 20:51

Hallo,

ich versuche jetzt seit zwei Tagen, mit meinem neuen Laptop WLAN zu benutzen.
Ich denke, dass es nicht funktioniert, weil ich den Kill Switch nicht gelöst bekomme.
Darüber beschwert sich auch das ipw2200 Modul.

ipw2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.


Der Laptop hat eine Taste, die das erledigen soll (zumindest entnehme ich das dem Benutzerhandbuch).
Nur scheint das ein Softwareswitch zu sein, den Linux erstmal nicht kennt.
Wenn ich auf den Knopf drücke meldet der Kernel:

atkbd.c: Unknown key released (translated set 2, code 0x6d on isa0060/serio0).
atkbd.c: Use 'setkeycodes 6d <keycode>' to make it known.


Ich finde nirgendwo Infos darüber und bein ein kleines bisschen am Verzweifeln.
Ich hoffe, es weiß jemand Rat.
Jinidog
 
Beiträge: 15
Registriert: 11.10.2005 08:13

Beitragvon aspettl » 14.10.2005 21:04

Dass der ACPI-Code empfangen wird ist schonmal gut. Linux muss darauf also nur noch reagieren.
Was für eine Distribution verwendest du?

Probiere mal, ob das folgende Skript eine Auswirkung hat, könnte sein, dass dies WLAN aktiviert (allerdings ohne LED):
Code: Alles auswählen
#!/bin/bash
for DEVICE in /sys/class/net/*; do
   if [ -d $DEVICE/wireless ]; then
      echo -n 0 > $DEVICE/device/power/state;
   fi
done

Kastriertes Skript aus: http://de.wikibooks.org/wiki/Asus_W3N-K ... ndertasten

Falls das geht, müsste man es beim Start nur noch automatisch ausführen lassen bzw. das Original mit dem ACPI-Event verknüpfen.

Falls es nicht geht:
Es gibt ein Tool acer_hk, vielleicht geht das bei dir.

Noch eine andere Möglichkeit;
Im Windows WLAN aktivieren und neu starten, ist es dann noch aktiv?

Noch etwas anders:
Vielleicht gibt es im BIOS eine Option, dass es sofort aktiv ist?

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7182
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon Jinidog » 14.10.2005 21:21

Ich benutze Gentoo.

Das Script funktioniert so nicht, zumindest habe ich jetzt ein Verzeichnis in sys gefunden, in dem ich ein bisschen suchen kann.

Acer_hk werde ich mal probieren.

Windows habe ich gleich am Anfang gelöscht, werde es wohl mal neuinstallieren müssen und prüfen, ob man da durch die beiliegenden Herstellertools irgendwie Zugriff auf das ganze bekommt.

Über das BIOS hat man keine Kontrolle.
(die BIOS-Optionen sind sowieso ziemlich mau)
Jinidog
 
Beiträge: 15
Registriert: 11.10.2005 08:13

Beitragvon Jinidog » 14.10.2005 21:23

Das acerhk Modul lässt sich nicht laden.

modprobe acerhk poll=1
FATAL: Error inserting acerhk (/lib/modules/2.6.13-gentoo-r3/extra/acerhk.ko): Cannot allocate memory


Komischer Fehler.
Jinidog
 
Beiträge: 15
Registriert: 11.10.2005 08:13

Beitragvon aspettl » 14.10.2005 22:58

Scheinbar ist das normal beim M7440 - siehe auch hier:
http://www.linuxquestions.org/questions/history/364047

Wahrscheinlich klappt das mit dem Modul "fsam7400" dann auch nicht.

Ich bin da jetzt auch ratlos.
Vielleicht könnte jemand anders mit einem M7440 und Linux etwas dazu sagen? (z.B. ob es geht, wenn man vorher in Windows WLAN aktiviert hat?)

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7182
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon thorlinux » 15.10.2005 08:17

hast du das hier schon gelesen?
http://fsam7440.sourceforge.net/fhome/index.html

sollte bei dir ja auch gehen.
deshalb koennen Pinguine nicht fliegen: Was nicht fliegt, kann auch nicht abstuerzen
Benutzeravatar
thorlinux
 
Beiträge: 44
Registriert: 13.03.2005 20:00
Wohnort: Braunschweig

Beitragvon aspettl » 15.10.2005 10:03

Super, das ist es. Ich habe es gleich beim Linux-Treiber-Thread eingefügt.

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7182
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon Jinidog » 15.10.2005 17:25

Okay, diesen Post schreibe ich gerade über das WLAN.
Das 7440 Modul hat funktioniert, ich hatte vorher mal ein 7400 Modul probiert und das hat nicht funktioniert.
Habe schon ein passendes Ebuild und werde das gleich mal bei bugs.gentoo.de posten.

Danke für die Hilfe.
Jinidog
 
Beiträge: 15
Registriert: 11.10.2005 08:13


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste