amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Amilo M1437G + Debian (Etch) - (fast) lauffähig

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Amilo M1437G + Debian (Etch) - (fast) lauffähig

Beitragvon gem » 01.12.2005 09:06

Hallo zusammen,

hier meine Erfahrung mit dem o.g. Amilo und Debian:

Mit der "Debian Sarge" Installations-CD hatte ich bzgl. der SATA-Erkennung keinen Erfolg, daher habe ich mir von

http://www.debian.org/devel/debian-installer/

das Netzwerkinstallations-CD-Image (100 MB) der Debian Etch Beta 1 heruntergeladen und es damit versucht.

Ich habe vor der Installation die WLAN-Karte ausgeschaltet, da ich kein Risiko eingehen wollte (was sich vielleicht als Fehler herausstellt, komme ich noch dazu) und nur die LAN-Verbindung genutzt. Man braucht logischerweise eine funktionierende Internet-Verbindung für die Installation, wie folgt:

Eingabe beim Bootprompt:
Code: Alles auswählen
expert

(weiß nicht ob nötig, da diese Version standardmässig den Kernel 2.6 installiert, aber mit Expert hat man mehr Möglichkeiten Einstellungen vorzunehmen)

Danach die üblichen Eingaben, bei der Paketauswahl habe nur das Paket zum Auswählen eines Mirrors angewählt.

Erkennung der Festplatte:
Zunächst wird keine Festplatte erkannt, allerdings kommt eine Auflistung mit Modulen, die nachgeladen werden können, hier hat bei mir die Auswahl der
Code: Alles auswählen
sd_mod
und
Code: Alles auswählen
sata_via

zum erfolgreichen Erkennen der Festplatte geführt.

Bei der Auswahl im Menu "Grundsystem installieren" habe ich
Code: Alles auswählen
linux-image-2.6.12-1-386
gewählt.

Beim ersten Booten war der Start des GDM bzw. X-Servers nicht erfolgreich, da hier die ATI-Treiber (noch?) nicht funktionieren, lässt sich damit beheben, dass man sich als root anmeldet und die Datei
Code: Alles auswählen
/etc/X11/xorg.conf
editiert.
Da ich weder den VI bedienen kann noch will, habe ich mir dazu einfach per
Code: Alles auswählen
apt-get install mc
den MidnightCommander installiert und das damit gemacht.
Man ersetzt einfach "ati" durch "vesa", speichert die Datei und startet den gdm mit
Code: Alles auswählen
/etc/init.d/gdm restart
neu.
(Sieht zunächst zwar so aus, als ob sich die Grafik aufgehängt hätte, aber dann kommt der Anmeldebildschirm).

Ich habe mir davor noch mit
Code: Alles auswählen
apt-get install kde-core
KDE geholt, aber das ist ja Geschmackssache.

Soweit also relativ unkompliziert und es funktioniert.

Problem(e):
    * die WLAN-Karte wird nachträglich nicht richtig erkannt, werde die Linux-Treiber noch austesten und hoffen, dass es dann funktioniert
    * Obwohl ich die Auflösung 1200x800 in der xorg.conf angegeben habe, wird sie mir nicht angeboten. Aber ich habe die ATI-Treiber auch noch nicht installiert
    * Über die Stabilität von Debian Etch kann ich nichts sagen, wie man daraus ein Sarge macht, weiss ich auch (noch?) nicht


Hab heute leider keine Zeit, großartig weiter daran zu basteln, aber vielleicht hilft es ja dem ein oder anderen.
Über Anregungen bin ich selbstverständlich dankbar.

PS: Ich hab bewusst den neuen Thread eröffnet, da es zu Debian m.E. noch keine "richtige" Lösung gab, sonst bitte einfach verschieben, danke.
gem
 
Beiträge: 2
Registriert: 29.11.2005 16:31

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron