amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

[V2030] Lüftersteuerung unter Linux [SOLVED]

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

[V2030] Lüftersteuerung unter Linux [SOLVED]

Beitragvon nurbs999 » 11.12.2005 23:16

Hi !

Ich habe ein AMILO PRO V2030 und hab ein kleines Problem. Der Lüfter läuft immer auf ca. 80% seiner Leistung.
Unter Windows wird der Lüfter automatisch auf die CPU-Temp abgestimmt und ich würde ihn gerne auch unter Linux regeln lassen.
Ich hab einige Foren durchstöbert und leider nichts gefunden.

Kann mir vielleicht hier jemand ein paar Tips geben??

Besten Dank im Vorraus
nurbs999
Zuletzt geändert von aspettl am 11.12.2005 23:16, insgesamt 1-mal geändert.
Grund: aspettl: Verschoben nach "Linux".
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon ElPolloDelDiablo » 12.12.2005 00:05

Das Gerät hat einen Celeron M, oder?

ACPI funktioniert schon so nicht richtig bei vielen Notebooks. Schätze, dass bei den Celerons das noch deutlich schlimmer ist (die Celeron Ms sind afaik so schnell wie die Pentium Ms, ihnen fehlen aber bestimmte Energiespareigenschaften). Windows schafft es irgendwie, da drum herumzuarbeiten; die Logik jedoch besagt, dass Du die Umdrehungszahlen benötigst, also am Besten nicht daran herumfummelst.

Btw., welche Linux-Version hast Du? Und welche Distribution? Evtl. ist eines von beidem etwas veraltet, dann könnte ein Update helfen.
AMILO Pro V2000:
Pentium M 705 (Banias), 512 MB RAM, Intel 855GM Chipsatz
Primäres OS: Xubuntu (6.06)
Benutzeravatar
ElPolloDelDiablo
 
Beiträge: 30
Registriert: 24.10.2005 12:25

Beitragvon nurbs999 » 12.12.2005 00:13

danke erstmal für deine antwort und hier meine auf deine fragen:

proz: celeron M 1.4GHz
gentoo linux
2.6.14 kernel
acpi installiert und der deamon läuft
system ist up2date :wink:

wegen den lüfter drehzahlen:
das ist kein problem die herauszufinden. also wenn du ein tutorial hast -> ich bin gerne bereit configs umzuschreiben...etc :wink:
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon aspettl » 12.12.2005 00:19

Läuft cpufreq? (Geht das mit einem Celeron - ich denke ja, nur natürlich nicht so gut wie bei einem Pentium M.)

Die Lüfterdrehzahlen kann man meines Wissens nicht auslesen oder direkt beeinflussen.

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Amilo M1420

Beitragvon nurbs999 » 12.12.2005 00:28

wie schon geschrieben, es ist Celeron M.
Die Celerons lassen sich nich runtertakten, deshalb läuft auch cpufreq nicht.
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon ElPolloDelDiablo » 12.12.2005 12:56

Das große Problem ist eben das BIOS; für ACPI muss das OS mit ihm zusammenarbeiten (normaler Weise). Wenn das BIOS einige Macken hat kann es zu seltsamen Effekten kommen. Lösungsansätze gibt es, wie man ja sehr schnell sieht, wenn man sich einen Kernel baut. Aber mehr als Ansätze sind es eben nicht. Vielleicht wirst Du eine Lösung mit dem Release des 2.6.20 haben - in einigen zig Monaten ^^

Ansonsten: existiert vielleicht ein BIOS-Update?
AMILO Pro V2000:
Pentium M 705 (Banias), 512 MB RAM, Intel 855GM Chipsatz
Primäres OS: Xubuntu (6.06)
Benutzeravatar
ElPolloDelDiablo
 
Beiträge: 30
Registriert: 24.10.2005 12:25

Beitragvon nurbs999 » 12.12.2005 23:07

ein Bios update half auch nich :( leider
was ich nur etwas komisch finde ist, dass nun mal unter windows geht.
kann man denn nich mit ndiswrapper einen "lüfter-treiber" installieren?
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon ElPolloDelDiablo » 13.12.2005 13:26

*g* NdisWrapper hat ja nur die Schnittstellen für WLAN, nicht für Lüfter.

Windows umgeht oft einfach Einstellungen im BIOS, also ist ein Vergleich nicht so einfach anwendbar.
AMILO Pro V2000:
Pentium M 705 (Banias), 512 MB RAM, Intel 855GM Chipsatz
Primäres OS: Xubuntu (6.06)
Benutzeravatar
ElPolloDelDiablo
 
Beiträge: 30
Registriert: 24.10.2005 12:25

Beitragvon nurbs999 » 13.12.2005 17:13

also, alles selber machen?? ;)

hat denn jemand erfahrung im programmieren von treibern unter linux?
auch büchertips sind gerne gesehen ;)
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon ElPolloDelDiablo » 13.12.2005 23:09

Wenn das so einfach wäre gäbe es diese Treiber längst für alle Notebooks ;-)
AMILO Pro V2000:
Pentium M 705 (Banias), 512 MB RAM, Intel 855GM Chipsatz
Primäres OS: Xubuntu (6.06)
Benutzeravatar
ElPolloDelDiablo
 
Beiträge: 30
Registriert: 24.10.2005 12:25

Beitragvon mauli » 17.12.2005 10:16

Hallo,

hatte das gleiche Problem mit meinem 7440G (SuSE 9.3)
Folgender Eintrag

echo -n 0 > /proc/acpi/fan/FAN1/state
echo -n 0 > /proc/acpi/fan/FAN2/state
echo -n 3 > /proc/acpi/fan/FAN1/state
echo -n 3 > /proc/acpi/fan/FAN2/state

in die boot.local hat geholfen.

Laut Bold funktioniert es auch bei einem V2010, sollte also auch bei Dir gehen.


Gruß Mauli
mauli
 
Beiträge: 5
Registriert: 01.10.2005 22:01

Beitragvon nurbs999 » 18.12.2005 21:31

@mauli:

erstmal danke für deinen tip, ich hab aber dabei 2 probeme:
1. in meinem dateisystem gibt es keine boot.local
2. echo -n 0 > /proc/acpi/fan/FAN/state und echo -n 3 > /proc/.../state hat keine wirkung; der lüfter dreht weiter fröhlich vor sich hin
also würde auch ein eintrag in die boot.local nichts bewirken, oder??
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon nurbs999 » 19.12.2005 03:45

@ElPolloDelDiablo

so schwer ist das wohl doch nicht :wink:
hab meine DSDT gefixt und etwas umgeschrieben, weil: was in DSDT fehlt sind die einträge was der ACPI-controller machen soll wenn man in /proc/.../FAN werte übergibt.
Was noch nicht funktioniert ist, dass man den lüfter ganz abschalten kann, er läuft nunmal sehr langsam; besser als nicht also :wink:

eine genaue beschreibung folgt noch.

P.S. Falls jemand mit meinem Tutorial was anfang kann, bitte posten
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon nurbs999 » 19.12.2005 13:56

So, hier nun ein kleines Tutorial:

Als erstes, macht euch von allem was ihr verändert ein backup!

http://forums.gentoo.org/viewtopic.php?t=122145 Hier findet ihr ein Tutorial um eure DSDT zu fixen.

Nach dem eure DSDT keine Errors und Warrings hat, sucht ihr in eurer dsdt.dsl (diese Datei wird beim decompilieren erstellt; wie man das macht wird in dem Link oben zum fixen der DSDT erklärt)
den Eintrag (bei mir in der Zeile 2507) :

Code: Alles auswählen
Device (FAN)
                {
                    Name (_HID, EisaId ("PNP0C0B"))
                    Name (_PSC, 0x00)


In dieser Sektion habt ihr auch die Einträge

Code: Alles auswählen
                    Method (_PS0, 0, NotSerialized)
                    {
                    }
         
                    Method (_PS3, 0, NotSerialized)
                    {
                    }


Wie man hier sieht, weiß der ACPI chip nicht, was er machen soll, wenn in die Datei /proc/acpi/fan/FAN/state per "echo 3 > state" oder "echo 0 > state".
Also schreiben wir hier rein, was passieren soll. Zusätzlich schreiben wir aber noch 2 andere Methoden, damit der Lüfter nicht nur 2 Geschwindigkeiten "kennt".

Code: Alles auswählen
                    Method (_PS0, 0, NotSerialized)
                    {
                        SFAN (0x00)
                    }
         
                    Method (_PS1, 0, NotSerialized)
                    {
                        SFAN (0x01)
                    }
         
                    Method (_PS2, 0, NotSerialized)
                    {
                        SFAN (0x02)
                    }

                    Method (_PS3, 0, NotSerialized)
                    {
                        SFAN (0x03)
                    }


Dannach müssen wir unsere DADT noch compilieren und
1. entweder die DSDT in den kernel einkompilieren
2. die DSDT beim booten laden lassen (per initrd)

Beide Wege die DSDT zu benutzen werden auch in dem Tutorial (der link oben) erklärt.

Nach dem erfolgreichen booten kann der Lüfter wie folgt eingestellt werden:
Code: Alles auswählen
echo 1 > /proc/acpi/fan/FAN/state

Dies läßt den Lüfter relatic langsam drehen
Code: Alles auswählen
echo 2 > /proc/acpi/fan/FAN/state

Die nächst höhere Stufe
Code: Alles auswählen
echo 3 > /proc/acpi/fan/FAN/state

Fullspeed ;)

Was noch nicht funktioniert ist, den Lüfter aus zu schalten. Ich hoffe, dass das auch noch gelöst wird.

Ich wünsch euch viel Erfolg :)
nurbs999
 
Beiträge: 37
Registriert: 11.12.2005 20:47

Beitragvon Slayer » 03.01.2006 17:23

Hi nurbs999,

habe mit Interesse dein Posting zur Lüftersteuerung des V2030 gelesen.

Bin deiner Beschreibung gefolgt und habe die DSDT entsprechend geändert. Es funktioniert alles so, wie du es beschrieben hast.

Leider ist der Lüfter nicht ganz auszukriegen. Ist SFAN dafür vielleicht nicht die richtige Methode? Mir ist aufgefallen, dass es noch ein Device PFAN gibt, aber wofür das sein soll, konnte ich noch nicht herausfinden. Wird immer als off angegeben, egal was ich reinpipe.

Falls du es mittlerweile hinbekommen hast, den Lüfter ganz auszuschalten, so würde ich mich freuen, wenn du das hier nochmal posten könntest, denn das ewige gesumme des Lüfters geht einem dann doch irgendwann auf die Nerven...
Slayer
 
Beiträge: 7
Registriert: 02.01.2006 13:54
Notebook:

Nächste

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron