amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Gentoo Linux on 1437G (ALSA problems) [SOLVED]

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Gentoo Linux on 1437G (ALSA problems) [SOLVED]

Beitragvon front243 » 20.12.2005 13:30

Hi, first of all sorry for writing in English but my german is very bad :)

I have a problem with Gentoo linux on my new Amilo 1437G, I have no sound with alsa.

OSS works fine , and I get sound with cp /dev/urandom > /dev/dsp

But when I try to use alsa I get errors:

Code: Alles auswählen
thomas@localhost ~ $ aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm_direct.c:900:(snd_pcm_direct_initialize_slave) unable to install hw params
ALSA lib pcm_dmix.c:831:(snd_pcm_dmix_open) unable to initialize slave
aplay: main:544: audio open error: Inappropriate ioctl for device


Does anybody know what my setting should be, perhaps I could get a copy of somebodys .config file for the kernel?

edit: I solved it by playing around with modules.conf, suddenly aplay worked :P
front243
 
Beiträge: 1
Registriert: 20.12.2005 13:25

Beitragvon nodh » 20.12.2005 21:50

Wanna post your modules.conf?
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste