amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

M3438G ACPI problems in KDE

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

M3438G ACPI problems in KDE

Beitragvon wu-hsin » 21.12.2005 20:27

Hello.

First I must apologize for posting in English, and also for not using search to see if someone has already solved this problem. But I don't understand German, so I have no choice. (This forum is really the best place in the net to ask for help.)

I have an Amilo M3438G, which is an absolutely wonderful "little" thing. :) I have Source Mage GNU/Linux 0.9.5 installed with KDE 3.5.
(If you don't know what Source Mage is, don't worry, it's not that important. Basically it's like Linux From Scratch, but with brilliant scripting that make compiling and managing easy to handle. But as I said it's not important, because I've already tried Kubuntu 5.10 and had the same problems with that distribution.)

The problem is that ACPI seems to be sending conflicting messages to the system apparently very randomly.
When I have the power cable attached, KDE's battery module sometimes shows that it is attached, sometimes it shows that it's running on battery, and sometimes it thinks that it's running on an empty battery.
It really doesn't bother me that the battery logo in the panel keeps changing. But that's not the whole story. The computer might be on for more than an hour, then it suddenly flashes a warning message on the screen claiming that the battery's empty (although the machine is plugged to the wall), and then the monitor goes black for a moment and KDE restarts (it goes back to the login screen).
When I had Kubuntu installed I had the same problem, but then it didn't restart KDE, it just completely froze. The monitor went black and absolutely nothing happened, although the computer was on. This also happened at random intervals.

Without KDE I have the same problem, although in console mode it doesn't matter because console doesn't restart because of ACPI battery messages (I wonder why KDE does).
I have a program called acpi installed that shows the current battery state (whether it's plugged or not and how many % of battery power is left). Usually when I type 'acpi' it gives the correct answer, but sometimes it claims that the cable is unplugged although it's not, and sometimes it doesn't get any kind of info from the ACPI.

Because of these things I am certain that the fault is in the computer's ACPI, not in KDE (although KDE is responsible for restarting every time it thinks the battery is dead). The ACPI seems to be having trouble expressing its thoughts coherently, so to speak.

I tried the iASL compiler to see if there is a bug in the DSDT table. I found three warnings but no errors. And I didn't find information on the net on how to fix those warnings.
I tried some ugly hacks and compiled the kernel with the external DSDT table, but that didn't solve anything. If there is anyone here who understands AML and wants to try fixing those warnings, I'm happy to tell more about them.

Does anyone know of a solution to these problems? What have you done with your M3438G's to get ACPI and battery support working without trouble?
If nothing else works, I can just recompile the kernel without ACPI battery support. That would of course free me of my worries, but on the other hand then I wouldn't know how much battery I have left. :(

I would be more than happy for any help!
Thanks and a merry Christmas from Finland. :)
wu-hsin
 
Beiträge: 1
Registriert: 21.12.2005 19:46

Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste