amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Schnellstarttasten unter Linux

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Schnellstarttasten unter Linux

Beitragvon Vengeance » 29.12.2005 13:54

Ich habe zu meinem Problem noch nichts Passendes hier im Forum gefunden, deshalb mache ich einfach mal ein neues Thema dazu auf.
Hat es jemand schon hinbekommen, die Schnellstarttasten für WLAN, Browser und Silent Mode bei einem Amilo A1650 unter Linux zum Laufen zu kriegen? Bei mir funktionieren die Tasten nicht trotz Software-Schalter "acer_acpi" oder "acerhk". Mir würde es reichen, wenn die Tasten Keycodes ausgeben würden (mit dem Programm xev lassen sich die Dinger anzeigen), die ich dann zum Ausführen von selbstgeschrieben Scripts verwenden kann, aber die Tasten geben keine Codes aus. Gibt es da irgendeine Lösung oder andere Software-Schalter, die ich testen kann oder die gar funktionieren? Ich verwende OpenSUSE 10.0.
Es gibt drei Dinge, die ich mir nicht wirklich merken kann:
Buchstaben, Zahlen......... und das Dritte habe ich schon wieder vergessen.
Vengeance
 
Beiträge: 18
Registriert: 27.12.2005 13:52
Wohnort: Hünfeld

Beitragvon ChaosKrieger » 03.01.2006 16:37

läuft bei dir acpid?

führ mal "acpi_listen" in der konsole aus, drücke deine sonder-tasten und schau ob irgendwas erscheint

so sollte das aussehen:

chaos@chaos:~$ acpi_listen
processor CPU1 00000080 00000009
processor CPU1 00000080 00000009
processor CPU1 00000080 00000009
processor CPU1 00000080 00000006
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon kluon » 04.01.2006 03:08

Habe ein M1424 aber das Grundgerüst müsste eigentlich das selbe sein.
Da ich auch OpenSUSE 10.0 hab häng ich mich hier mal mit dran.
Bei mir sieht das ganze so aus:

kluon@linux:~> acpi_listen
processor CPU! 00000080 00000009
processor CPU! 00000080 00000003

Nur das drücken der Silent Mode Taste funktioniert (auch korrekt).
Ein drücken der Mail/Internet Tasten hat keinerlei Effekt auf die Ausgabe.
kluon
 

Beitragvon ChaosKrieger » 04.01.2006 12:07

das ist korrekt, der silent mode wird über acpi gesteuert, die zusatz tasten (mail , internet) sind ganz normale tastatur eingaben (wie die fernbedienung übrigens auch)

einstellen kann man das ganze bei den "Tastenkompinationen" weis nicht ob suse so ein menu hat.. aber wer sucht wirds finden ;)
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon Vengeance » 05.01.2006 15:45

ChaosKrieger hat geschrieben:das ist korrekt, der silent mode wird über acpi gesteuert, die zusatz tasten (mail , internet) sind ganz normale tastatur eingaben (wie die fernbedienung übrigens auch)

einstellen kann man das ganze bei den "Tastenkompinationen" weis nicht ob suse so ein menu hat.. aber wer sucht wirds finden ;)


Nun ja, wenn es einfache Tastatureingaben wäre, bräuchte man auch keinen Softwareschalter, um die WLAN-Antenne zum Laufen zu kriegen. ACPID läuft bei mir, was dabei angezeigt wird, poste ich später. Was muss ich denn machen, wenn bei mir eine solche Ausgabe angezeigt wird?
Es gibt drei Dinge, die ich mir nicht wirklich merken kann:
Buchstaben, Zahlen......... und das Dritte habe ich schon wieder vergessen.
Vengeance
 
Beiträge: 18
Registriert: 27.12.2005 13:52
Wohnort: Hünfeld

Beitragvon Vengeance » 07.01.2006 16:20

Der Befehl "acpi_listen" zeigt bei mir keine Ausgabe an, wenn ich die Tasten drücke. Das Programm "acpid" läuft bei mir. Gibt es vielleicht noch andere Programme, mit denen man den Sondertasten unter Linux auf die Spur kommen kann?
Es gibt drei Dinge, die ich mir nicht wirklich merken kann:
Buchstaben, Zahlen......... und das Dritte habe ich schon wieder vergessen.
Vengeance
 
Beiträge: 18
Registriert: 27.12.2005 13:52
Wohnort: Hünfeld

Beitragvon aspettl » 07.01.2006 17:59

acpi_listen ist für ACPI-Events
xev ist für Events mit normalem Keycode
Mehr kenne ich auch nicht - wäre aber auch an mehr interessiert, meine Zusatztasten am Lifebook gehen unter Linux nicht...

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Lifebook E8020D
  • Amilo M1420

Beitragvon Vengeance » 08.01.2006 01:42

Xev hat bei mir auch keine Wirkung gezeigt. Das System muss die Tasten überhaupt erst einmal orten und das tut es nicht. Ich vermute sogar, dass das Problem der Kernel ist. Ich werde mir den aktuellen Kernel 2.6.15 runterladen und kompilieren. Ich hoffe, dass es damit funktioniert. Im Changelog wird auch ein Problem beschrieben, dass Fehler im ACPI System speziell für Notebooks behebt. Hat denn niemand noch eine mögliche Lösung?
Es gibt drei Dinge, die ich mir nicht wirklich merken kann:
Buchstaben, Zahlen......... und das Dritte habe ich schon wieder vergessen.
Vengeance
 
Beiträge: 18
Registriert: 27.12.2005 13:52
Wohnort: Hünfeld

Beitragvon kuschelganxta » 13.02.2006 12:21

Probier mal
Code: Alles auswählen
cat /dev/input/event0

wobei event0 deine interne Tastatur sein sollte. Wenn da irgendwelche Zeichen kommen, wenn du die Taste drückst, weißt du zumindest, dass dein System davon was mitbekommt. ACPI-Tasten liefern dort keinen Input.

Gruß
Sascha
Benutzeravatar
kuschelganxta
 
Beiträge: 87
Registriert: 28.01.2006 21:00
Notebook:
  • FSC Amilo M6453G

Beitragvon Vengeance » 03.03.2007 18:25

Ich habe gute Nachrichten. Im Zusammenhang mit OpenSUSE 10.2 funktionieren die Zusatztasten mit acerhk am Amilo A1650. Die Taste für den Browser startet gleich Konqueror, die Tasten für WLAN und Silent-Mode erzeugen Codes, aber haben noch keine Funktion. Nach der acerhk-FAQ soll man die Codes zusammen mit den entsprechenden Buttons an Olaf Tauber schicken, nur da gibts ein Problem. Seine acerhk-Seite bei der Uni Berlin gibt es nicht mehr. Wie könnte man das noch lösen?

Mar 3 18:18:44 judicator kernel: acerhk: translated acer key code 0x30 to no key
Mar 3 18:18:46 judicator kernel: acerhk: received key code 0x6e
Mar 3 18:18:46 judicator kernel: acerhk: translated acer key code 0x6e to no key
Mar 3 18:18:49 judicator kernel: acerhk: received key code 0x6e

Das ist die Kernelausgabe von acerhk, wenn man das Modul mit verbose=4 startet. Der Keycode 0x30 stammt vom WLAN-Button, 0x6e vom Silent-Mode-Button.
Es gibt drei Dinge, die ich mir nicht wirklich merken kann:
Buchstaben, Zahlen......... und das Dritte habe ich schon wieder vergessen.
Vengeance
 
Beiträge: 18
Registriert: 27.12.2005 13:52
Wohnort: Hünfeld

Beitragvon aspettl » 03.03.2007 20:43

Ich denke das ist die aktuelle Homepage:
http://www.cakey.de/acerhk/

Gruß
Aaron
Vor dem Erstellen neuer Themen bitte die Suchfunktion benutzen und Forenregeln lesen!
Bitte trage dein Notebook mit den technischen Daten im Profil ein.
Benutzeravatar
aspettl
Administrator
 
Beiträge: 7181
Registriert: 15.11.2004 12:46
Notebook:
  • Lifebook E8020D


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste