amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

amilo v2030: yenta / cardbus problem [solved]

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

amilo v2030: yenta / cardbus problem [solved]

Beitragvon frank_v2030 » 14.01.2006 16:52

Hi,

ich habe das Problem eine 32Bit Cardbus Karte unter Linux auf meinem Fujitsu-Siemens Amilo Pro v2030 zum Laufen zu bringen. Genauer: die Option Qualcomm 3G CDMA (GT 3G Quad), von Eplus die Notebookcard II. Das ganze scheitert am modprobe von yenta_socket:


Jan 14 15:37:52 xxx PCI: Found IRQ 10 for device 0000:00:0c.0
Jan 14 15:37:52 xxx PCI: Sharing IRQ 10 with 0000:00:0f.1
Jan 14 15:37:52 xxx PCI: Sharing IRQ 10 with 0000:00:10.0
Jan 14 15:37:52 xxx PCI: Sharing IRQ 10 with 0000:00:10.1
Jan 14 15:37:52 xxx PCI: Sharing IRQ 10 with 0000:00:12.0
Jan 14 15:37:52 xxx Yenta: CardBus bridge found at 0000:00:0c.0 [1734:109b]
Jan 14 15:37:52 xxx Yenta: Enabling burst memory read transactions
Jan 14 15:37:52 xxx Yenta: Using CSCINT to route CSC interrupts to PCI
Jan 14 15:37:52 xxx Yenta: Routing CardBus interrupts to PCI
Jan 14 15:37:52 xxx Yenta TI: socket 0000:00:0c.0, mfunc 0x01ac1b22, devctl 0x64
Jan 14 15:37:52 xxx Yenta TI: socket 0000:00:0c.0 probing PCI interrupt failed, trying to fix
Jan 14 15:37:52 xxx Yenta TI: socket 0000:00:0c.0 no PCI interrupts. Fish. Please report.
Jan 14 15:37:52 xxx Yenta: no PCI IRQ, CardBus support disabled for this socket.
Jan 14 15:37:52 xxx Yenta: check your BIOS CardBus, BIOS IRQ or ACPI settings.
Jan 14 15:37:52 xxx Yenta: ISA IRQ mask 0x08d8, PCI irq 0
Jan 14 15:37:52 xxx Socket status: 30000820
Jan 14 15:37:53 xxx cs: pcmcia_socket0: cardbus cards are not supported.

Hat jemand von euch yenta auf einem v2030 zum Laufen bekommen? Auf meinem anderen Notebook (Acer 290lmi) klappt es ohne Probleme. Ich mache die ACPI Probleme (boot option pci=noacpi) dafür verantwortlich. Habe schon einiges ausprobiert mem reserve, irqfixup etc. nichts bisher geholfen.

knoppix 4 bootet, yenta socket findet und aktiviert die Karte, es muss also gehen. Ich konnte bisher nicht nachvollziehen wie knoppix die Probleme löst. Weiß jemand wie man bei knoppix die bootparameter sehen kann? Was er also alles an den kernel übergibt?

Hoffe jemand hat ein paar Tipps für mich oder eine Howto yenta zum Laufen zu bringen auf einem v2030. :-)

Grüße
Frank
Zuletzt geändert von frank_v2030 am 16.01.2006 14:34, insgesamt 1-mal geändert.
frank_v2030
 
Beiträge: 3
Registriert: 14.01.2006 16:09

Beitragvon ChaosKrieger » 15.01.2006 12:46

boote knoppix, und vergleich mal die module, hat knoppix nen eigenen grub? weis garnicht mehr.. /boot/grub/menu.lst sollte es die datei geben, schau dir die boot parameter an (zwecks acpi)

ansonnsten gibts natürlich noch die lösung acpi komplett von knoppix zu übernehmen, aber dazu frag bitte dr. google ;)

edit: welche distri nutzt du?
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep; shutdown -r now
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Beitragvon frank_v2030 » 15.01.2006 16:40

Hi,

danke für deine Antwort.

ChaosKrieger hat geschrieben:boote knoppix, und vergleich mal die module, hat knoppix nen eigenen grub? weis garnicht mehr.. /boot/grub/menu.lst sollte es die datei geben, schau dir die boot parameter an (zwecks acpi)

ansonnsten gibts natürlich noch die lösung acpi komplett von knoppix zu übernehmen, aber dazu frag bitte dr. google ;)

edit: welche distri nutzt du?


Hatte ich vergessen, benutze gentoo. Kernel 2.6.15. Das gleiche System läuft auch auf einem Acer Travelmate 290lmi, wo das alles geht. Es muss also am 2030 liegen.

Die Kernel Bootparameter habe ich rausgefunden kann man auch per dmesg ablesen (dmesg | grep Kernel). Habe sie aber auch auf der knoppix dvd gefunden (/boot/isolinux/isolinux.cfg). Leider hat es nicht weitergeholfen, da steht nix besonders zu acpi. Lediglich ramdisk_size=10000 init/etc/init lang=de apm=power_off vga=791 initrd=minirt.gz nomce quiet BOOT_IMAGE=knoppix. Habe damit probiert, zeigt keine Wirkung. Ich vermute, dass Knoppix acpi komplett als module gebaut hat. Das werde ich jetzt auch machen und mal sehen ob ich damit weiterkomme. Wie du gemeint hast, von Knoppix die Eintellungen und Reihenfolge weitgehend übernehmen.

Grüße
Frank
frank_v2030
 
Beiträge: 3
Registriert: 14.01.2006 16:09

Re: amilo v2030: yenta / cardbus problem

Beitragvon frank_v2030 » 16.01.2006 14:34

Hi,

das Problem ist gelöst. Hatte das Problem, dass irgendwas in den shared-memory Bereich der onboard-Grafikkarte geschrieben hat. Eventuell hatte das etwas damit zu tun, dass ich die Broadcom Mini-PCI Wlan Karte getauscht habe.

Es kam beim Booten gang am Anfang folgende Meldung, die mir erst bei genauem hinsehen des Bootvorgangs aufgefallen ist:

Code: Alles auswählen
PCI: Failed to allocate mem resource #6: 10000@f4000000 for 0000:01:00.0


lspci | grep 01:00

ergab dann die Grafikkarte:

Code: Alles auswählen
01:00.0 VGA compatible controller: VIA Technologies, Inc. Unknown device 3344 (rev 01)


Nach dieser http://averatecforums.com/showthread.php?t=2014&page=2 kann man den Speicherbereich mit der reserve=Startadresse,Länge reservieren. Der shared memory der Grafikkarte liegt am Ende des Hauptspeichers. Also 256MB - 64MB ist Startadresse und 64MB ist die Länge. Das ergibt:

Code: Alles auswählen
reserve=0xC000000,0x4000000


Das in den Bootparameter und schon war der Fehler verschwunden. Ich habe dann noch mal den Kernel neu gebaut (.config komplett gelöscht) und jetzt tut alles (ACPI geht, Yenta geht) sogar ohne die pci=noacpi Option.

Grüße
Frank
frank_v2030
 
Beiträge: 3
Registriert: 14.01.2006 16:09

Beitragvon ChaosKrieger » 16.01.2006 17:47

und deshalb liebe ich linux ;)

gut das du es noch "auf"-gelöst hast.. ;)
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep; shutdown -r now
Benutzeravatar
ChaosKrieger
Ehemaliger Moderator
 
Beiträge: 418
Registriert: 03.01.2006 13:51
Wohnort: Bühl-Baden
Notebook:
  • Amilo M 1439G

Re: amilo v2030: yenta / cardbus problem

Beitragvon mherweg » 05.07.2006 10:47

frank_v2030 hat geschrieben:Ich habe dann noch mal den Kernel neu gebaut (.config komplett gelöscht) und jetzt tut alles (ACPI geht, Yenta geht) sogar ohne die pci=noacpi Option.


kannst du bitte deine kenel-config hier posten oder an mich mailen ?

ich habe es mit

reserve=0x1f000000,0x1000000

versucht (512MB RAM, Grafik im BIOS auf 16MB gestellt)
leider bisher ohne Erfolg
mherweg
 
Beiträge: 1
Registriert: 05.07.2006 10:40


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron