amilo-forum.de

Inoffizielles Forum rund um die Notebooks der Amilo- und Lifebook-Serien von Fujitsu

Erfahrungsaustausch Linux auf M1425

Alle Fragen, die sich speziell um Linux oder andere Unix-ähnliche Betriebssysteme drehen.

Erfahrungsaustausch Linux auf M1425

Beitragvon amilist » 02.12.2004 22:32

hi,
ich habe ein amilo m1425 und suse 9.2 installiert. eigentlich läuft alles problemlos ohne grosses rumfummeln (auch 1280x800), allerdings mit einer einschränkung: 3d geht definitiv nicht. der suse-radeon-treiber kann das mit dem grafikchip (RV350NP M10) nicht und der ati-linux treiber kann nur xfree, aber kein xorg.

dazu hätte ich 2 fragen (leider antwortet ati nicht auf meine mails...):

- hat jemand 3d unter linux zum laufen gekriegt? wäre schon schade, eine moderne grafikkarte mit 128mb nur beim internetsurfen "auszureizen"...

- die bezeichnung des grafikchips mit RV350NP M10 (ausgabe von lspci) macht mich grübeln: laut ati-webseite hat die mobility radeon 9700 einen M11 chip. der M10 steckt in der mr9600. auf meiner amilo-verpackung steht mr9700. ist das einfach etikettenschwindel oder kann lspci die (modernere) mr9700 einfach nicht erkennen? meines wissens nach liest lspci nur aus, was in der hardware als ID eingebrannt ist.

hat jemand einen tipp?
amilist
 
Beiträge: 17
Registriert: 02.12.2004 20:10

Beitragvon nodh » 03.12.2004 21:43

Die Radeon 9700 mobile ist nichts anderes als eine 9600 mit wenigen zusätzlichen Features und höherem Takt. Unter Windows seh ich sie zB als Radeon 9600/9700. Aber was draufsteht, sollte schon drin sein ;)

Huch, Suse verwendet auch schon X.Org? Ja, dann gibts Probleme mit X.Org, ATI und Kernel 2.6. Soweit ich weiß versprach ATI Besserung mit den Treibern und wird bald einen herausbringen der auf der Basis der Catalyst-Treiber für Windows arbeitet.
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630

Beitragvon amilist » 06.12.2004 21:54

Vielen Dank für die Antwort. Ich hab mich mal weiter umgeschaut und bin mittlerweile hierdrauf gestossen:

http://gatos.sourceforge.net/
http://www.gmpf.de/index.php/Main_Page
http://utah-glx.sourceforge.net/

Und der ATI-Treiber soll sogar schon in der übernächsten Version im Labor laufen. Schaun mer mal, dann sehn mer scho ;-)

Zum Thema Radeon 9600/9700: irgendwie scheint ATI gezielt Verwirrung um die Modellbezeichnungen zu stiften. Es gibt 9700 mit M10 und mit M11. Und ein RV350 ist die lahmere Variante des R350. Die RV350NP jedoch soll flotter sein als die blanke RV350. "Respekt!" an die Marketingabteilung - das schafft Transparenz und Vertrauen :evil: Für Linux ist eh NVidia die erste Wahl - ich weiss auch nicht, was mich beim Kauf geritten hat.... irgendwo habe ich einen Thread von einem PC-Techniker gelesen, der sprach von 45% Rücklaufquote beim Amilo. Und die BIOS-Batterie soll fest verlötet sein, der Austausch kostet angeblich 600.-?. Haltbarkeit ca. 1,5-2 Jahre.....

Ja, SuSe verwendet X.org, wie mittlerweile wohl die meisten grossen Distros.
Zuletzt geändert von amilist am 07.12.2004 07:37, insgesamt 1-mal geändert.
amilist
 
Beiträge: 17
Registriert: 02.12.2004 20:10

Beitragvon nodh » 06.12.2004 22:39

Das mit der BIOS-Batterie wurde eh schon hier im Forum schon mal angesprochen.
Ja, das mit 9600m, 9700m und 9800m hat ATI nicht gut getroffen, weil die 9700m eben nur eine verbesserte 9600m ist und die 9800m wieder eine ganz andere Generation ist.
Ich hätte auch lieber eine NV-Grafikkarte im Laptop, aber finde mal einen Laptop mit halbwegs guter NV-Karte drin :roll:
mfg nodh
nodh
Ehemaliger Moderator
 
Beiträge: 600
Registriert: 21.11.2004 15:38
Wohnort: Österreich
Notebook:
  • Amilo A 1630

Beitragvon pfleidi85 » 23.12.2004 15:02

Gibt es eine Möglichkeit das Amilo mit voller 3D unterstützung zum laufen zu bringen??
Ich benutze gerade Slackware 10.0 mit Kernel 2.6.9 und X.Org. So ähnlich wir die Konfiguration auch beim Notebook aussehen.
pfleidi85
 
Beiträge: 2
Registriert: 23.12.2004 14:55

Beitragvon amilist » 23.12.2004 15:21

Hi,
angeblich soll der x.org-Treiber (incl. 3D) von ATI im Dezember erscheinen, auf der ATI-Seite ist aber bis jetzt nichts zu finden. Also abwarten. Im Falle von Suse gibt es für die 9.1 (xfree) ein rpm mit dem customized ATI-Treiber, vielleicht gibt es sowas ja auch bei Slackware. Wo wir schon bei Slackware sind: nach der Übernahme von Suse durch Novell suche ich gerade eine alternative Distribution. Ist Slackware eine Empfehlung? Ich bin ein ziemlicher Newbie und freue mich sehr über umkomplizierte Konfigurationstools. Bei Suse funktionieren ACPI, Suspend to disk, bluetoothnetzwerk mit meinem Win-PC usw. out of the box. Wie sieht das bei Slackware aus?

Gruß
Amilist

PS: Ich habe mein M1425 gerade zum Service geschickt (Tastaturklappern, Brennerprobs, kleinere Verarbeitungsmängel). Bei Interesse kann ich gerne einen Erfahrungsbericht posten.
amilist
 
Beiträge: 17
Registriert: 02.12.2004 20:10

Beitragvon pfleidi85 » 23.12.2004 15:34

Naja unkomplizierte Konfigurationstools ist ein dehnbarer begriff. Hier mal ein paar punkte zu Slackware:

Slackware GNU/Linux (9.1)
-> eine der ältesten Distributionen ( seit 1993 )
-> Eigenes Paketsystem ( tgz )
-> Für Einsteiger nicht so geeignet, umso besser für lesewillige Fortgeschrittene die sehr viele Anpassungsmöglichkeiten haben wollen

+ sehr aktueller Stand ( speziell mit slackware-current )
+ sehr schlank
+ sehr nahe an den Standards, bei Fragen kann deshalb oftmals sehr schnell geholfen werden ( keine distributionsspezifischen Änderungen )
+ optimale Kontrolle über das System
+ das System ist extrem anpassbar an die eigenen Bedürfnisse
+ Dropline Gnome ( muss extra heruntergeladen werden, updatet sich regelmäßig über das Internet auf die aktuellste Version )
+ gutes Paketmanagement, rpm auch parallel nutzbar
+ fast keine grafischen Konfigurationstools die dazwischenfunken könnten und stören, wenn man die Arbeit auf der Kommandozeile gewöhnt ist ein riesiger Vorteil

- keine grafischen Konfgurationstools ( im Bezug auf Einsteiger und Bequeme ein Nachteil ), vieles muss "von Hand" erledigt werden
- nur bedingt für Einsteiger geeignet (keine Partitionsresizer, d.h. will man Windows und Linux parallel betreiben so muss man zuvor mit einem anderen Tool Platz frei machen, keine "hübsche grafische Installation")
- schnelle Internetanbindung speziell zu Beginn empfehlenswert ( z.B. für Softwarepakete, die 2 CDs beinhalten nur die grundlegenden Programme )
- Englischkenntnisse so gut wie unabdingbar (ob das ein Nachteil ist darüber lässt sich streiten)

Quelle: http://www.linuxforen.de/forums/showthread.php?t=117571

Aber nun mal zum Treiber zurück. Ich werde mir das Notebook wahrscheinlich im Januar zulegen. Dann dürfte also in absehbarer Zeit ein vernünftiger Treiber verfügbar sein?
pfleidi85
 
Beiträge: 2
Registriert: 23.12.2004 14:55

Beitragvon amilist » 24.12.2004 10:18

Alles klar! Herzlichen Dank für die erhellende Antwort. Ich bleib dann erst mal bei Novell/Suse bis sie mich mit ihrer Firmenpolitik endgültig sauer gefahren haben und bemühe mich in dieser Zeit verstärkt um die Kommandozeile. Falls ich da Fortschritte mache, kümmere ich mich dann mal um Gentoo.

Zum Treiber-Thema: wenn Du fit bist (klingt so :-)), findest Du auf den links in meinem anderen Post Anleitungen, wie Du die Treiber für x.org lauffähig machst. Selber übersetzen, Symlinks manuell ändern usw. Ich persönlich machs wie der Altkanzler: Aussitzen!! Und wenn ATI schon von Dezember spricht, dann kann man ja mal im Januar bei ati.com schauen, vielleicht haben sie sich ja bis dahin erbarmt.

Frohe Weihnachten!

PS: Habe Montag nachmittag beim FSC-Support angerufen, Dienstag mittag stand der Abholservice vor der Tür. Ein guter Anfang!
amilist
 
Beiträge: 17
Registriert: 02.12.2004 20:10

Beitragvon TomPie » 22.04.2005 08:42

Hi,

der Treiber von ATI funktioniert prinzipiell schon. Ich hatte ihn auf meinem Amilo M1424 bereits mit 3D unterstützung laufen. Das Problem mit dem ATI Treiber ist das er die ID der Karte (1002:4e52) nicht erkennt und deshalb das Kernel-Modul seinen Dienst verweigert. Habe den Treiber dann disassembliert und konnte die Stelle mit den PCI IDs finden und meine hinzufügen. Das Kernel Modul hat dann schonmal geladen. Dem Xorg Treiber könnte man zwar auch die PCI ID des Grafikchips per Hexeditor beibringen jedoch ist dies nicht nötig da man mit der Konfigurationsdirektive "ChipID" in der xorg.conf die ID für den Treiber ändern kann.

Die Performance war aber alles andere als befriedigend. Ich hatte zuvor ein Toshiba Notebook mit Geforce 4 420GO mit 32MB und die Radeon aus dem Amilo war nur etwa 30% schneller als die alte Geforce :roll:

Ich würde einfach mal eine Mail an ATI schicken warum die PCI ID nicht im Treiber drin ist. Denn das ist alles was fehlt. Lustigerweise wird die Karte vom xorg-Treiber sogar als 9700SE erkannt wenn man ihm keine Falsche ChipID vorgaukelt. Das erlaubt dann aber keine 3D-Beschleunigung.

ciao,

Tom
TomPie
 
Beiträge: 2
Registriert: 21.04.2005 15:22


Zurück zu Linux / Unix / BSD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste